Как сравнить три ячейки в excel

Сравнение данных 3-х ячеек и вывод данных в 4-ую

Всем доброго времени суток! люди добрый помогите плиз составить расчет.
Пр: в 3 ячейках существуют числа.
A1=7; B1=4; C1=11
в D1 необходимо поставить условие таким образом,
чтоб при "A1 C1; A1>B1 A1 B1 и A1>C1" в D1 подставлялась ‘3’.

как составить 1 формулу с соблюдением всех параметров?

P.S. Я себе уже все волосы вырвал

Помощь в написании контрольных, курсовых и дипломных работ здесь.

Сравнение ячеек данных Stringgrid и ячейками данных Access
Помогите пожалуйста! Как сравнивать данные ячеек стринггрида и данные базы аксесс типа стринг, и.

Сравнение данных в двух textarea и вывод данных
Добрый день! Возникла такая проблема, сразу скажу что в javascript слабо разбираюсь В 2.

Сравнение данных из ячеек DataGridView на двух разных формах
Есть 2 формы, на одной есть DataGridView и на второй — DataGridView. Нужно сравнить данные из.

Сравнение (поиск) ячеек из столбца и копирование к ним дополнительных данных
Добрый день! У меня к сожалению пока посредственные знания VBA, но я уже примерно попытался.

Сообщение было отмечено alyaska213 как решение

Решение

Вложения

для форума.xlsx (9.0 Кб, 10 просмотров)

Сообщение от tam_tam
Вложения

для форума (9).xlsx (9.2 Кб, 8 просмотров)

Добрый день!
Абсолютно такая же проблема, но требующая решения через код VBA.
Имеется три столбца с набором данных, информацию требуется выводить в четвертый столбец.

Необходимо:
1. Если текст в ячейке столбца A совпадает с текстом в ячейке столбца B, а в соседней ячейке столбца С есть текст, то выводить в соседнюю ячейку столбца D "текст 1";
2. Если текст в ячейке столбца A совпадает с текстом в ячейке столбца B, а в соседней ячейке столбца С НЕТ текста, то выводить в соседнюю ячейку столбца D "текст 2";
3. Если текст в ячейке столбца A НЕ совпадает с текстом в ячейке столбца B, а в соседней ячейке столбца С есть текст, то выводить в соседнюю ячейку столбца D "текст 3";
4. Если текст в ячейке столбца A НЕ совпадает с текстом в ячейке столбца B, а в соседней ячейке столбца С НЕТ текста, то выводить в соседнюю ячейку столбца D "текст 4".

Буду очень признателен за помощь.
Спасибо

Как сравнить текст в ячейках таблицы Excel

Часто перед пользователями табличного редактора Эксель стоит такая задачка, как сравнение текста в ячейках таблички. Существует несколько способов реализации этой процедуры. В статье мы детально рассмотрим каждый из способов, позволяющий реализовать сравнение текстовой информации в ячейках таблички.

Сравнение двух ячеек в табличном редакторе

В табличном редакторе имеется два различных метода, позволяющих сравнить текстовую информацию в ячейках. Методы отличаются друг от друга тем, что один учитывает регистр, а второй – нет

Применение специальной формулы без учета регистра

Самый простейший вариант сравнения текста в 2-х ячейках без учета регистра – это применение символа «=» между координатами ячеек. Пример формулы: =А1=В1.

Важно! А1 и В1 являются элементами сравнения. В результате, в ячейке с формулой выведется либо значение ЛОЖЬ, либо значение ИСТИНА.

Если пользователь желает в виде результата отобразить уникальные сообщения, говорящие о наличие соответствий в ячейках, то дополнительно в формулу необходимо добавить оператор «ЕСЛИ». Простой пример такой формулы: =ЕСЛИ(А2=В2; “Совпадает”; “НЕ совпадает”).

На нижеприведенной картинке прекрасно видно, как две рассмотренные формулы справляются с процедурой сравнения текстовой информации в ячейках.

kak-sravnit-tekst-v-yachejkah-tablicy-excel

1

Применение специальной формулы с учетом регистра

Часто при работе с документами случаются такие моменты, когда необходимо не просто произвести сравнение текстовой информации, но и учесть регистр. Для реализации этой несложной процедуры применятся специальный оператор «СОВПАД». В английской вариации он имеет наименование «EXACT». Общий вид формулы выглядит так: =СОВПАД(текст1; текст2). Аргументы текст1 и текст2 – это координаты ячеек, в которых будет производиться сравнение текстовой информации.

К примеру, данные для сравнения располагаются в полях, имеющих координаты А1 и В1. В этом случае, применяемая формула будет выглядеть так: =СОВПАД(А1; В1). Значение ИСТИНА будет отображено в том случае, если регистр каждого знака будет совпадать. В иных случаях отобразится значение ЛОЖЬ.

Внимание! Если пользователь желает в виде результата отобразить уникальные сообщения, говорящие о наличие соответствий в ячейках, то дополнительно в формулу необходимо добавить оператор «ЕСЛИ».

Простой пример такой формулы: =ЕСЛИ(СОВПАД(A1; B1); “Совпадает”; “НЕ совпадает”). На нижеприведенной картинке прекрасно видно, как две рассмотренные формулы справляются с процедурой сравнения текстовой информации в ячейках с учетом регистра.

kak-sravnit-tekst-v-yachejkah-tablicy-excel

2

Сравнение нескольких ячеек в табличном редакторе

Теперь поговорим детально о том, как произвести сравнение текстовой информации более, чем в двух ячейках. Эти методы практически идентичны тем, что были рассмотрены выше.

Применение специальной формулы без учета регистра для нескольких ячеек

Здесь, как и в ранее рассмотренных методах, применяется две вариации формулы:

  1. Первый вариант формулы выглядит так: =И(А1=В1; А1=С1).
  2. Второй вариант формулы выглядит так: =ЕСЛИ(И(А1=В1; А1=С1); “Совпадает”; “НЕ совпадает”).

Функция «И» реализует возврат значения ИСТИНА в том случае, если все поля таблички имеют совпадающие значения. Возврат значения ЛОЖЬ происходит, если какое-либо из значений не совпадает. Оператор «ЕСЛИ» позволяет отобразить на экране те показатели, которые ввел пользователь в формулу.

На нижеприведенной картинке прекрасно видно, как две рассмотренные формулы справляются с процедурой сравнения не только текстовой информации, но и с числовыми показателями, а также с данными формата «Дата».

kak-sravnit-tekst-v-yachejkah-tablicy-excel

3

Применение специальной формулы с учетом регистра для нескольких ячеек

Здесь, как и в ранее рассмотренных методах, применяется две вариации формулы:

  1. Первый вариант формулы выглядит так: =И(СОВПАД(А1;В1); СОВПАД(А1; С2)).
  2. Второй вариант формулы выглядит так: =ЕСЛИ(И(СОВПАД(А1;В1);СОВПАД(А1; С1));”Точное совпадение”; “НЕ совпадает”).

Как и в предыдущем примере, функция «И» реализует возврат значения ИСТИНА в том случае, если все поля таблички имеют совпадающие значения. Возврат значения ЛОЖЬ происходит, если какое-либо из значений не совпадает. Оператор «ЕСЛИ» позволяет отобразить на экране те показатели, которые ввел пользователь в формулу. Результат преобразований выглядит так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

4

Если пользователю необходимо, чтобы формула вывела наличие соответствий хотя бы 2-х показателей, то ему необходимо использовать следующую формулу: =ЕСЛИ(ИЛИ(СОВПАД(А1;В1);СОВПАД(А1; С1);СОВПАД(В1;С1)); “Не менее двух точных соответствий”; “Соответствий нет”). Иными словами, в этом случае наличие хотя бы 2-х соответствий в 3-х случаях, выведет положительное значение. Результат преобразований выглядит так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

5

Если же пользователю необходимо произвести сравнение в табличке, в которой присутствует огромное количество ячеек, то вышеописанная формула будет не удобной в использовании, так как она станет слишком длинной. Здесь целесообразнее использовать математический оператор «СЧЕТЕСЛИ». Подсчитать количество соответствий в большом диапазоне ячеек можно при помощи следующей формулы: <=СЧЕТЕСЛИ(А2:D2;А2:D2)>. Результат преобразований выглядит так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

6

Стоит отметить! Очень важно следить за количеством ненужных пробелов в ячейках. Дело в том, что если в ячейке присутствует пробел, то он будет восприниматься табличным редактором как символ. Поэтому перед использованием формул необходимо убедиться в том, что в ячейках отсутствуют ненужные пробелы.

Заключение

Мы выяснили, что в табличном редакторе Эксель существует огромное количество методов, позволяющих реализовать сравнение текстовой информации в ячейках. Мы узнали, что можно сравнивать информацию с учетом регистра и без учета. Для реализации этой процедуры великолепно подходит такой оператор, как «СОВПАД». Дополнительно для более сложных процедур применяются такие функции, как «И», «ИЛИ», «ЕСЛИ» И «СЧЕТЕСЛИ».

Ссылка на основную публикацию