Как сделать пустую ячейку в excel вместо 0 или ошибки

Как сделать пустую ячейку в excel вместо 0 или ошибки

1. У формуле : =ЕСЛИ(ИНДЕКС(Лист1!$A$1:$N$21;СТРОКА();СТОЛБЕЦ())=0;"";ИНДЕКС(Лист1!$A$1:$N$21;СТРОКА();СТОЛБЕЦ())) вот эти вот двойные кавычки : ;""; и убирают нолик.

2. Варианты AndreTM вопросов не возникает, и так все понятно. Но если можно поясните в чем заключается странность переноса данныхс помощью этой формулы. И что вы предлагаете взамен. Если знаете, то приведите, пожалуйста формулу, для переноса данных из закрытой книги, которая находится в той же папке, что и орегинал.. Очень нужно.

3. Эта формула : =ВПР(B3;Лист1!$B$3:$C$15;2;0) Может быть и лучше, но она вместо ноликов, выдает #Н/Д. Но это уже другая тема.
Можно просто отключить отображение нулей — меню Сервис-Параметры-Нулевые_значения. Об этом я знаю давно.

4. А вот здесь Формат ячейки — Число — Все форматы , как я понял, нужно в ячейки с этими формулами вставить еще и формат типа # ##0,00;-# ##0,00;;@. Проверил на практике – срабатывает.

Скрытие в EXCEL ошибки в ячейке

history 25 апреля 2013 г.
    Группы статей

  • Значение Пустой текст ("")
  • Поиск и исправление ошибок в формулах
  • Пользовательский формат
  • Условное форматирование

Иногда требуется скрыть в ячейке значения ошибки: #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? Сделаем это несколькими способами.

Пользовательский формат

Пользовательский формат вводим через диалоговое окно Формат ячеек (см. файл примера ).

  • для вызова окна Формат ячеек нажмите CTRL+1 ;
  • выберите (все форматы).
  • в поле Тип введите формат [Черный]Основной
  • нажмите ОК
  • цвет шрифта ячейки установите таким же как и ее фон (обычно белый)

На рисунке ниже пользовательский формат применен к ячейкам А6 и B6 . Как видно, на значения, которые не являются ошибкой, форматирование не повлияло.

Применение вышеуказанного формата не влияет на вычисления. В Строке формул , по-прежнему, будет отображаться формула, хотя в ячейке ничего не будет отображаться.

Условное форматирование

Используя Условное форматирование , также можно добиться такого же результата.

  • выделите интересующий диапазон;
  • в меню выберите Главная/ Стили/ Условное форматирование/ Создать правило. );
  • в появившемся окне выберите Форматировать только ячейки, которые содержат ;
  • в выпадающем списке выберите Ошибки (см. рисунок ниже);
  • выберите пользовательский формат (белый цвет шрифта);

Теперь ошибочные значения отображаются белым шрифтом и не видны на стандартном белом фоне. Если фон поменять, то ошибки станут снова видны. Даже если просто выделить диапазон, то ошибки будут слегка видны.

Значение Пустой текст ("")

Замечательным свойством значения Пустой текст является, то что оно не отображается в ячейке (например, введите формулу ="" ). Записав, например, в ячейке А14 формулу =ЕСЛИОШИБКА(1/0;"") получим пустую ячейку А14 .

Ссылка на основную публикацию