Как сделать кроссворд в excel с макросами

Создание кроссворда в программе Microsoft Excel

Кроссворд в Microsoft Excel

Многие люди любят разгадывать кроссворды, есть так же лица, которым нравится их составлять. Иногда, составить кроссворд требуется не просто ради развлечения, а, например, чтобы проверить знания учащихся нестандартным способом. Но, мало кто догадывается, что отличным инструментом для создания кроссвордов является программа Microsoft Excel. И, действительно, ячейки на листе данного приложения, как будто специально предназначены для того, чтобы вписывать туда буквы отгадываемых слов. Давайте выясним, как быстро составить кроссворд в программе Microsoft Excel.

Создание кроссворда

Прежде всего, нужно найти готовый кроссворд, с которого вы будете делать копию в программе Excel, или же продумать структуру кроссворда, если вы будете придумывать его полностью сами.

Для кроссворда нужны квадратные ячейки, а не прямоугольные, как по умолчанию в Microsoft Excel. Нам нужно изменить их форму. Для этого, на клавиатуре нажимаем комбинацию клавиш Ctrl+A. Этим мы выделяем весь лист. Затем, кликаем правой кнопкой мыши, чем вызываем контекстное меню. В нём кликаем по пункту «Высота строки».

Высота строки в Microsoft Excel

Открывается небольшое окошко, в котором нужно задать высоту строки. Устанавливаем значение 18. Жмем на кнопку «OK».

Установка высоты строки в Microsoft Excel

Чтобы изменить ширину, кликаем по панели с наименованием столбцов, и в появившемся меню выбираем пункт «Ширина столбца…».

Переход к изменению ширины столбца в Microsoft Excel

Как и в предыдущем случае, появляется окошко, в которое нужно внести данные. На этот раз это будет число 3. Жмем на кнопку «OK».

Ширина столбца в Microsoft Excel

Далее, следует подсчитать число клеточек для букв в кроссворде в горизонтальном и вертикальном направлении. Выделяем соответствующее количество ячеек на листе Excel. Находясь во вкладке «Главная», кликаем по кнопке «Граница», которая расположена на ленте в блоке инструментов «Шрифт». В появившемся меню, выбираем пункт «Все границы».

Установка границ в Microsoft Excel

Как видим, границы, очерчивающие наш кроссворд, установлены.

Установлены границы в Microsoft Excel

Теперь, следует удалить эти границы в некоторых местах, чтобы кроссворд принял нужный для нас вид. Это можно сделать при помощи такого инструмента, как «Очистить», значок запуска которого имеет форму ластика, и находится в блоке инструментов «Редактирование» всё той же вкладки «Главная». Выделяем границы ячеек, которые хотим стереть и кликаем на данную кнопку.

Кнопка очистить в Microsoft Excel

Таким образом, постепенно прорисовываем наш кроссворд, поочередно удаляя границы, и получаем готовый результат.

Кроссворд нарисован в Microsoft Excel

Для наглядности, в нашем случае, можно выделить горизонтальную строку кроссворда другим цветом, например желтым, воспользовавшись для этого кнопкой «Цвет заливки» на ленте.

Заливка желтым цветом в Microsoft Excel

Далее, проставляем номера вопросов на кроссворде. Лучше всего, это делать не слишком большим шрифтом. В нашем случае, использован шрифт 8.

Номера кроссворда в Microsoft Excel

Для того, чтобы разместить сами вопросы, можно кликнуть любую область ячеек в стороне от кроссворда, и нажать на кнопку «Объединить ячейки», которая находится на ленте всё на той же вкладке в блоке инструментов «Выравнивание».

Далее, в большой объединенной ячейке можно пропечатать, или скопировать туда вопросы кроссворда.

Вопросы кроссворда в Microsoft Excel

Собственно, сам кроссворд на этом готов. Его можно распечатывать, или разгадывать прямо в Экселе.

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Таблица с результатами в Microsoft Excel

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

Вызов мастера функций в Microsoft Excel

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Мастер функций в Microsoft Excel

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Переход к выбору ячейки в Microsoft Excel

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Выбор диапазона ячеек в Microsoft Excel

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Данные введены в Microsoft Excel

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Функция СТРОЧН в Microsoft Excel

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Функция ЕСЛИ в Microsoft Excel

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Автосумма в Microsoft Excel

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Ответ на кроссворд в Microsoft Excel

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

Мы рады, что смогли помочь Вам в решении проблемы.

Помимо этой статьи, на сайте еще 11905 инструкций.
Добавьте сайт Lumpics.ru в закладки (CTRL+D) и мы точно еще пригодимся вам.

Отблагодарите автора, поделитесь статьей в социальных сетях.

Опишите, что у вас не получилось. Наши специалисты постараются ответить максимально быстро.

Делаем кроссворд в Excel

Составление кроссвордов в программе Microsoft Excel более желательно, нежели проделывание подобной процедуры в Word. Дело в том, что функционал Excel позволяет создать этот сканворд быстрее, плюс, имеется возможность создать проверку для кроссворда. В Word такой возможности.

Ранее мы уже разбирали, как создать кроссворд в MS Word. Рекомендуем ознакомиться с этой статьёй для лучшего понимания.

  1. Как создать кроссворд в Excel
  2. Этап 1: Создаём сканворд
  3. Этап 2: Проверка правильности

Как создать кроссворд в Excel

Для начала лучше обдумать структуру кроссворда заранее и начертить её где-нибудь на бумаге. Можно найти в сети уже готовый сканворд и скопировать его структуру. Когда всё будет готово переходите в интерфейс Excel.

Этап 1: Создаём сканворд

Задать саму структуру будущего кроссворда можно, если выполнить следующие действия:

  1. Запустите Excel. Как видите, ячейки здесь прямоугольные. Они не подходят для создания кроссворда, поэтому придётся поменять их форму. Выделите вся ячейки на листе, воспользовавшись сочетанием клавиш Ctrl+A.
  2. Нажмите правой кнопкой мыши по выделению. Из контекстного меню выберите вариант «Высота строки».

Откроется окошко с настройками высоты строки. Здесь задайте любое удобное вам значение, но не сильно большое. Например, мы установим высоту в 20 единиц. Жмите «Ок» для применения изменений.

  • Теперь кликните правой кнопкой мыши по названию любого столбца. Из контекстного меню выберите вариант «Ширина столбца».
  • Установите здесь значение 3 и нажмите «Ок».
  • Определитесь с размером кроссворда в вертикальном и горизонтальном положении. Сделайте выделение области в соответствии с тем, сколько клеток вы запланировали в сканворде.
  • Теперь в верхней строке, в блоке инструментов «Шрифт», кликните по кнопке «Граница». Из контекстного меню выберите «Все границы».
  • Границы, которые очерчивают сканворд успешно установлены. Теперь выделите те его части, которые не нужны в кроссворде, то есть куда ничего не будет вписываться. В блоке инструментов «Редактирование» нажмите на кнопку в виде ластика. Таким образом вы удалите выделение у тех участков, где оно не требуется.

  • Дополнительно можно выделить каким-нибудь акцентным цветом главную полосу кроссворда. Выделите эту полосу и измените у неё цвет с помощью инструмента заливки, что расположен в блоке «Шрифт».
  • Основная структура кроссворда готова, теперь осталось только пронумеровать строки и столбцы, а также прописать вопросы в отдельном блоке.

    1. Выделите ячейку около нужной строки/столбца. Поставьте в ней номер данной ячейки. Если цифра номера слишком большая, то вы можете уменьшить её, выбрав соответствующий размер в блоке инструментов «Шрифт». Также можно настроить выравнивание цифры в соответствующем блоке.
    2. Теперь нужно выделить область, в которую будут записаны вопросы. Её размер может быть произвольным, главное, чтобы все данные поместились в указанной области.
    3. В выделенной области нужно убрать разбиение на ячейки. Нажмите по ней правой кнопкой мыши и выберите из контекстного меню «Объединить ячейки».

  • Вставьте туда заранее подготовленный текст или пропишите вопросы вручную.
  • Этап 2: Проверка правильности

    Вы можете также сделать проверку кроссворда в Excel. Правда, она будет доступна только для тех пользователей, которые разгадывают его в электронном виде. Для печати функция проверки недоступна.

    Делается проверка готового кроссворда следующим образом:

    1. Создайте дополнительный лист для таблицы. Здесь запишите ответы в формате таблицы. Разделите её на столбцы:
      • «Ответы». Сюда вписываются сами ответы на вопросы;
      • «Введено». В этом столбце вписываются данные, которые пользователь ввёл;
      • «Совпадения». Здесь Excel будет сверять данные введённые пользователем с ответами;
      • Ещё внизу можно создать блок «Итого», где будет подсчитана сумма верных ответов.

    2. Переключитесь на первую ячейку столбца «Введено». Здесь нужно задать специальную функцию. Нажмите на кнопку в виде буквы «f» около строки ввода данных.
    3. Будет открыт мастер создания функций. В нём найдите функцию, которая называется «Сцепить». Выберите её и нажмите «Ок», чтобы она применилась.
    4. Откроется окошко задания аргументов для функции. Здесь нужно нажать на кнопку в виде таблички, что расположена около строки ввода аргумента.
    5. Переключитесь на первый лист и выберите все ячейки той строки, которая соответствуют нужному вопросу.
    6. Проделайте аналогичную операцию с другими ответами.
    7. Теперь переключитесь на первую ячейку совпадений. Сюда нужно задать функцию «Если». Она будет иметь следующий вид: «=ЕСЛИ(номер_ячейки_ответа=номер_ячейки_введено;1;0)». Вот так она выглядит у нас: «=ЕСЛИ(A4=B4;1;0)». То есть, если ответ пользователя совпадает с записанным в таблице ответом, то в «Совпадение» пишется один балл. В противном случае ставится 0.

    8. Переключитесь к строке «Итого». Здесь нужно прописать функцию «СУММ», чтобы суммировать полученные баллы. В скобках этой функции проставьте номера ячеек, которые требуется просуммировать.
    9. Осталось только вписать завершающую функцию на первом листе с кроссвордом, которая будет выдавать, правильно ли он решён или нет.

      1. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу. Именно от этого числа нужно будет составлять дальнейшую формулу.
      2. Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

      Теперь, если пользователь ответил на один или несколько вопросов неверно, то система предложит ему подумать ещё. В противном случае Excel оповестит человека о том, что он решил кроссворд правильно.

      Ссылка на основную публикацию