Как сохранить документ 1с в excel

Работа с файлами Excel

MS Excel давно стал стандартом для работы с электронными таблицами. В статье рассматриваются способы программной выгрузки и загрузки из 1С в файлы Excel.

Существует несколько способов программной работы с файлами Excel из 1С. Каждый из них имеет свои преимущества и недостатки.

Обмен через табличный документ

Данный способ простой. Его суть заключается в том, что объект ТабличныйДокумент имеет методы:

  • Записать ( ИмяФайла >, ТипФайлаТаблицы >) для выгрузки данных в файл;
  • Прочитать ( ИмяФайла >, СпособЧтенияЗначений >) для загрузки данных из файла.

Внимание!

Метод Записать () доступен как на клиенте, так и на сервере. Метод Прочитать () доступен только на стороне сервера. Необходимо помнить об этом
при планировании клиент-серверного взаимодействия.

Рассмотрим пример сохранения табличного документа в файл. Необходимо любым способом создать и заполнить объект ТабличныйДокумент, а выгрузка в файл осуществляется всего лишь одной строкой:

ТабДок . Записать ( ПутьКФайлу , ТипФайлаТабличногоДокумента . XLSX );

Здесь ТабДок — сформированный табличный документ, ПутьКФайлу — имя файла для выгрузки, ТипФайлаТабличногоДокумента.XLSX — формат создаваемого файла. Поддерживаются следующие форматы Excel:

  • XLS95 — формат Excel 95;
  • XLS97 — формат Excel 97;
  • XLSX — формат Excel 2007.

Загрузка из файла осуществляется также достаточно просто:

ТабДок = Новый ТабличныйДокумент ;
ТабДок . Прочитать ( ПутьКФайлу , СпособЧтенияЗначенийТабличногоДокумента.Значение );

Здесь ПутьКФайлу — путь к загружаемому файлу Excel. СпособЧтенияЗначенийТабличногоДокумента.Значение определяет, каким образом нужно интерпретировать данные, считываемые из исходного документа. Доступны варианты:

  • Значение;
  • Текст.

Обмен через OLE

Обмен через технологию OLE automation, пожалуй, самый распространенный вариант программной работы с файлами Excel. Он позволяет использовать весь функционал, предоставляемый Excel, но отличается медленной скоростью работы по сравнению с другими способами. Для обмена через OLE требуется установка MS Excel:

  • На компьютере конечного пользователя, если обмен происходит на стороне клиента;
  • На компьютере сервера 1С:Предприятие, если обмен происходит на стороне сервера.

Пример выгрузки:

// Создание COM-объекта
Эксель = Новый COMОбъект ( «Excel.Application» );
// Отключение вывода предупреждений и вопросов
Эксель . DisplayAlerts = Ложь;
// Создание новой книги
Книга = Эксель . WorkBooks . Add ();
// Позиционирование на первом листе
Лист = Книга . Worksheets ( 1 );

// Запись значения в ячейку
Лист . Cells ( НомерСтроки , НомерКолонки ). Value = ЗначениеЯчейки ;

// Сохранение файла
Книга . SaveAs ( ИмяФайла );

// Закрытие Эксель и освобождение памяти
Эксель . Quit ();
Эксель = 0 ;

Примеры чтения:

// —— ВАРИАНТ 1 ——

// Создание COM-объекта
Эксель = Новый COMОбъект ( «Excel.Application» );
// Открытие книги
Книга = Эксель . Workbooks . Open ( ПутьКФайлу );
// Позиционирование на нужном листе
Лист = Книга . Worksheets ( 1 );

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;

// Закрытие книги
Книга . Close ( 0 );

// Закрытие Эксель и освобождение памяти
Эксель . Quit ();
Эксель = 0 ;

// —— ВАРИАНТ 2 ——

// Открытие книги
Книга = ПолучитьCOMОбъект ( ПутьКФайлу );
// Позиционирование на нужном листе
Лист = Книга . Worksheets ( 1 );

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;

// Закрытие книги
Книга . Application . Qui t ();

Для обхода всех заполненных строк листа Excel можно использовать следующие приемы:

// —— ВАРИАНТ 1 ——
КоличествоСтрок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Row ;
Для НомерСтроки = 1 По КоличествоСтрок Цикл
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;
КонецЦикла;

// —— ВАРИАНТ 2 ——
НомерСтроки = 0 ;
Пока Истина Цикл
НомерСтроки = НомерСтроки + 1 ;
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;
Если НЕ ЗначениеЗаполнено ( ЗначениеЯчейки ) Тогда
Прервать;
КонецЕсли;
КонецЦикла;

Вместо последовательного обхода всех строк листа можно выгрузить все данные в массив и работать с ним. Такой подход будет быстрее при чтении большого объема данных:

ВсегоКолонок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Column ;
ВсегоСтрок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Row ;

Область = Лист . Range ( Лист . Cells ( 1 , 1 ), Лист . Cells ( ВсегоСтрок , ВсегоКолонок ));
Данные = Область . Value . Выгрузить ();

В таблице ниже приведены наиболее востребованные свойства и методы для работы с Excel через OLE:

Действие Код Комментарий
Работа с приложением
Установка видимости окна приложения Эксель . Visible = Ложь;
Установка режима вывода предупреждений (выводить/не выводить) Эксель . DisplayAlerts = Ложь;
Закрытие приложения Эксель . Quit ();
Работа с книгой
Создание новой книги Книга = Эксель . WorkBooks . Add ();
Открытие существующей книги Книга = Эксель . WorkBooks . Open ( ИмяФайла );
Сохранение книги Книга . SaveAs ( ИмяФайла );
Закрытие книги Книга . Close ( 0 );
Работа с листом
Установка текущего листа Лист = Книга . WorkSheets ( НомерЛиста );
Установка имени Лист . Name = Имя ;
Установка защиты Лист . Protect ();
Снятие защиты Лист . UnProtect ();
Установка ориентации страницы Лист . PageSetup . Orientation = 2 ; 1 — книжная, 2 — альбомная
Установка левой границы Лист . PageSetup . LeftMargin = Эксель . CentimetersToPoints ( Сантиметры );
Установка верхней границы Лист . PageSetup . TopMargin = Эксель . CentimetersToPoints ( Сантиметры );
Установка правой границы Лист . PageSetup . RightMargin = Эксель . CentimetersToPoints ( Сантиметры );
Установка нижней границы Лист . PageSetup . BottomMargin = Эксель . CentimetersToPoints ( Сантиметры );
Работа со строками, колонками, ячейками
Установка ширины колонки Лист . Columns ( НомерКолонки ). ColumnWidth = Ширина ;
Удаление строки Лист . Rows ( НомерСтроки ). Delete ();
Удаление колонки Лист . Columns ( НомерКолонки ). Delete ();
Удаление ячейки Лист . Cells ( НомерСтроки , НомерКолонки ). Delete ();
Установка значения Лист . Cells ( НомерСтроки , НомерКолонки ). Value = Значение ;
Объединение ячеек Лист . Range ( Лист . Cells ( НомерСтроки , НомерКолонки ), Лист . Cells ( НомерСтроки1 , НомерКолонки1 )). Merge ();
Установка шрифта Лист . Cells ( НомерСтроки , НомерКолонки ). Font . Name = ИмяШрифта ;
Установка размера шрифта Лист . Cells ( НомерСтроки , НомерКолонки ). Font . Size = РазмерШрифта ;
Установка жирного шрифта Лист . Cells ( НомерСтроки , НомерКолонки ). Font . Bold = 1 ; 1 — жирный шрифт, 0 — нормальный
Установка курсива Лист . Cells ( НомерСтроки , НомерКолонки ). Font . Italic = 1 ; 1 — курсив, 0 — нормальный
Установка подчеркнутого шрифта Лист . Cells ( НомерСтроки , НомерКолонки ). Font . Underline = 2 ; 2 — подчеркнутый, 1 — нет

Для того, чтобы узнать какое свойство нужно менять или какой метод вызвать можно воспользоваться макросами Excel. Если записать макрос с требуемыми действиями, то после можно посмотреть программный код на VBA записанного макроса.

Использование COMSafeArray

При выгрузке больших объемов данных из 1С в Excel для ускорения можно использовать объект COMSafeArray. Согласно определению из синтакс-помощника, COMSafeArray — объектная оболочка над многомерным массивом SafeArray из COM. Позволяет создавать и использовать SafeArray для обмена данными между COM-объектами. Проще говоря, это массив значений, который можно использовать для обмена между приложениями по технологии OLE.

// Создание COMSafeArray
МассивКом = Новый COMSafeArray ( «VT_Variant» , ВсегоКолонок , ВсегоСтрок );
// Заполнение COMSafeArray
Для Стр = 0 По ВсегоСтрок — 1 Цикл
Для Кол = 0 По ВсегоКолонок — 1 Цикл
МассивКом . SetValue ( Кол , Стр , Значение );
КонецЦикла;
КонецЦикла;
// Присвоение области листа Excel значений из COMSafeArray
Лист . Range ( Лист . Cells ( 1 , 1 ), Лист . Cells ( ВсегоСтрок , ВсегоКолонок )). Value = МассивКом ;

Обмен через ADO

Файл Excel при обмене через ADO представляет собой базу данных, к которой можно обращаться при помощи SQL-запросов. Установка MS Excel не требуется, но обязательно наличие драйвера ODBC, при помощи которого будет осуществляться доступ. Используемый драйвер ODBC определяется при указании строки соединения к файлу. Обычно требуемый драйвер уже установлен на компьютере.

Обмен через ADO заметно быстрее обмена через OLE, но при выгрузке нет возможности использовать функционал Excel для оформления ячеек, разметки страниц, задания формул и т.д.

Пример выгрузки:

// Создание COM-объекта для соединения
Соединение = Новый COMОбъект ( «ADODB.Connection» );

// Установка строки соединения
Соединение . ConnectionString = «
|Provider=Microsoft.ACE.OLEDB.12.0;
|Data Source=» + ИмяФайла + «;
|Extended Properties=»»Excel 12.0 XML;HDR=YES»»;» ;
Соединение . Open (); // Открытие соединения

// Создание COM-объекта для команды
Команда = Новый COMОбъект ( «ADODB.Command» );
Команда . ActiveConnection = Соединение ;

// Присвоение текста команды для создания таблицы
Команда . CommandText = «CREATE TABLE [Лист1] (Колонка1 char(255), Колонка2 date, Колонка3 int, Колонка4 float)» ;
Команда . Execute (); // Выполнение команды

// Присвоение текста команды для добавления строки таблицы
Команда . CommandText = «INSERT INTO [Лист1] (Колонка1, Колонка2, Колонка3, Колонка4) values (‘абвгдеё’, ‘8/11/2017’, ‘12345’, ‘12345,6789’)» ;
Команда.Execute(); // Выполнение команды

// Удаление команды и закрытие соединения
Команда = Неопределено;
Соединение . Close ();
Соединение = Неопределено ;

Для создания нового листа и формирования его структуры можно воспользоваться объектами ADOX.Catalog и ADOX.Table. В этом случае код примет вид:

// Создание COM-объекта для работы с книгой
Книга = Новый COMОбъект ( «ADOX.Catalog» );
Книга . ActiveConnection = Соединение ;

// Создание COM-объекта для работы со структурой данных на листе
Таблица = Новый COMОбъект ( «ADOX.Table» );
Таблица . Name = «Лист1» ;
Таблица . Columns . Append ( «Колонка1» , 202 );
Таблица . Columns . Append ( «Колонка2» , 7 );
Таблица . Columns . Append ( «Колонка3» , 5 );
Таблица . Columns . Append ( «Колонка4» , 5 );

// Создание в книге листа с описанной структурой
Книга . Tables . Append ( Таблица );
Таблица = Неопределено;
Книга = Неопределено;

В приведенном примере в методе

Таблица . Columns . Append ( «Колонка1» , 202 );

во втором параметре указывается тип колонки. Параметр необязательный, вот некоторые значения типа колонки:

  • 5 — adDouble;
  • 6 — adCurrency;
  • 7 — adDate;
  • 11 — adBoolean;
  • 202 — adVarWChar;
  • 203 — adLongVarWChar.

Пример чтения:

// Создание COM-объекта для соединения
Соединение = Новый COMОбъект ( «ADODB.Connection» );

// Установка строки соединения
Соединение . ConnectionString = «
|Provider=Microsoft.ACE.OLEDB.12.0;
|Data Source=» + ИмяФайла + «;
|Extended Properties=»»Excel 12.0 XML;HDR=YES»»;» ;
Соединение . Open (); // Открытие соединения

// Создание COM-объекта для получения выборки
Выборка = Новый COMОбъект ( «ADODB.Recordset» );
ТекстЗапроса = «SELECT * FROM [Лист1$]» ;

// Выполнение запроса
Выборка . Open ( ТекстЗапроса , Соединение );

// Обход результата выборки
Пока НЕ Выборка . EOF () Цикл
ЗначениеКолонки1 = Выборка . Fields . Item ( «Колонка1» ). Value ; // Обращение по имени колонки
ЗначениеКолонки2 = Выборка . Fields . Item ( 0 ). Value ; // Обращение по индексу колонки
Выборка . MoveNext ();
КонецЦикла;

Выборка . Close ();
Выборка = Неопределено;
Соединение . Close ();
Соединение = Неопределено;

В строке соединения параметр HDR определяет как будет восприниматься первая строка на листе. Возможны варианты:

  • YES — первая строка воспринимается как названия колонок. К значениям можно обращаться по имени и по индексу колонки.
  • NO — первая строка воспринимается как данные. К значениям можно обращаться только по индексу колонки.

В приведенных примерах рассмотрено лишь несколько объектов ADO. Объектная модель ADO состоит из следующих объектов:

  • Connection;
  • Command;
  • Recordset;
  • Record;
  • Fields;
  • Stream;
  • Errors;
  • Parameters;
  • Properties.

Выгрузка без программирования

Для сохранения данных из 1С в Excel не всегда целесообразно прибегать к программированию. Если в режиме Предприятия пользователь может отобразить требуемые для выгрузки данные, то, их возможно сохранить в Excel без программирования.

Для сохранения табличного документа (например, результата отчета) можно вызвать команду Сохранить или Сохранить как… главного меню.

Сохранение табличного документа 1С

В открывшемся окне требуется выбрать каталог, имя и формат сохраняемого файла.

Для сохранения данных динамических списков (например, списка номенклатуры) необходимо:

  1. Вывести данные в табличный документ при помощи команды Еще ⇒ Вывести список…;
  2. Сохранить табличный документ в требуемый формат.

Сохранение динамического списка

Остались вопросы?
Спросите в комментариях к статье.

Как выгрузить документ из 1С в Excel: особенности экспорта файлов

У многих пользователей программы 1С: Бухгалтерия в процессе работы с ней часто возникает необходимость в том, чтобы выгрузить документ из 1C в Excel для переноса в другую базу. Экспорт может понадобиться и в том случае, если бухгалтеру надо обработать данные без использования программы. Для осуществления данного механизма нет необходимости устанавливать внешние компоненты, ведь программа оснащена всем необходимым функционалом. В большинстве случаев выгрузить файл из системы можно без помощи программистов.

Способы выгрузки документов из программы 1С

Если бухгалтеру необходимо выгрузить отчетность, имеющую печатную форму, тогда выполнение процедуры не составит большого труда. Для этого следует сохранить документ стандартным способом, нажав пункт меню «Сохранить как» и выбрав требуемый формат файла. Данный способ подходит для конфигураций, которые поддерживают различные форматы. Если система предлагает сохранить документ только в формате mxl, следует прибегнуть к другим методам.

Применение специального программного обеспечения. Утилита «1С:Предприятие – Работа с файлами» позволяет просматривать табличную часть документов, созданных во внутренних форматах 1С, а также конвертировать их и распечатывать на бумажных носителях. Программу можно скачать бесплатно на официальном сайте 1С.

Осуществление выгрузки с использованием внутреннего языка системы 1С: Предприятие. Выполнение данного процесса находится в компетенции программистов, так как для успешного экспорта файлов потребуется знание различных кодов программы. Если же у вас нет желания заниматься изучением кодов, то вы в любое время сможете обратиться за помощью к специалистам.

Особенности выгрузки и загрузки данных

Если экспорт объектов из одной программы в другую происходит программно, следует помнить, что количество полей одного и того же документа в разных системах может отличаться. Поэтому перед выгрузкой файлов из базы необходимо преобразовать их в соответствии с правилами обмена

Чтобы документ корректно загрузился на другую платформу необходимо создать при помощи конфигурации «Конвертация данных» файл с расширением;

Настройка соответствий между объектами метаданных и реквизитами таблиц обеих программ является ключевой задачей при подготовке правил обмена. Для создания метаописаний данных используются внешние обработки;

Выгрузка файлов из программы может осуществляться с группировками строк;

Программа 1С: Бухгалтерия не различает формулы, которые мы видим в ячейках MS Excel, для работы с ней используются функции на языке VBA.

Стандартный способ вывода информации из программы 1С в Excel

Данный способ подходит для всех платформ 1С, в том числе и для 1С: Торговля. Программа предлагает несколько форматов хранения файлов: mxl (предназначен для таблиц в 1С), xls (MS Excel), html (размещение на веб-ресурсах), txt (текстовый документ). От выбора формата будет зависеть внешний вид полученного документа. Последовательность действий приведена далее:

Открыть информационную базу, затем выбрать пункты «Операции» − «Справочники» − «Номенклатура»;

Щелкнуть правой кнопкой мышки в любом месте, затем нажать «Вывести список». Появится окно установки;

В открывшемся списке отметить флажком поля, которые будут экспортироваться;

В меню «Выводить в …» следует выбрать текстовый или табличный формат, нажать клавишу«Enter»;

Когда откроется таблица − надо выделить ее. После этого нажать «Файл − Сохранить»;

Ввести название документа и выбрать формат, в котором он будет сохранен.

Если таблица объемная и содержит большой объем данных, для удобства работы с ней в дальнейшем можно выгрузить каждую группу в отдельный документ. MS Excel имеет ограниченный размер, максимальное количество строк – 1048000 (версии от 2007 года выпуска). Так как выгружаемая отчетность содержит важную информацию, желательно, чтобы все операции по экспорту данных выполнял профессионал.

Выгрузка информации из платформы 1С: Бухгалтерия 7.7

Перенос данных из платформы 1С 7.7 рекомендуется проводить в начале нового отчетного периода, после выполнения всех операций прошедшего периода. Процедура осуществляется при помощи внешних обработок, основной из которых является ACC_ACC8.ert. Эту обработку можно открывать в программе через меню «Сервис» − «Дополнительные возможности», где она называется «Переход на 1С: Бухгалтерию» (указывается версия программы). Также используется пункт «Синхронизировать данные с 1С: Бухгалтерией», устанавливающий режим синхронизации.

Из информационной базы можно выгрузить элементы справочников, сведения о товарах, текущие документы и остатки на счетах бухгалтерского учета, формы ФСС из зарплаты и др. Перенос происходит в два этапа: все данные выгружаются в отдельный файл, а затем он загружается в другую базу. Установка обработки запускается двойным нажатием мышки на setup.exe.

После успешной инсталляции надо открыть пункт меню «Сервис», затем «Дополнительные возможности», и выбрать «Выгрузка данных для 1С». Когда параметры будут определены − нажать кнопку «Загрузить правила обмена». Если перенос данных осуществляется в последний день 2015 года, то следует указать дату выгрузки 01.01.2016. Тогда документы с введенными остатками будут датированы 31.12.2015, а документы с текущими операциями – следующим днем.

Выгрузка данных из программ 1С: Бухгалтерия 8 и 8.2

В системах 1С 8 и 1С 8.2 есть возможность экспорта информационных баз в полном объеме для последующей загрузки на других компьютерах, также можно сохранять отчеты в нескольких форматах, выгружать таблицы и получать информацию с помощью запросов консоли. Чтобы экспортировать базу целиком следует зайти в режим Конфигуратор, выбрать пункт меню «Администрирование», затем нажать «Выгрузить информационную базу». Система попросит пользователя указать наименование файла и его расположение. Если надо загрузить сохраненную информацию в другую базу, следует нажать кнопку «Загрузить информационную базу» и выбрать требуемый файл.

Иногда перед бухгалтерами ставят задачи, связанные с получением списков определенных документов или товаров. Рассмотрим, как можно выгрузить такую информацию из программы 1С. Для этого надо открыть форму списка и установить необходимые отборы, затем правой кнопкой мышки вызвать контекстное меню и выбрать «Вывести список». Программа предложит возможные варианты вывода.

Еще один несложный способ – выгрузка печатных форм в Excel. Для получения данных необходимо открыть реестр документов, выбрать из списка нужный, затем открыть печатную форму. После этого нажать сочетание клавиш «Ctrl + S» или «Файл – Сохранить как», система предложит ввести имя файла и выбрать его тип. Сформированный отчет выгружается по похожему алгоритму.

Экспорт остатков из системы 1С

Справочники номенклатуры и остатки можно выгрузить из программы при помощи различных обработок. Они позволяют выводить данные о наименованиях товаров, единицах измерений, количестве на складе. Данная функция очень востребована в тех случаях, когда необходимо отобрать продукцию по заданным параметрам для отправки чекбокса клиенту. Порядок действий при выгрузке остатков приведен далее:

Нажать «Операции» − «Справочники» − «Номенклатура»;

Когда появится окно с перечнем номенклатур, можно отобрать требуемые наименования при помощи фильтров. Затем кликнуть мышкой по любой строке, в контекстном меню выбрать «Вывести список»;

Установить галочки на необходимых параметрах, нажать «OK»;

Набрать комбинацию «Файл» − «Сохранить как»;

Ввести название файла, выбрать тип «Лист Excel», сохранить.

Основные средства выгружаются по подобному сценарию.

Экспорт справочников контрагентов из 1С в Excel

Выгрузить список контрагентов из системы 1С: Бухгалтерия довольно просто. Для этого можно использовать обработки или печатные формы. При выводе печатных форм последовательность действий будет следующей:

Открыть меню «Предприятие», выбрать пункт «Контрагенты»;

Нажать «Действия», выбрать команду «Вывести список»;

Когда появится список, следует проверить, чтобы в каждом поле был указан параметр ИНН. При необходимости установить флажок в настройках. В рядке «Выводить в …» указать «Табличный документ». Сформировать готовый список;

Нажать «Файл» − «Сохранить как».

Выгрузка счетов из программы 1С: Бухгалтерия в Excel

Необходимость обмены счетами с покупателями и контрагентами возникает довольно часто. Но так как для ведения бухгалтерского и налогового учета используется специальное программное обеспечение, сотрудникам компании приходится выгружать из него документы и сохранять их в табличной форме. Формат Excel позволяет экспортировать файлы из системы 1С без потерь, и если другой пользователь откроет сохраненный документ в программе Excel – он увидит его точно таким, каким он был создан в бухгалтерской программе.

Для начала необходимо сформировать счет и вывести его на экран. После этого документ можно распечатать на бумажном носителе или сохранить во внешний файл для последующей отправки по электронной почте. Выгрузка счетов осуществляется по стандартной схеме: в меню «Файл» выбрать пункт «Сохранить как», затем ввести название и указать тип сохраняемого документа.

Ссылка на основную публикацию