Как сравнить два значения в excel что больше что меньше

Сравнение числовых столбцов

history 11 октября 2015 г.
    Группы статей

  • Сравнение списков
  • Условное форматирование

Сравним 2 столбца значений. Сравнение будем производить построчно: если значение во втором столбце больше, чем в первом, то оно будет выделено красным, если меньше — то зеленым. Выделять ячейки будем Условным форматированием.

Пусть имеется 2 столбца с числами. Сравним значения второго столбца с первым (см. файл примера ).

Выделите все значения из второго столбца и создайте правило Условного форматирования для выделения меньших значений.

Обратите внимание, что при создании ссылки на ячейку из первого столбца использована относительная адресация на строку, т.е. =$A6 , а не =$A$6 , которая предлагается MS EXCEL по умолчанию. Такая адресация позволяет построчно сравнивать столбцы, в противном случае все значения второго столбца будут сравниваться только со значением из ячейки А6 .

Аналогично создайте правило для значений, которые больше.

Как сравнить текст в ячейках таблицы Excel

Часто перед пользователями табличного редактора Эксель стоит такая задачка, как сравнение текста в ячейках таблички. Существует несколько способов реализации этой процедуры. В статье мы детально рассмотрим каждый из способов, позволяющий реализовать сравнение текстовой информации в ячейках таблички.

Сравнение двух ячеек в табличном редакторе

В табличном редакторе имеется два различных метода, позволяющих сравнить текстовую информацию в ячейках. Методы отличаются друг от друга тем, что один учитывает регистр, а второй – нет

Применение специальной формулы без учета регистра

Самый простейший вариант сравнения текста в 2-х ячейках без учета регистра – это применение символа «=» между координатами ячеек. Пример формулы: =А1=В1.

Важно! А1 и В1 являются элементами сравнения. В результате, в ячейке с формулой выведется либо значение ЛОЖЬ, либо значение ИСТИНА.

Если пользователь желает в виде результата отобразить уникальные сообщения, говорящие о наличие соответствий в ячейках, то дополнительно в формулу необходимо добавить оператор «ЕСЛИ». Простой пример такой формулы: =ЕСЛИ(А2=В2; “Совпадает”; “НЕ совпадает”).

На нижеприведенной картинке прекрасно видно, как две рассмотренные формулы справляются с процедурой сравнения текстовой информации в ячейках.

kak-sravnit-tekst-v-yachejkah-tablicy-excel

1

Применение специальной формулы с учетом регистра

Часто при работе с документами случаются такие моменты, когда необходимо не просто произвести сравнение текстовой информации, но и учесть регистр. Для реализации этой несложной процедуры применятся специальный оператор «СОВПАД». В английской вариации он имеет наименование «EXACT». Общий вид формулы выглядит так: =СОВПАД(текст1; текст2). Аргументы текст1 и текст2 – это координаты ячеек, в которых будет производиться сравнение текстовой информации.

К примеру, данные для сравнения располагаются в полях, имеющих координаты А1 и В1. В этом случае, применяемая формула будет выглядеть так: =СОВПАД(А1; В1). Значение ИСТИНА будет отображено в том случае, если регистр каждого знака будет совпадать. В иных случаях отобразится значение ЛОЖЬ.

Внимание! Если пользователь желает в виде результата отобразить уникальные сообщения, говорящие о наличие соответствий в ячейках, то дополнительно в формулу необходимо добавить оператор «ЕСЛИ».

Простой пример такой формулы: =ЕСЛИ(СОВПАД(A1; B1); “Совпадает”; “НЕ совпадает”). На нижеприведенной картинке прекрасно видно, как две рассмотренные формулы справляются с процедурой сравнения текстовой информации в ячейках с учетом регистра.

kak-sravnit-tekst-v-yachejkah-tablicy-excel

2

Сравнение нескольких ячеек в табличном редакторе

Теперь поговорим детально о том, как произвести сравнение текстовой информации более, чем в двух ячейках. Эти методы практически идентичны тем, что были рассмотрены выше.

Применение специальной формулы без учета регистра для нескольких ячеек

Здесь, как и в ранее рассмотренных методах, применяется две вариации формулы:

  1. Первый вариант формулы выглядит так: =И(А1=В1; А1=С1).
  2. Второй вариант формулы выглядит так: =ЕСЛИ(И(А1=В1; А1=С1); “Совпадает”; “НЕ совпадает”).

Функция «И» реализует возврат значения ИСТИНА в том случае, если все поля таблички имеют совпадающие значения. Возврат значения ЛОЖЬ происходит, если какое-либо из значений не совпадает. Оператор «ЕСЛИ» позволяет отобразить на экране те показатели, которые ввел пользователь в формулу.

На нижеприведенной картинке прекрасно видно, как две рассмотренные формулы справляются с процедурой сравнения не только текстовой информации, но и с числовыми показателями, а также с данными формата «Дата».

kak-sravnit-tekst-v-yachejkah-tablicy-excel

3

Применение специальной формулы с учетом регистра для нескольких ячеек

Здесь, как и в ранее рассмотренных методах, применяется две вариации формулы:

  1. Первый вариант формулы выглядит так: =И(СОВПАД(А1;В1); СОВПАД(А1; С2)).
  2. Второй вариант формулы выглядит так: =ЕСЛИ(И(СОВПАД(А1;В1);СОВПАД(А1; С1));”Точное совпадение”; “НЕ совпадает”).

Как и в предыдущем примере, функция «И» реализует возврат значения ИСТИНА в том случае, если все поля таблички имеют совпадающие значения. Возврат значения ЛОЖЬ происходит, если какое-либо из значений не совпадает. Оператор «ЕСЛИ» позволяет отобразить на экране те показатели, которые ввел пользователь в формулу. Результат преобразований выглядит так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

4

Если пользователю необходимо, чтобы формула вывела наличие соответствий хотя бы 2-х показателей, то ему необходимо использовать следующую формулу: =ЕСЛИ(ИЛИ(СОВПАД(А1;В1);СОВПАД(А1; С1);СОВПАД(В1;С1)); “Не менее двух точных соответствий”; “Соответствий нет”). Иными словами, в этом случае наличие хотя бы 2-х соответствий в 3-х случаях, выведет положительное значение. Результат преобразований выглядит так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

5

Если же пользователю необходимо произвести сравнение в табличке, в которой присутствует огромное количество ячеек, то вышеописанная формула будет не удобной в использовании, так как она станет слишком длинной. Здесь целесообразнее использовать математический оператор «СЧЕТЕСЛИ». Подсчитать количество соответствий в большом диапазоне ячеек можно при помощи следующей формулы: <=СЧЕТЕСЛИ(А2:D2;А2:D2)>. Результат преобразований выглядит так:

kak-sravnit-tekst-v-yachejkah-tablicy-excel

6

Стоит отметить! Очень важно следить за количеством ненужных пробелов в ячейках. Дело в том, что если в ячейке присутствует пробел, то он будет восприниматься табличным редактором как символ. Поэтому перед использованием формул необходимо убедиться в том, что в ячейках отсутствуют ненужные пробелы.

Заключение

Мы выяснили, что в табличном редакторе Эксель существует огромное количество методов, позволяющих реализовать сравнение текстовой информации в ячейках. Мы узнали, что можно сравнивать информацию с учетом регистра и без учета. Для реализации этой процедуры великолепно подходит такой оператор, как «СОВПАД». Дополнительно для более сложных процедур применяются такие функции, как «И», «ИЛИ», «ЕСЛИ» И «СЧЕТЕСЛИ».

Ссылка на основную публикацию