Как пронумеровать строки в таблице excel если стоит фильтр

Автоматическая перенумерация строк при применении фильтра в EXCEL

history 18 апреля 2013 г.
    Группы статей

  • Нумерация строк/ столбцов
  • Последовательности Чисел

При применении фильтра строки скрываются целиком. Если в таблице имелась нумерация строк, то она будет сбита. Но, есть способ обойти эту проблему.

Пусть имеется таблица с нумерацией строк (в столбце введены числа от 1 до 16).

Если к таблице применить фильтр (нажав в строке заголовков таблицы CTRL+SHIFT+L и установив критерии отбора), то нумерация строк будет сбита (см. столбец А ).

Для того, чтобы сохранить нумерацию строк, используем вместо последовательности констант (от 1 до 16) — формулу.

Решение основано на использовании функции ПРОМЕЖУТОЧНЫЕ.ИТОГИ() , которая «чувствует», когда строка скрыта фильтром .

Столбец с нумерацией расположим в столбце А (заголовок таблицы разместим в строке 6 ). Полезные данные, которые вводятся БЕЗ ПРОПУСКОВ, расположим в столбце В (см. Файл примера ):

Записав в ячейке A 7 формулу =ЕСЛИОШИБКА(ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;B7);A6+1;A6);1)

и скопировав ее в ячейки ниже, получим желаемый результат. Если строка скрыта, то функция ПРОМЕЖУТОЧНЫЕ.ИТОГИ() возвращает 0 (ЛОЖЬ) и счетчик номера строки не увеличивается на 1, а остается, как у предыдущей строки.

После применения фильтра нумерация строк таблицы автоматически изменится.

Как пронумеровать строки в таблице excel если стоит фильтр

1

Чтобы пронумеровать по порядку строки, полученные после применения фильтра, необходимо:

  1. 1. В первую ячейку отфильтрованного списка внести функцию ПРОМЕЖУТОЧНЫЕ.ИТОГИ, выбрать 103-й номер функции (СЧЁТЗ) кликнув 2 раза по номеру

2

2. Нажать fx в строке формул и указать в Ссылка1 соседнюю ячейку в этой же строке (в примере – наименования товаров).

3

3. Ввести «:» и еще раз указать эту же ячейку, создав диапазон из одной ячейки.

4

4. Первую границу диапазона фиксируем (выделяем адрес и нажимаем на клавиатуре F4)

5

5. Нажимаем «OK» и протягиваем формулу до конца списка.

Мы получаем активную нумерацию. Даже если вы отсортируете значения в других столбцах, нумерация сохранится.

7

Если материал Вам понравился или даже пригодился, Вы можете поблагодарить автора, переведя определенную сумму по кнопке ниже:
(для перевода по карте нажмите на VISA и далее "перевести")

Ссылка на основную публикацию