Как в excel выделить только четные строки

Выделение строк и столбцов в таблице Excel

Ячейки и диапазоны в таблице можно выбирать точно так же, как на отдельные ячейки и столбцы, но выбор строк и столбцов таблицы отличается от выбора строк и столбцов.

Выполните указанное действие

Столбец таблицы с заголовком или без него

Щелкните в таблице верхний край столбца или его заголовка. Следующая стрелка выделения указывает на то, что столбец выбирается щелчком.

Примечание: Если щелкнуть верхний край, будут выбраны данные столбца таблицы. Если щелкнуть его дважды, будет выбран весь столбец таблицы.

Можно также щелкнуть в любом месте столбца таблицы и нажать клавиши CTRL+ПРОБЕЛ или щелкнуть первую ячейку столбца таблицы, а затем нажать клавиши CTRL+SHIFT+СТРЕЛКА ВНИЗ.

Примечание: Один раз при нажатии CTRL+ПРОБЕЛ будут выбраны данные столбца таблицы. Дважды при нажатии CTRL+ПРОБЕЛ будет выбран весь столбец таблицы.

Щелкните левую границу строки таблицы. Следующая стрелка выделения указывает на то, что при щелчке выбрана строка.

Можно щелкнуть первую ячейку в строке таблицы и нажать клавиши CTRL+SHIFT+СТРЕЛКА ВПРАВО.

Все строки и столбцы таблицы

Щелкните левый верхний угол таблицы. Следующая стрелка выделения указывает на то, что при щелчке будут выбраны данные таблицы во всей таблице.

Дважды щелкните левый верхний угол таблицы, чтобы выбрать всю таблицу, включая ее заглавные.

Можно также щелкнуть в любом месте таблицы и нажать CTRL+A, чтобы выбрать данные во всей таблице, или щелкнуть левую верхнюю ячейку таблицы и нажать CTRL+SHIFT+END.

Чтобы выделить таблицу целиком вместе с заголовками, дважды нажмите клавиши CTRL+A.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Отбор четных и нечетных строк таблицы в EXCEL

history 11 апреля 2014 г.
    Группы статей

  • Отбор строк в таблице
  • Условное форматирование

Для извлечения из таблицы только четных или нечетных строк можно использовать формулы и Автофильтр .

Пусть имеется исходная таблица с объемами продаж товаров по кварталам.

Нам требуется отобразить только четные или нечетные строки.

Примечание : О выделении нечетных строк Условным форматированием читайте в статье о Чрезстрочном выделении .

Автофильтр

Это можно легко сделать с помощью Автофильтра в столбце F . Для этого в ячейку F8 введите формулу =ЕЧЁТН(СТРОКА()-СТРОКА($F$7)) и скопируйте ее вниз. Формула для четных строк таблицы (не листа!) возвращает ИСТИНА.

Теперь с помощью Автофильтра можно выбрать либо четные либо нечетные строки.

Формулы

Выведем четные и нечетные строки с помощью формул.

С помощью формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$21))*2) можно отобрать только четные строки из исходной таблицы.

С помощью формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$30))*2-1) можно отобрать только нечетные строки.

Ссылка на основную публикацию