Как удалить нечетные строки в excel

Отбор четных и нечетных строк таблицы в EXCEL

history 11 апреля 2014 г.
    Группы статей

  • Отбор строк в таблице
  • Условное форматирование

Для извлечения из таблицы только четных или нечетных строк можно использовать формулы и Автофильтр .

Пусть имеется исходная таблица с объемами продаж товаров по кварталам.

Нам требуется отобразить только четные или нечетные строки.

Примечание : О выделении нечетных строк Условным форматированием читайте в статье о Чрезстрочном выделении .

Автофильтр

Это можно легко сделать с помощью Автофильтра в столбце F . Для этого в ячейку F8 введите формулу =ЕЧЁТН(СТРОКА()-СТРОКА($F$7)) и скопируйте ее вниз. Формула для четных строк таблицы (не листа!) возвращает ИСТИНА.

Теперь с помощью Автофильтра можно выбрать либо четные либо нечетные строки.

Формулы

Выведем четные и нечетные строки с помощью формул.

С помощью формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$21))*2) можно отобрать только четные строки из исходной таблицы.

С помощью формулы =ИНДЕКС(A$8:A$17;(СТРОКА()-СТРОКА($A$30))*2-1) можно отобрать только нечетные строки.

Как удалить каждую вторую строку в Excel

Возможность удаления каждой второй строки в Excel — это часто возникающая задача, решение которой не займет более 5 минут.

  • Инструкция;
  • Способы применения.

Как удалить каждую вторую строку в Excel

Для выполнения этой задачи потребуется первоначально добавить новый столбец, который можно назвать «Индикатором» и добавить в первые две строчки цифры 1 и 2.

Создание дополнительной строки и цифр в них в Excel

После копируем первые две ячейки, кликнув правой клавишей мыши и нажав на «Копировать» (сочетание клавиш CTRL+C).

Копирование ячеек в Эксель

Далее выделяем область, в которой будет происходить удаление и нажимаем кликаем правой клавишей мыши и выбираем «Вставить скопированные ячейки» (сочетание клавиш CTRL+V).

Растягивание значений в столбце в Excel

После включаем фильтр, перейдя в «Данные»-«Фильтр».

Фильтрация ячеек в Эксель

Следующим этапом кликаем на 1 и удаляем ее из показа.

Выбор показа каждой второй строки в Excel

Выделяем оставшиеся четные строки и при помощи правой клавиши мыши выводим меню и выбираем «Удалить строку».

Удаление каждой второй строки в Excel

Включаем показ нечетных строк.

Остаток после удаления каждой второй строки в Эксель

Все готово, остались лишь нечетные строки.

Удаление каждой третьей или любой другой строки в Эксель

Сделать это можно по той же инструкции, сменив лишь начальные цифры, например, если нужно избавиться от каждой третьей строки, то необходимо использовать повторяющуюся комбинацию 1, 2, 3.

Удаление каждой третей строки в Excel

Аналогичный образом можно обрезать не только 1 но 2 ненужные строки из списка, например, 2 и 4 из 5.

Ссылка на основную публикацию