Как сделать формулу в excel правда ложь

Создание условных формул

Проверка истинного или ложного условия и логические сравнения выражений являются общими для многих задач. Для создания условных формул можно использовать функции И, ИЛИ,НЕ и ЕСЛИ.

Например, функция ЕСЛИ использует следующие аргументы:

Формула, использующая функцию ЕСЛИ

logical_test: условие, которое вы хотите проверить.

value_if_true: значение, возвращаемое, если условие имеет значение Истина.

value_if_false: значение, которое возвращается, если условие имеет значение False.

Дополнительные сведения о создании формул см. в теме Создание и удаление формул.

Что необходимо сделать

Создание условной формулы с логическим значением (ИСТИНА или ЛОЖЬ)

Для этого используйте функции и операторы AND, ORи NOT, как показано в примере ниже.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Выделите пример, приведенный в этой статье.

Важно: Не выделяйте заголовки строк или столбцов.

Выделение примера в справке

Нажмите клавиши CTRL+C.

В Excel создайте пустую книгу или лист.

Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.

Важно: Чтобы пример правильно работал, его нужно вставить в ячейку A1.

Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (знак ударения) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показывать формулы.

Скопировав пример на пустой лист, вы можете настроить его так, как вам нужно.

Определяет, больше ли значение в ячейке A2, а также если значение в ячейке A2 меньше значения в ячейке A4. (ЛОЖЬ)

Определяет, что значение в ячейке A2 больше, чем значение в ячейке A3, или значение в ячейке A2 меньше, чем значение в ячейке A4. (ИСТИНА)

Определяет, не равна ли сумма значений в ячейках A2 и A3 24. (ЛОЖЬ)

Определяет, не равно ли значение в ячейке A5 значению "Sprockets". (ЛОЖЬ)

Определяет, не равно ли значение в ячейке A5 значению "Sprockets" или если значение в ячейке A6 равно "Мини-приложениям". (ИСТИНА)

Дополнительные сведения об использовании этих функций см.в функциях И,ИЛИ иНЕ.

Создание условной формулы, которая приводит к другому вычислению или значению, кроме ИСТИНА или ЛОЖЬ

Для этого используйте функции и операторы ЕСЛИ, Ии ИЛИ, как показано в примере ниже.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Выделите пример, приведенный в этой статье.

Важно: Не выделяйте заголовки строк или столбцов.

Выделение примера в справке

Нажмите клавиши CTRL+C.

В Excel создайте пустую книгу или лист.

Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.

Важно: Чтобы пример правильно работал, его нужно вставить в ячейку A1.

Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (знак ударения) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показывать формулы.

Скопировав пример на пустой лист, вы можете настроить его так, как вам нужно.

=ЕСЛИ(A2=15; "ОК"; "Не ОК")

Если значение в ячейке A2 равно 15, возвращается "ОК". В противном случае возвращается "Не ОК". (ОК)

=ЕСЛИ(A2<>15; "ОК"; "Не ОК")

Если значение в ячейке A2 не равно 15, возвращается значение "ОК". В противном случае возвращается "Не ОК". (Не ОК)

=ЕСЛИ(НЕ(A2 "SPROCKETS"; "ОК"; "Не ОК")

Если значение в ячейке A5 не равно значению "SPROCKETS", возвращается "ОК". В противном случае возвращается "Не ОК". (Не ОК)

Если значение в ячейке A2 больше, чем в ячейке A3, а значение в ячейке A2 также меньше, чем в ячейке A4, возвращается значение "ОК". В противном случае возвращается "Не ОК". (Не ОК)

=ЕСЛИ(И(A2<>A3; A2<>A4); "ОК"; "Не ОК")

Если значение в ячейке A2 не равно A3, а значение в ячейке A2 также не равно значению в ячейке A4, возвращается значение "ОК". В противном случае возвращается "Не ОК". (ОК)

Если значение в ячейке A2 больше, чем в ячейке A3, или значение в ячейке A2 меньше, чем в ячейке A4, возвращается значение "ОК". В противном случае возвращается "Не ОК". (ОК)

=ЕСЛИ(ИЛИ(A5<>"Sprockets", A6<>"Widgets"), "ОК"; "Не ОК")

Если значение в ячейке A5 не равно "Sprockets" или значение в ячейке A6 не равно "Мини-приложения", возвращается "ОК". В противном случае возвращается "Не ОК". (Не ОК)

=ЕСЛИ(ИЛИ(A2<>A3; A2<>A4); "ОК"; "Не ОК")

Если значение в ячейке A2 не равно значению в ячейке A3 или значение в ячейке A2 не равно значению в ячейке A4, возвращается значение "ОК". В противном случае возвращается "Не ОК". (ОК)

Дополнительные сведения об использовании этих функций см.в функциях ЕСЛИ,Ии ИЛИ.

Логические функции в Excel. Часть №1

Logic function 1 Логические функции в Excel. Часть №1 Доброго времени суток уважаемый читатель!

Вот я, наконец, то и добрался к своим любимым логическим функциям Excel. Признаю, что мне они наиболее ближе и удобнее в использовании нежели другие разделы функций, каюсь грешен, должны же быть и у меня любимчики… А если говорить серьезно, логические функции одни из самых распространённых в использовании функции и самые полезные в работе бухгалтеров, экономистов, да и в принципе любого специалиста финансовых дисциплин.

Основной особенностью этих функций, это проверка данных на соответствие результату «ИСТИНА» или «ЛОЖЬ», то есть когда результат соответствует заданному условию, получаем итог «ИСТИНА» и «ЛОЖЬ», когда условия не выполнены. На самом деле это намного легче понять, чем описать и я думаю, что читая дальше, вы сможете понять логику работы этих функций.

Поскольку хочется написать многое, описать работу и возможности функций в одной статье, это будет чрезмерно много, поэтому, как и в случае с описанием текстовых функций, я разобью информацию о логических функциях на 2 части.

Logic function 2 Логические функции в Excel. Часть №1

В своем арсенале Excel содержит 7 логических функций, хотя в зависимости от версий их может быть и меньше, и больше. Найти перечень доступных функций вы можете в панели управления на вкладке «Формулы», в блоке «Библиотека функций», нажав кнопку «Логические» с выпадающем перечнем логических функций. Или с помощью мастера функций: А вот собственно и перечень логических функций, которые мы будем рассматривать в первой части этой статье:

Все предоставленные функции достаточны, просты и легки в использовании, и я думаю, у вас не будет никаких затруднений в их реализации и использовании. Главное условие этого я бы выделил только понимание сути и логики исполнения функции и варианты ее применения вы сразу сможете понять.

Сразу скажу это одна из самых классных функций в Excel. Я ее результатами пользуюсь, где нужно и ненужно, а поэтому считаю, что изучить ее возможности необходимо любому уважающему себя человеку, который хочет показать себя как специалист финансовых дисциплин. Несмотря на кажущуюся простоту, возможности этой функции очень удивляют и приятно радуют. Для углублённого изучения ее возможностей вам поможет статья «Как используется функция ЕСЛИ в Excel с несколькими условиями».

Функция ЕСЛИ возвращает один результат в случаях, если аргумент «логическое выражение» при вычислении получает ответ «ИСТИНА» и совсем другой, если ответ «ЛОЖЬ». Функция может содержать до семи логических условий внутри себя для аргумента «_значение если истина_», а для аргумент «_значение если ложь_» умеет выполнять функции или команды дальнейшего действия (к примеру, использование функции ПЕРЕЙТИ).

Синтаксис функции:

=ЕСЛИ(_лог_выражение_,_значение_если_истина_,_значение_если_ложь_), где:

  • Логическое выражение – указывается практически любое выражение или значение, которое в процессе вычисления получает значение «ИСТИНА» или «ЛОЖЬ»;
  • Значение если истина – это значение, которое будет возвращено, если аргумент «Логическое выражение» получит результат «ИСТИНА». В случае, когда этот аргумент не указан в формуле, возвращается результат «ИСТИНА»;
  • Значение если ложь — это значение, которое будет возвращено, если аргумент «Логическое выражение» получит результат «ЛОЖЬ». В случае, когда этот аргумент опущен в формуле, возвращается результат «ЛОЖЬ».

Пример №1:

Рассмотрим усложнённый пример со многими условиями, вложенными в функцию ЕСЛИ. У нас есть персонал, которому в зависимости от стажа работы, производится доплата к ставке заработной платы. Всего будет три доплаты, стаж работы 3 года – 10%, 10 лет – 20% и 20 лет – 30%. Для получения результата и автоматического расчёта доплаты в зависимости от стажа нам нужна формула такого вида:

=ЕСЛИ(C2>=20;»30%»;ЕСЛИ(C2>=10;»20%»;ЕСЛИ(C2>=3;»10%»;»0%»))).

Logic function 3 Логические функции в Excel. Часть №1

Пример №2:

Рассмотрим еще один сложный пример, в котором мы будем определять, и идентифицировать виды банковских карточек по их номерам. Для первого аргумента используем текстовую функцию ЛЕВСИМВ для захвата первых 4 цифр, которые и будут условием определения. Для карты «Visa Electron» установим идентификатор 1234, для карты «Maestro» — 5678 и все остальные карты будут по умолчанию «MasterCard Standard». Теперь собственно формула, которая поможет нам определить результат будет такова:

=ЕСЛИ( ЛЕВСИМВ (B14;4)= «1234»; «Visa Electron»; ЕСЛИ ( ЛЕВСИМВ (B14;4)=»5678»; «Maestro»; «MasterCard Standard»)).

Абсолютно простая логическая функция ИСТИНА, не имеет никаких аргументов и умеет возвращать всего лишь логическое значение «ИСТИНА». Имеет смысл использовать только в связке с другими функциями.

Синтаксис функции:

=ИСТИНА().

Простая функция ЛОЖЬ аналогична описываемой ранее функции ИСТИНА, но наоборот, умеет возвращать всего лишь логическое значение «ЛОЖЬ» и не имеет никаких аргументов. Её тоже необходимо использовать в тандеме с другими функциями.

Синтаксис функции:

=ЛОЖЬ().

Простая в работе и исполнении логическая функция НЕ умеет только одно, производит замену полученного логического значения своего аргумента на абсолютно противоположный, т.е. он заменяет значение «ЛОЖЬ» на «ИСТИНА» и, наоборот, в другую сторону. Использование функции НЕ, рационально применять в случаях, когда нужна 100%-ная уверенность что некое значение не будет равно некой определённой величине.

Синтаксис функции:

= НЕ(_логическое_значение_), где:

  • Логическое значение – это выражение, ссылка на ячейку или значение, которое как результат вычислений дает логическое значение «ИСТИНА» или «ЛОЖЬ». Функция НЕ при получении такого результата меняет его: «ЛОЖЬ» на «ИСТИНА» и «ИСТИНА» на «ЛОЖЬ».

Пример:

Logic function 10 Логические функции в Excel. Часть №1

Обращаю внимание! Все логические функции в своих выражениях используют знаки сравнения «=», « », « =» или «<>», в результате чего получаются значения «ИСТИНА» и «ЛОЖЬ».

А на этом у меня пока всё, жду вас на страницах второй части статьи! Я очень надеюсь, что описанные всех логических функций в Excel в этой части были ёмкими и понятными. Буду очень благодарен за оставленные комментарии, так как это показатель читаемости и вдохновляет на написание новых статей! Делитесь с друзьями, прочитанным и ставьте лайк!

Не забудьте поблагодарить автора!

Богатство приносит не большое состояние, а скромные потребности.
Эпиктет (Epictetus)

Ссылка на основную публикацию