Как работает формула индекс в excel

Функция ИНДЕКС в Excel

Здравствуйте. Формула ИНДЕКС в Excel возвращает значение из массива по указанному порядковому номеру. Синтаксис функции такой:

=ИНДЕКС( данные ; номер строки ; [номер столбца] ; [номер области] )

Аргумент Описание
Данные Массив или ссылка на массивы, из которых выбираются значения
Номер строки Порядковый номер возвращаемого элемента (если в первом аргументе одномерный массив), или номер строки в выбранном диапазоне
Номер столбца (необязательный аргумент) Порядковый номер столбца в массиве для выводимого элемента
Номер области (необязательный аргумент) Порядковый номер области, при указании нескольких массивов с данными

Простейший способ использования функции – выбор в одномерном массиве:

простая функция ИНДЕКС

В этом примере мы получили продажи менеджера Смирнова в феврале. Достаточно было указать два обязательных аргумента – строку с данными и порядковый номер ячейки в этом диапазоне: =ИНДЕКС(B4:I4;4) .

Две формы применения функции ИНДЕКС

Разработчики предусмотрели две формы представления функции: массив и ссылка.

    В режиме массива вы выбираете координаты выводимой ячейки, т.е. номер строки и столбца:

Функция ИНДЕКС по массиву

В примере на картинке мы получили продажи Кузнецова в феврале. В выбранном диапазоне нужное число находится на пересечении 3 строки и 4 столбца. Поэтому, формула выглядит так: =ИНДЕКС(B4:I18;3;4)

В ссылочном режиме, в качестве первого аргумента (данных) вы указываете ссылки на несколько диапазонов, перечисляете их в скобках через точку с запятой. Соответствено, последним, четвертым аргументом – выбираете, в какой из перечисленных областей находится искомая ячейка.

Функция Индекс по ссылке

На картинке выше есть две области B4:I10 и B12:I19 . Чтобы выбрать продажи менеджера Павлова (он во втором диапазоне), нужно, чтобы последний аргумент был равен 2. И формула будет такой:

В Эксель функция ИНДЕКС редко бывает самостоятельной. Часто она используется в комбинации с другими функциями. Например, ПОИСКПОЗ. Применяя их вместе, можно получить результат, аналогичный ВПР.

Функция ИНДЕКС в Excel и примеры ее работы с массивами данных

Функция ИНДЕКС предназначена для выборки значений из таблиц Excel по их координатам. Ее особенно удобно использовать при работе с базами данных. Данная функция имеет несколько аналогов, такие как: ПОИСКПОЗ, ВПР, ГПР, ПРОСМОТР, с которыми может прекрасно сочетаться в сложных формулах. Но все же гибкость и простота в этой функции на первом месте.

Как работает функция ИНДЕКС в Excel?

Допустим мы работаем с большой таблицей данных с множеством строк и столбцов. Первая строка данной таблицы содержит заголовки столбцов. А в первом столбце соответственно находиться заголовки строк. Пример такой таблицы изображен ниже на рисунке:

База данных.

Задача следующая: необходимо определить какое числовое значение относится к конкретному отделу и к конкретной статьи. Другими словами, необходимо получить значение ячейки на пересечении определенного столбца и строки.

Функция ИНДЕКС в Excel пошаговая инструкция

  1. Ниже таблицы данный создайте небольшую вспомогательную табличку для управления поиском значений: Вспомагательная таблица.
  2. В ячейке B12 введите номер необходимого отдела, который потом выступит в качестве критерия для поискового запроса. Например, 3.
  3. В ячейке B13 введите номер статьи. Например, 7.
  4. В ячейку B14 введите следующую формулу:

В результате получаем значение на пересечении столбца 3 и строки 7:

Выборка значения по индексу.

Как видно значение 40 имеет координаты Отдел №3 и Статья №7. При этом функцией ИНДЕКС не учитываются номера строк листа Excel, а только строки и столбцы таблицы в диапазоне B2:G10.

Описание примера как работает функция ИНДЕКС

В первом аргументе функции указывается диапазон ячеек таблицы, по которому будет выполнен поиск значений на пересечении строк и столбцов. Во втором аргументе сначала указываем номер строки, а потом в третьем аргументе – номер столбца. На основе этой информации функция ищет соответствующее значение в таблице.

Внимание! Для функции ИНДЕКС номера строк и столбцов определяют высоту и ширину таблицы, указанной в ее первом аргументе. Они никак не связаны с номерами рабочего листа Excel и не обязаны соответствовать им.

Ссылка на основную публикацию