Как указать диапазон дат в excel

Как установить диапазон дат в Excel — Вокруг-Дом — 2021

Table of Contents:

Возможность установки диапазонов дат для Excel позволяет выполнять вычисления по датам так же, как и другие числа. Выполнение таких вычислений необходимо, когда вам нужно определить дату исполнения с учетом даты начала и количества дней в диапазоне дат. Чтобы установить диапазон дат в Excel, вы можете отформатировать ячейки, содержащие даты начала и окончания, как даты, а затем использовать операторы «-» и «+» для расчета продолжительности диапазона или даты окончания.

Установить начальную и конечную даты

Шаг 1

Щелкните любую ячейку в таблице Excel, затем перейдите на вкладку «Главная». Щелкните элемент «Короткая дата» в раскрывающемся списке на панели «Номера». Это говорит Excel, чтобы отобразить число, введенное вами в ячейку, в качестве даты.

Шаг 2

Введите любую дату в ячейку, которую вы только что отформатировали, в этом формате «м / д / гггг». Например, введите «01.01.2001».

Шаг 3

Используйте инструкции из шага 1, чтобы отформатировать ячейку в два столбца справа от первой отформатированной ячейки. Введите дату окончания вашего диапазона в этой ячейке.

Шаг 4

Нажмите на ячейку, которая находится между двумя ячейками, содержащими ваши даты, затем нажмите знак «=», чтобы сообщить Excel, что вы вводите формулу вместо числа или текста. Щелкните по ячейке с датой окончания, нажмите «-», чтобы указать расчет вычитания.

Шаг 5

Нажмите дату начала, затем нажмите «Ввод». Excel введет количество дней между начальной и конечной датами.

Установить дату начала и продолжительность

Шаг 1

Щелкните ячейку в электронной таблице, затем щелкните элемент «Короткая дата» на вкладке «Главная» на панели «Числа».

Шаг 2

Введите дату начала вашего диапазона. Например, введите «01.01.2001».

Шаг 3

Щелкните ячейку справа от даты начала, а затем введите количество дней, которое вы хотите для своего диапазона дат. Например, если ваш диапазон охватывает три дня, введите «3» в ячейку.

Шаг 4

Используйте инструкции из шагов 1 для форматирования следующей ячейки справа в качестве короткой даты. Нажмите «=», чтобы указать формулу, затем щелкните ячейку даты начала, а затем нажмите «+».

Шаг 5

Нажмите на ячейку слева, затем нажмите «Enter». Excel вычислит дату окончания вашего диапазона, добавив дату начала к числу в ячейке слева, которое является числом дней в вашем диапазоне.

Диапазон дат в одной ячейке (в текстовом формате) в EXCEL

history 6 августа 2014 г.
    Группы статей

  • Месяц
  • Пользовательский формат
  • Срок, Возраст, Стаж

Выведем диапазон дат (начальная — конечная дата) в одной ячейке в формате 21-25.10.2012.

Пусть задана начальная дата (ячейка B7 ) и длительность периода (ячейка B8 ), выведем диапазон дат в одной ячейке в формате 21-25.10.2012 (см. файл примера ).

Это можно сделать с помощью формулы = ТЕКСТ(B7;"дд")&"-"&ТЕКСТ(B7+B8;"дд.ММ.гггг")

Совет : О пользовательском формате дат можно прочитать в статье Пользовательский формат ДАТЫ и ВРЕМЕНИ в MS EXCEL

Это решение, однако, не учитывает, что начальная и конечная дата могут принадлежать разным месяцам. В этом случае формула может вернуть, например 21-05.10.2012, что довольно сложно для понимания. Поэтому, изменим формулу: =ТЕКСТ(B7;ЕСЛИ(МЕСЯЦ(B7)-МЕСЯЦ(B7+B8);"дд.ММ";"дд"))&"-"&ТЕКСТ(B7+B8;"дд.ММ.гггг")

Теперь. если начальная и конечная даты принадлежат разным месяцам, то у начальной даты будет дополнительно выводиться месяц.

Диапазон с указанием месяца и года

Более простым случаем является вывод начальной даты с указанием месяца и года (что позволяет корректно учесть случай, когда даты принадлежат разным годам). В этом случае нужно использовать формулу = ТЕКСТ(B13;"дд.ММ.гггг")&"-"&ТЕКСТ(B13+B14;"дд.ММ.гггг")

В формуле предполагается, что начальная дата введена в ячейку B13 , а длительность периода введена в ячейку B14 .

Диапазон в пределах 1 месяца

Иногда требуется, чтобы начальная и конечная даты принадлежали одному месяцу. В этом случае в формуле необходимо провести проверку: не выходит ли конечная дата за границы месяца. Если конечная дата выходит за границы месяца, то она заменяется последней датой месяца.

= ЕСЛИ(B19=КОНМЕСЯЦА(B19;0);"Последний день месяца";ТЕКСТ(B19;"дд")&"-"&ТЕКСТ(B19+МИН(B20;КОНМЕСЯЦА(B19;0)-B19);"дд.ММ.гггг"))

В формуле предполагается, что начальная дата введена в ячейку B19 , а длительность периода введена в ячейку B20 .

Ссылка на основную публикацию