Как сделать нумерацию строк в excel с фильтром

Автоматическая перенумерация строк при применении фильтра в EXCEL

history 18 апреля 2013 г.
    Группы статей

  • Нумерация строк/ столбцов
  • Последовательности Чисел

При применении фильтра строки скрываются целиком. Если в таблице имелась нумерация строк, то она будет сбита. Но, есть способ обойти эту проблему.

Пусть имеется таблица с нумерацией строк (в столбце введены числа от 1 до 16).

Если к таблице применить фильтр (нажав в строке заголовков таблицы CTRL+SHIFT+L и установив критерии отбора), то нумерация строк будет сбита (см. столбец А ).

Для того, чтобы сохранить нумерацию строк, используем вместо последовательности констант (от 1 до 16) — формулу.

Решение основано на использовании функции ПРОМЕЖУТОЧНЫЕ.ИТОГИ() , которая «чувствует», когда строка скрыта фильтром .

Столбец с нумерацией расположим в столбце А (заголовок таблицы разместим в строке 6 ). Полезные данные, которые вводятся БЕЗ ПРОПУСКОВ, расположим в столбце В (см. Файл примера ):

Записав в ячейке A 7 формулу =ЕСЛИОШИБКА(ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;B7);A6+1;A6);1)

и скопировав ее в ячейки ниже, получим желаемый результат. Если строка скрыта, то функция ПРОМЕЖУТОЧНЫЕ.ИТОГИ() возвращает 0 (ЛОЖЬ) и счетчик номера строки не увеличивается на 1, а остается, как у предыдущей строки.

После применения фильтра нумерация строк таблицы автоматически изменится.

Автоматическая нумерация строк

В этом курсе:

  • Автоматическая нумерация строк
    Статья
  • Вычисление разности двух дат
    Статья
  • Определение и использование имен в формулах
    Статья
  • Объединение текста из двух или нескольких ячеек в одну
    Статья

Автоматическая нумерация строк

В отличие от других программ Microsoft Office, в Excel нет кнопки автоматической нумерации данных. Однако можно легко добавить последовательные числа в строки данных путем перетаскивания маркер заполнения для заполнения столбца последовательностью чисел или с помощью функции СТРОКА.

Совет: Если необходима более совершенная система автоматической нумерации и на компьютере установлено приложение Access, можно импортировать данные Excel в базу данных Access. В ней можно создать поле, которое автоматически генерирует уникальный номер при добавлении в таблицу новой записи.

В этой статье

Заполнение столбца последовательностью чисел

Выделите первую ячейку в диапазоне, который необходимо заполнить.

Введите начальное значение последовательности.

Введите значение в следующей ячейке, чтобы задать образец заполнения.

Совет: Например, если требуется задать последовательность 1, 2, 3, 4, 5. введите в первые две ячейки значения 1 и 2. Если необходимо ввести последовательность 2, 4, 6, 8. введите значения 2 и 4.

Выделите ячейки, содержащие начальные значения.

Примечание: В Excel 2013 и более поздних годах кнопка "Быстрый анализ" отображается по умолчанию при выборе более одной ячейки с данными. Для завершения этой процедуры кнопку можно проигнорировать.

Перетащите маркер заполнения диапазон, который вы хотите заполнить.

Примечание: По мере перетаскивания маркера заполнения через ячейки Excel показывает предварительное значение. Чтобы изменить образец, перетащите маркер заполнения, удерживая нажатой правую кнопку мыши, а затем выберите образец.

Чтобы ввести последовательность в возрастающем порядке, перетащите маркер вниз или вправо. Чтобы ввести последовательность в убывающем порядке, перетащите маркер вверх или влево.

Совет: Если маркер заполнения не виден, возможно, его сначала необходимо отобразить. Дополнительные сведения см. в статье Отображение или скрытие маркера заполнения.

Примечание: При добавлении, перемещении или удалении строк эти числа автоматически не обновляются. Последовательную нумерацию можно обновить вручную, выбрав два числа в правильной последовательности и перетащив маркер заполнения в конец нумерованного диапазона.

Нумерация строк с помощью функции СТРОКА

Введите в первую ячейку диапазона, который необходимо пронумеровать, формулу =СТРОКА(A1).

Функция СТРОКА возвращает номер строки, на которую указана ссылка. Например, функция =СТРОКА(A1) возвращает число 1.

Перетащите маркер заполнения , охватив диапазон, который необходимо заполнить.

Совет: Если маркер заполнения не виден, возможно, его сначала необходимо отобразить. Дополнительные сведения см. в статье Отображение или скрытие маркера заполнения.

Эти числа обновляются при сортировке данных. При добавлении, перемещении или удалении строк последовательность может быть прервана. Последовательность можно обновить вручную, выбрав два числа в правильной последовательности и перетащив маркер заполнения в конец нумерованного диапазона.

Если вы используете функцию СТРОКА и хотите, чтобы числа вставлялись автоматически при добавлении новых строк данных, преобразуйте диапазон данных в таблицу Excel. Все строки, добавленные в конец таблицы, последовательно нумеруются. Дополнительные сведения см. в статье Создание и удаление таблицы Excel на листе.

Для ввода определенных последовательных числовых кодов, например кодов заказа на покупку, можно использовать функцию СТРОКА вместе с функцией ТЕКСТ. Например, чтобы начать нумерованный список с кода 000-001, введите формулу =ТЕКСТ(СТРОКА(A1),"000-000") в первую ячейку диапазона, который необходимо пронумеровать, и перетащите маркер заполнения в конец диапазона.

Отображение или скрытие маркера заполнения

По маркер заполнения отображается по умолчанию, но вы можете включить или отключить его.

В Excel 2010 и более поздних для этого выберите вкладку Файл и нажмите кнопку Параметры.

В Excel 2007 нажмите кнопку Microsoft Office и выберите Excel параметры.

В категории Дополнительно в разделе Параметры правки установите или снимите флажок Разрешить маркеры заполнения и перетаскивание ячеек, чтобы отобразить или скрыть маркер заполнения.

Примечание: Чтобы предотвратить замену имеющихся данных при перетаскивании маркера заполнения, по умолчанию установлен флажок Предупреждать перед перезаписью ячеек. Если не требуется, чтобы приложение Excel выводило сообщение о перезаписи ячеек, можно снять этот флажок.

Ссылка на основную публикацию