Как найти количество засушливых месяцев в excel
Перейти к содержимому

Как найти количество засушливых месяцев в excel

Как найти количество засушливых месяцев в excel

Урок №5
ОБРАБОТКА ДАННЫХ МЕТЕОСТАНЦИИ.

  • закрепить навыки по использованию функций Excel;
  • научиться решать типовые задачи по обработке массивов с использованием электронных таблиц;
  • познакомиться с логическими функциями Excel

Постановка задачи.
Имеется таблица, содержащая количество осадков в миллиметрах, построенная на основе наблюдений метеостанции г.Екатеринбурга.

картинка excel

Определить для всей таблицы е целом:
1) минимальное количество осадков, выпавшее за 3 года;
2) суммарное количество осадков, выпавшее за 3 года;
3)среднемесячное количество осадков по итогам 3-летних на­блюдений;
4)максимальное количество осадков, выпавшее за 1 месяц, по итогам 3-летних наблюдений;
5) количество засушливых месяцев за все 3 года, в которые выпало меньше 10 мм осадков.
Данные оформить в виде отдельной таблицы.

картинка excel

Те же данные определить для каждого года и оформить в виде отдельной таблицы 3 (рис. 5.3).

картинка excel

Дополнительно для каждого года определить:
1) количество месяцев в году с количеством осадков в преде­лах (>20; 100) мм.

картинка excel

При вводе года в таблице должны отражаться данные именно за этот год, в случае некорректного ввода должно выдаваться со­общение "данные отсутствуют".
Структура электронной таблицы позволяет использовать ее для решения задач, сходных с задачами обработки массивов. В качестве одномерных массивов можно рассматривать строки или столбцы электронной таблицы, заполненные однотипны­ми числовыми или текстовыми данными. Аналогом двумерно­го массива является прямоугольная область таблицы, также заполненная однотипными данными.
В нашей задаче область B5:D16 исходной таблицы можно рассматривать как двумерный массив из 3 столбцов и 12 строк, а данные по каждому году В5:В16; С5:С16; D5:D16 как одномерные массивы по 12 элементов каждый.
Возможности электронной таблицы Excel: использование формул и большой набор встроенных функций, абсолютная адресация, операции копирования позволяют решать типовые задачи по обработке одномерных и двумерных массивов.

ХОД РАБОТЫ:

ЗАДАНИЕ 1. Заполните таблицу согласно рисунку и оформите ее по своему усмотрению.

ЗАДАНИЕ 2. Сохраните таблицу на диске в личном каталоге под именем work5.xls

ЗАДАНИЕ 3. На том же листе создайте и оформите еще 2 таб­лицы, как показано на рисунках.

ЗАДАНИЕ 4. Заполните формулами ячейки G5: G8 таблицы 2 для обработки двумерного массива В5 : D16 (данные за 3 года).
Используя мастер функций, занесите формулы:
4.1. В ячейку G5 =МАКС (B5:D16)
4.2. В ячейку G6= МИН (B5:D16) и так далее в соответствии с требуемой обработкой двумерного массива B5:D16
4.3. Определите количество засушливых месяцев за 3 года.
Для определения воспользуйтесь функцией СЧЕТ ЕСЛИ, ко­торая подсчитывает количество непустых ячеек, удовлетворяю­щих заданному критерию внутри интервала.

Формат функции

СЧЕТ ЕСЛИ (интервал; критерии).
Воспользуйтесь мастером функций, на 2 шаге укажите интер­вал B5:D16 и критерий ; ; ) Первый аргумент функции ЕСЛИ — логическое выражение (в частном случае условное выражение), которое принимает одно из двух значений: "Истина" или "Ложь". В первом случае функ­ция ЕСЛИ принимает значение выражения 1, а во втором слу­чае — значение выражения 2.
Пример.
В ячейке H5 нужно записать максимальное из двух чисел, содержащихся в ячейках Н2 и Н5.
Формула, введенная в ячейку Н5: = ЕСЛИ (Н2>Н5; Н2; Н5) означает, что если значение ячейки Н2 больше значения ячейки Н5, то в ячейке Н5 будет записано значение из Н2, в противном случае — из Н5.
В качестве выражения 1 или выражения 2 можно записать вложенную функцию ЕСЛИ. Число вложенных ЕСЛИ не должно превышать семи. На месте логического выражения можно использовать одну из логических функций «И» или «ИЛИ».

Формат функций

И( ; . ) ИЛИ( ; . )

В скобках может быть указано до пятидесяти логических вы­ражений. Функция И принимает значение "Истина", если одновременно все логические выражения истинны. Функция ИЛИ принимает значение "Истина", если хотя бы одно из логических выражений истинно.
Пример.
Определить, входит ли в заданный диапазон (5;10) число, со­держащееся в ячейке Н10. Ответ 1(если число принадлежит диа­пазону) и 0 ( если число не принадлежит диапазону) должен быть получен в ячейке Н12.
В ячейку Н12 вводится формула:
— ЕСЛИ (И (Н10>5; Н10 20 ; 100) мм.
13.1. Создайте вспомогательную таблицу для оп­ределения месяцев с количеством осадков в пределах
(>20; 20;В5 20; 100)(формулу необходимо изменить в соответствии с условием).
13.7.В ячейку G17 занесите формулу:

=ЕСЛИ(год=1992;В33;ЕСЛИ (год=1993;С33;ЕСЛИ(год=1995;D33; «данные отсутствуют»))).
13.8. Скопируйте эту формулу в ячейки G18 и отредактируйте.
13.9. Оформите на свой вкус вспомогательные таблицы и добавьте к ним заголовки и обозначения.

ЗАДАНИЕ14. Сохраните результат работы под тем же именем work5.xls в личном каталоге.

ЗАДАНИЕ 15. Подведите итоги.

Проверьте:
Знаете ли вы:

Практическая работа №4 «Количество осадков»

Переименуйте «Лист 4» в лист «Осадки».

Составьте таблицу «Количество осадков (мм )»

Таблица построена на основании наблюдений метеостанции города N

Количество осадков (мм)

Всего осадков:

Определите для всей таблицы в целом:

Минимальное количество осадков, выпавшее за три года.

Суммарное количество осадков, выпавшее за три года.

Среднемесячное количество осадков по итогам 3-летних наблюдений.

Максимальное количество осадков, выпавшее за месяц, по итогам 3-летних наблюдений;

Количество засушливых месяцев за все 3 года, в которые выпало меньше 10 мм осадков.

Количество дождливых месяцев за все 3 года, в которые выпало больше 100 мм осадков.

Результаты представьте в виде дополнительной таблицы. Для нахождения указанных значений создайте макросы. Привяжите созданные макросы к заранее подготовленным графическим объектам.

Данные за 2003-2005 годы

Макс. кол-во осадков за 3 года (мм)

Мин. кол-во осадков за 3 года (мм)

Суммарное кол-во осадков за 3 года (мм)

Среднемесячное кол-во осадков за 3 года (мм)

Кол-во засушливых месяцев за 3 года ( 100 мм)

Создайте макрос для очистки ячеек с полученными результатами. Привяжите макрос к графическому объекту.

7. Ваш лист должен выглядеть так:

Основная таблица располагается в диапазоне B5:E18

Начиная с ячейки G5, находится дополнительная таблица вопросов и ответов.

Ячейка C18 содержит формулу: =СУММ(C6:C17);

Ячейка D18 содержит формулу: =СУММ(D6:D17);

Ячейка E18 содержит формулу: =СУММ(E6:E17);

Подготовьте макрос для нахождения максимального и минимального количества осадков за 3 года. Привяжите созданный макрос к графическому объекту.

Ячейка H6 содержит формулу: =МАКС(C6:E17);

Ячейка H7 содержит формулу: =МИН (C6:E17);

Подготовьте макрос для нахождения суммарного и среднемесячного количества осадков за 3 года. Привяжите созданный макрос к графическому объекту.

Ячейка H8 содержит формулу: =СУММ(C6:E17);

Ячейка H9 содержит формулу: =СРЗНАЧ(C6:E17);

Подготовьте макрос для нахождения количества засушливых и дождливых месяцев за 3 года. Привяжите созданный макрос к графическому объекту.

Ячейка H10 содержит формулу: =СЧЕТЕСЛИ(B3:D14; 10);

Подготовьте макрос для очистки диапазона ячеек H5;H11. Привяжите созданный макрос к графическому объекту.

Практическая работа №5 «Работа с автоформой»

Переименуйте «Лист 5» в лист «Список класса»

Составьте таблицу и заполните первую строку:

Добавить комментарий

Ваш адрес email не будет опубликован.