Как создать кроссворд в excel с проверкой пошагово

REDMOND

Делаем кроссворд в Excel

Составление кроссвордов в программе Microsoft Excel более желательно, нежели проделывание подобной процедуры в Word. Дело в том, что функционал Excel позволяет создать этот сканворд быстрее, плюс, имеется возможность создать проверку для кроссворда. В Word такой возможности.

Ранее мы уже разбирали, как создать кроссворд в MS Word. Рекомендуем ознакомиться с этой статьёй для лучшего понимания.

  1. Как создать кроссворд в Excel
  2. Этап 1: Создаём сканворд
  3. Этап 2: Проверка правильности

Как создать кроссворд в Excel

Для начала лучше обдумать структуру кроссворда заранее и начертить её где-нибудь на бумаге. Можно найти в сети уже готовый сканворд и скопировать его структуру. Когда всё будет готово переходите в интерфейс Excel.

Этап 1: Создаём сканворд

Задать саму структуру будущего кроссворда можно, если выполнить следующие действия:

  1. Запустите Excel. Как видите, ячейки здесь прямоугольные. Они не подходят для создания кроссворда, поэтому придётся поменять их форму. Выделите вся ячейки на листе, воспользовавшись сочетанием клавиш Ctrl+A.
  2. Нажмите правой кнопкой мыши по выделению. Из контекстного меню выберите вариант «Высота строки».

Откроется окошко с настройками высоты строки. Здесь задайте любое удобное вам значение, но не сильно большое. Например, мы установим высоту в 20 единиц. Жмите «Ок» для применения изменений.

  • Теперь кликните правой кнопкой мыши по названию любого столбца. Из контекстного меню выберите вариант «Ширина столбца».
  • Установите здесь значение 3 и нажмите «Ок».
  • Определитесь с размером кроссворда в вертикальном и горизонтальном положении. Сделайте выделение области в соответствии с тем, сколько клеток вы запланировали в сканворде.
  • Теперь в верхней строке, в блоке инструментов «Шрифт», кликните по кнопке «Граница». Из контекстного меню выберите «Все границы».
  • Границы, которые очерчивают сканворд успешно установлены. Теперь выделите те его части, которые не нужны в кроссворде, то есть куда ничего не будет вписываться. В блоке инструментов «Редактирование» нажмите на кнопку в виде ластика. Таким образом вы удалите выделение у тех участков, где оно не требуется.

  • Дополнительно можно выделить каким-нибудь акцентным цветом главную полосу кроссворда. Выделите эту полосу и измените у неё цвет с помощью инструмента заливки, что расположен в блоке «Шрифт».
  • Основная структура кроссворда готова, теперь осталось только пронумеровать строки и столбцы, а также прописать вопросы в отдельном блоке.

    1. Выделите ячейку около нужной строки/столбца. Поставьте в ней номер данной ячейки. Если цифра номера слишком большая, то вы можете уменьшить её, выбрав соответствующий размер в блоке инструментов «Шрифт». Также можно настроить выравнивание цифры в соответствующем блоке.
    2. Теперь нужно выделить область, в которую будут записаны вопросы. Её размер может быть произвольным, главное, чтобы все данные поместились в указанной области.
    3. В выделенной области нужно убрать разбиение на ячейки. Нажмите по ней правой кнопкой мыши и выберите из контекстного меню «Объединить ячейки».

  • Вставьте туда заранее подготовленный текст или пропишите вопросы вручную.
  • Этап 2: Проверка правильности

    Вы можете также сделать проверку кроссворда в Excel. Правда, она будет доступна только для тех пользователей, которые разгадывают его в электронном виде. Для печати функция проверки недоступна.

    Делается проверка готового кроссворда следующим образом:

    1. Создайте дополнительный лист для таблицы. Здесь запишите ответы в формате таблицы. Разделите её на столбцы:
      • «Ответы». Сюда вписываются сами ответы на вопросы;
      • «Введено». В этом столбце вписываются данные, которые пользователь ввёл;
      • «Совпадения». Здесь Excel будет сверять данные введённые пользователем с ответами;
      • Ещё внизу можно создать блок «Итого», где будет подсчитана сумма верных ответов.

    2. Переключитесь на первую ячейку столбца «Введено». Здесь нужно задать специальную функцию. Нажмите на кнопку в виде буквы «f» около строки ввода данных.
    3. Будет открыт мастер создания функций. В нём найдите функцию, которая называется «Сцепить». Выберите её и нажмите «Ок», чтобы она применилась.
    4. Откроется окошко задания аргументов для функции. Здесь нужно нажать на кнопку в виде таблички, что расположена около строки ввода аргумента.
    5. Переключитесь на первый лист и выберите все ячейки той строки, которая соответствуют нужному вопросу.
    6. Проделайте аналогичную операцию с другими ответами.
    7. Теперь переключитесь на первую ячейку совпадений. Сюда нужно задать функцию «Если». Она будет иметь следующий вид: «=ЕСЛИ(номер_ячейки_ответа=номер_ячейки_введено;1;0)». Вот так она выглядит у нас: «=ЕСЛИ(A4=B4;1;0)». То есть, если ответ пользователя совпадает с записанным в таблице ответом, то в «Совпадение» пишется один балл. В противном случае ставится 0.

      REDMOND

    8. Переключитесь к строке «Итого». Здесь нужно прописать функцию «СУММ», чтобы суммировать полученные баллы. В скобках этой функции проставьте номера ячеек, которые требуется просуммировать.
    9. Осталось только вписать завершающую функцию на первом листе с кроссвордом, которая будет выдавать, правильно ли он решён или нет.

      1. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу. Именно от этого числа нужно будет составлять дальнейшую формулу.
      2. Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

      Теперь, если пользователь ответил на один или несколько вопросов неверно, то система предложит ему подумать ещё. В противном случае Excel оповестит человека о том, что он решил кроссворд правильно.

      Как сделать в Excel кроссворд

      Программы из пакета Mircosoft Office предназначены для работы с документами в самых разных их проявлениях. За время, прошедшее с момента запуска пакета и до сегодняшнего дня, каждая из этих программ обросла множеством полезных и важных функций, так что пользователь может выполнить практически любую операцию всего парой нажатий мышью.

      Создание кроссворда в Excel

      Специальные функции позволяют автоматизировать процесс работы

      Однако есть вещи, которые сделать не так просто. Например, в Excel — программе для работы с таблицами — компания встроила механизм функций, которые может использовать пользователь. С их помощью можно обрабатывать самые разные данные. Но автору придётся лично выстраивать модель взаимодействия, вводя формулы и указывая диапазоны данных.

      Нужно учитывать также то, что перед пользователем встают иногда весьма нетривиальные задачи — как, например, создать кроссворд в Excel. Понятно, что в самой программе такой функции нет, так что нужно будет кое-что всё же выполнить вручную.

      Первый этап

      Перед тем как начать создание кроссворда с проверкой в Excel, вам нужно определиться со списком вопросов и ответов. Мы рекомендуем завести для этого отдельный файл и сразу вписать строчки так, как они должны выглядеть в результате работы. После этого откройте программу; необходимо создать новую книгу, если она не создаётся автоматически. Это нужно потому, что наш способ будет использовать одновременно два рабочих листа, поэтому целесообразно выделить их в отдельный файл. Итак, переименуем «Лист 1» так, как вам удобно. По сути, его имя может быть произвольным, главное, чтобы вы его потом не меняли. На этом листе с помощью границ нужно нарисовать контур будущего кроссворда.

      Выделяем ячейки по горизонтали или вертикали, находим в ленте настроек вкладку «Разметка страницы» и нажимаем на кнопку «Границы». Если вам недостаточно появившихся на экране вариантов, смело выбирайте свои в одноимённом пункте. Теперь на листе у нас появился контур одного из слов. Нужно повторить это столько раз, сколько вопросов вы хотите включить в своё творение. Не забывайте ставить числа в первые ячейки, чтобы потом не пришлось вспоминать, какое именно слово должно быть сюда вписано.

      Если вам не нужно делать кроссворд с проверкой, Excel можно закрывать, так как на этом собственно рисование заканчивается. Вы можете, например, вставить его в Ворд или просто распечатать, чтобы получить на листе бумаги нарисованную сетку с пересечениями в нужных местах. При должной сноровке вы можете даже «Заливкой ячейки» закрасить некоторые из них чёрным цветом, чтобы получить стилизацию под напечатанный в газете кроссворд. Однако это самый простой вариант.

      Добавление нужных границ

      Заливка цветом отдельных ячеек

      Второй этап

      Если проверять впечатанные пользователем слова всё же нужно, придётся немного схитрить. Дело в том, что фоновую проверку слов, чтобы пользователь её не видел, можно осуществить разве что с помощью макросов. Но если воспользоваться встроенными средствами Excel, то можно добиться похожего результата. Для этого скопируйте лист с кроссвордом, щёлкнув по нему правой кнопкой мыши. Полученный лист переименуйте (имя тоже может быть произвольным). В клетки кроссворда, сделанного на втором листе Excel, впишите ответы — это нужно будет для проверки правильности введённых пользователем букв.

      Теперь рядом с кроссвордом сделайте небольшую табличку из двух столбцов. В первом будет указан номер вопроса, во втором — результат отгадки. Используем интуитивно понятную систему: 1 — если ответ правильный, и 0 — во всех остальных случаях. Наш кроссворд не будет учитывать сделанные пользователем опечатки, так что они тоже будут туда попадать.

      Теперь нужно в ячейки второго столбца нашей проверочной таблицы добавить формулу. Её суть в том, чтобы сравнивать диапазон ячеек на первом листе с аналогичным диапазоном на втором. Диапазоны — слова в кроссворде. Если они совпадают, то в столбец на этой строке заносится единица, если нет — ставится ноль. Провести такую проверку можно с помощью оператора сравнения, формула в общем виде будет выглядеть примерно так: =ЕСЛИ((Кроссворд.D1=Ответ.D1) И (Кроссворд.D2=Ответ.D2) И … ) ТО 1 ИНАЧЕ 0.

      Как видите, она не очень-то сложная, правда, выстраивать диапазон ячеек вам нужно очень внимательно. Кстати, именно для того, чтобы сделать кроссворд с проверкой в Excel, мы копировали заполненный кроссворд на второй лист. Это гарантирует, что ячейки на проверочном листе находятся по тем же адресам, что и на основном.

      Таблица для проверки ответов

      Последние штрихи: на листе с кроссвордом можно сделать счётчик количества правильно отгаданных слов, чтобы пользователь ориентировался в нём. Для этого просто суммируем данные из второго столбца проверочной таблицы. Ну, и осталось только скрыть этот лист, щёлкнув по нему правой кнопкой мыши и выбрав одноимённый параметр.

      Счётчик отгаданных слов

      Заключение

      Решение этой, на первый взгляд нетривиальной задачи на поверку оказывается не таким уж сложным. Используя гибкость встроенных функций Excel, вы можете создавать кроссворды как с проверкой, так и без неё, причём делать это так, как считаете нужным. Ведь мы описали только один из возможных способов.

      REDMOND

      Ссылка на основную публикацию