Как посчитать ячейки с текстом в excel
Перейти к содержимому

Как посчитать ячейки с текстом в excel

Подсчет ТЕКСТовых значений (в диапазонах с ТЕКСТом и ЧИСЛАми) в EXCEL

history 18 апреля 2013 г.
    Группы статей

  • Подсчет текстовых значений

Подсчитаем количество ячеек содержащих текст. Предполагаем, что диапазон содержит и текст и числа и пустые ячейки.

Пусть диапазон суммирования находится в ячейках A1:A10 . Предположим, что диапазон содержит и текст и числа и пустые ячейки. Функция СЧЁТЗ() подсчитает и текст и числа, поэтому она не годится.

Подсчитаем количество ячеек содержащих текстовые значения с помощью других формул (см. файл примера ):

или другой вариант: =СУММПРОИЗВ(—ЕТЕКСТ(A1:A10)) или =СУММПРОИЗВ(ЕТЕКСТ(A1:A10)+0)

еще варианты: =СЧЁТЗ(A1:A10)-СЧЁТ(A1:A10) =СЧЁТЕСЛИ(A1:A10;"*?")

Если число находится в текстовом формате, то оно также будет подсчитано. Если нужно подсчитать только те значения, которые не могут быть преобразованы в число, то нужно использовать формулу массива : =СУММ(ЕСЛИ(ЕОШ(A1:A10+0);1;0))

Способы подсчета количества ячеек в диапазоне с данными

В Excel есть несколько функций, позволяющих подсчитать число пустых ячеек или ячеек с данными определенного типа в диапазоне.

Щелкните ячейку, в которой должен выводиться результат.

На вкладке Формулы щелкните Другие функции, наведите указатель мыши на пункт Статистические и выберите одну из следующих функции:

СЧЁТЗ: подсчитывает количество непустых ячеек.

СЧЁТ: подсчитывает количество ячеек, содержащих числа.

СЧИТАТЬПУСТОТЫ: подсчитывает количество пустых ячеек.

СЧЁТЕСЛИ: подсчитывает ячейки, отвечающие заданным условиям.

Совет: Чтобы ввести нескольких условий, используйте вместо этого функцию СЧЁТЕСЛИМН.

Выделите диапазон ячеек и нажмите клавишу RETURN.

Щелкните ячейку, в которой должен выводиться результат.

На вкладке Формулы щелкните Вставить, наведите указатель мыши на пункт Статистические и выберите одну из следующих функции:

СЧЁТЗ: подсчитывает количество непустых ячеек.

СЧЁТ: подсчитывает количество ячеек, содержащих числа.

СЧИТАТЬПУСТОТЫ: подсчитывает количество пустых ячеек.

СЧЁТЕСЛИ: подсчитывает ячейки, отвечающие заданным условиям.

Совет: Чтобы ввести нескольких условий, используйте вместо этого функцию СЧЁТЕСЛИМН.

Выделите диапазон ячеек и нажмите клавишу RETURN.

Добавить комментарий

Ваш адрес email не будет опубликован.