Как указать пустую ячейку в формуле excel

Как указать пустую ячейку в формуле excel

Использование функции ЕСЛИ для проверки ячейки на наличие символов

Иногда требуется проверить, пуста ли ячейка. Обычно это делается, чтобы формула не выводила результат при отсутствии входного значения.

Ячейка E2 содержит формулу =ЕСЛИ(D2=1;

В данном случае мы используем ЕСЛИ вместе с функцией ЕПУСТО:

Эта формула означает: ЕСЛИ(ячейка D2 пуста, вернуть текст "Пустая", в противном случае вернуть текст "Не пустая"). Вы также можете легко использовать собственную формулу для состояния "Не пустая". В следующем примере вместо функции ЕПУСТО используются знаки "". "" — фактически означает "ничего".

Проверка пустоты ячейки — ячейка E2 содержит формулу =ЕСЛИ(ЕПУСТО(D2);

Эта формула означает: ЕСЛИ(в ячейке D3 ничего нет, вернуть текст "Пустая", в противном случае вернуть текст "Не пустая"). Вот пример распространенного способа использования знаков "", при котором формула не вычисляется, если зависимая ячейка пуста:

ЕСЛИ(в ячейке D3 ничего нет, не возвращать ничего, в противном случае вычислить формулу).

Как указать пустую ячейку в формуле excel

Регистрация на форуме тут, о проблемах пишите сюда — alarforum@yandex.ru, проверяйте папку спам! Обязательно пройдите активизацию e-mail, а тут можно восстановить пароль.

Поиск по форуму
Расширенный поиск
К странице.
Страница 1 из 2 1 2 Следующая >

А что, "пусто" от "пустой строки" сильно отличается ?

это те значения, которые имеют ячейки при открытии новой книги, а не ноль и не пустой текст

__ Полезные надстройки для Excel. Парсинг сайтов и файлов.
Макросы любой сложности на заказ. Мониторинг цен конкурентов

EducatedFool
Посмотреть профиль
Найти ещё сообщения от EducatedFool

А что, "пусто" от "пустой строки" сильно отличается ?

Позвольте узнать, каким способом Вы определили, что ячейки вновь создаваемой книги какие-то "особо пустые"?

позвольте, в ячейке ="" — записана формула, естесственно она неПУСТО.
Если в ячейке есть формула, то она уже никогда не будет "ЕПУСТО", какой бы результат не возвращала

как вычислить посредством формулы, чтобы значение ячейки равнялось "пусто"
Определяется применением функции ЕПУСТО(): к девственной ячейке — получается значение ИСТИНА и к ячейке ="" — получается значение ЛОЖЬ

А Вы проверять это пробовали?

Ввожу в ячейку формулу =ЕПУСТО(A4)
В ячейку А4 ввожу данные — формула выдаёт ЛОЖЬ
Удаляю данные (клавишей Delete) — формула выдаёт опять ИСТИНА.

Что, "девственность ячейки" восстановилась?

__ Полезные надстройки для Excel. Парсинг сайтов и файлов.
Макросы любой сложности на заказ. Мониторинг цен конкурентов

EducatedFool
Посмотреть профиль
Найти ещё сообщения от EducatedFool

позвольте, в ячейке ="" — записана формула, естесственно она неПУСТО.
Если в ячейке есть формула, то она уже никогда не будет "ЕПУСТО", какой бы результат не возвращала

Вы несколько неправильно понимаете и вот почему.

Применением функции (в частности ЕПУСТО() ) к ячейке в качестве её аргумента используется именно значение ячейки, а не её содержание (формула).

Пример: в ячейке А1 запишем форумулу =""
Значение ячейки будет пустая строка (текст). Проверка — запишите в ячейке B1 формулу =ЕТЕКСТ(А1). Значение получится ИСТИНА.

А Вы проверять это пробовали?

Ввожу в ячейку формулу =ЕПУСТО(A4)
В ячейку А4 ввожу данные — формула выдаёт ЛОЖЬ
Удаляю данные (клавишей Delete) — формула выдаёт опять ИСТИНА.

Что, "девственность ячейки" восстановилась?

Конечно, перед тем выкладывать пример проверяю его.

Вы совершенно правильно описали пример. Удаляя содержимое ячейки клавишей Delete, ячейка принимает значение ПУСТО. Я это понимаю именно так — "девственность ячейки" восстановилась. Т.е. значение не есть число или текст (частный случай текста пустая строка "").

Я же спрашивал как, например, формулой ЕСЛИ( лог_выражение; ячейка_принимает_значение_пусто ; [значение_если_ложь] ) определить значение ячейки как "ПУСТО".

Ссылка на основную публикацию