Как сделать аргументы функции в excel

Как в Excel функции использовать: несколько простых правил

Здравствуйте, друзья! Это вводная статья о функциях Excel, где я расскажу, что такое функции, аргументы функции, как вставить функцию в формулу. А в следующих постах мы будем разбираться, какие есть функции Эксель и как их правильно использовать.

Функции в Excel – это инструкции, которые выполняют более сложные расчеты, чем математические операторы. Некоторые расчеты невозможно выполнить без функций, поэтому их идеальное знание — залог вашего успеха.

Вы можете «вкладывать» одну функцию в другую, копировать формулы с функциями (не забываем о разных типах ссылок). Главное – чётко понимать, как работает функция, иначе она может дать неверный результат или ошибку. Вы можете и не заметить этого. А чтобы разобраться в работе функций – читайте мои посты о различных функциях и справку Microsoft.

С появлением каждой новой версии Эксель, перечень функций обновляется. Разработчики добавляют новые, востребованные, убирают функции, которые уже не актуальны. В этом блоге я буду описывать функции Microsoft Excel 2013, но отвечу на все вопросы о функциях в других версиях программы. Как всегда, задавайте их в комментариях.

Аргументы функции Excel

Аргументы функций – это исхоные данные для расчета функции. Например, для функции СУММ (суммирование) – это перечень чисел, ячеек или диапазонов ячеек для суммирования. Аргументы указываются в скобках после имени функции и разделяются точкой с запятой (в англоязычной версии — запятой). По количеству аргументов, функции могут быть:

  • Без аргументов – не нуждаются в аргументах для расчета. Например, =ПИ() – возвращает число 3,1428.
  • С одним аргументом – нужно ввести всего один аргумент. Например =СТРОЧН(А1) – переведёт в строчный вид все символы в ячейке А1.
  • С несколькими аргументами – нужно ввести определенное число аргументов, больше одного. Например, функция =ПСТР(А1;1;10) вернёт первые 10 символов из строки в ячейке А1.
  • С необязательными аргументами – функция имеет аргументы, которые указывать необязательно. Например, =ВПР(«Иванов»;А1:В30;2;0) будет искать фамилию «Иванов» в диапазоне А1:В30 и вернёт информацию о нём. Последний аргумент здесь – «Интервальный просмотр» — обозначает способ поиска, его указывать необязательно.
  • С переменным количеством аргументов – количество аргументов может изменяться. Например, =СРЗНАЧ(А1;В3:В15;С2:F2) – посчитает среднее значение цифр в указанных диапазонах. Перечисляя ячейки через точку с запятой, вы можете задать разное количество аргументов.

Как вставить функцию в Excel

Чтобы вставить функцию в формулу, можно воспользоваться одним из перечисленных способов:

  1. Если вы знаете имя функции – начните его записывать с клавиатуры, инструмент «Автозаполнение» предложит варианты функций, выберите в списке нужную, нажмите TAB и вводите аргументы;
    Автозаполнение при вводе функции Excel Автозаполнение при ручном вводе функции
  2. Еще один способ, если вы знакомы с перечнем функций – выбрать на ленте: Формулы – Библиотека функций . В этой группе собраны функции по типам: логические, текстовые, математические и др. Открыв нужную группу – выберите функцию и перейдите к заполнению аргументов.
    Вставка функции из ленты Excel Выбор функции на ленте

Если имя функции вам неизвестно, воспользуйтесь окном Вставка функции . Чтобы его вызвать – попробуйте один из способов:

Вставка функции в Эксель

  1. Нажмите комбинацию клавиш SHIFT+F3
  2. Выполните на ленте Формулы – Библиотека функций – Вставить функцию
  3. Нажать на значок fx слева от строки формул
    Окно «Вставка функции»

После выполнения любой из этих операций, откроется окно Вставка функции . В поле Поиск функции кратко опишите, что нужно сделать и нажмите Найти . В поле Выберите функцию появятся результаты поиска. Кликайте на функции в списке, читайте их описания. Если подходящая функция не найдена – перефразируйте запрос и повторите поиск.

Когда вы нашли функцию, кликните на ней 2 раза, откроется окно аргументов. После их заполнения, нажмите ОК , программа просчитает результат.

Аргументы функции в Excel

Окно» Аргументы функции»

И снова я констатирую, что мы изучили важную и простую тему. Пока еще простую! Попрактикуйтесь самостоятельно вставлять функции на рабочий лист и убедитесь, что в этом нет ничего сложного. Тем не менее, это очень важные навыки. Их успешное применение, доведенное до автоматизма — это основа основ. Далее уже буду описывать работы, основанные на практике из этой статьи.

Вот и всё о вставке функций на лист, а в следующей статье мы начнём рассматривать текстовые функции. До встречи на страницах блога OfficeЛЕГКО.com!

Понятие функции в Excel

Что такое функция в Excel и как с ней работать?

Функция Excel — это предопределенная формула, которая возвращает результат, оперируя заранее заданными аргументами (значениями).

Excel имеет множество интересных функций, которые смогут значительно сэкономить время при вычислении сумм; максимальных, средних и минимальных значений; подсчета данных и т.д. Для корректной работы функций следует соблюдать правила записи — СИНТАКСИС ФУНКЦИЙ.

Синтаксис функций (формул):

У стандартного синтаксиса функций есть знак равенства (=), имя функции (как например: “ СУММ ”, ” ЕСЛИ ”, ” ВПР ” и т.д.) и необходимые аргументы. В аргументах находиться информация, которая нужна для вычисления. Например, ниже представленная функция “ СУММ ” суммирует значения в диапазоне B1:B10.

Синтаксис функций

Как работать с аргументами функции в Excel

В Excel существует множество полезных функций со своим уникальным набором аргументов. Существует даже такие, которые не имеют ни одного аргумента, такие например как функции “ СЕГОДНЯ() ” (Возвращает текущую дату) и “ ПИ() ” (возвращает число 3,14159265358979 — математическую константу «пи» с точностью до 15 цифр).

Для вставки функции можно воспользоваться диалоговым окном Мастер функций. Это окно можно вызвать одним из следующих способов:

  • кнопку Вставить функцию, расположенную в группе Формулы ► Библиотека функций.
  • Нажмите кнопку Вставить функцию слева от строки формул.
  • Нажмите Shift+F3.

Вставки функции в Excel

Часто используемые функции довольно быстро запоминаются и воспользоваться ими не заставит труда, но, если вы забыли или не знаете её имя, можно использовать поисковое поле и нажать на кнопку “Найти”. После того как функция нашлась нажмите на “ОК” и следом откроется окно “Аргументы функции”, в котором можно ознакомится с аргументами данной функции.

Аргументы функции в Excel

При вводе функцию вручную (без помощи окна Мастер функций) для вызова диалогового окна “Аргументы функции” используйте сочетание клавиш Ctrl+A . Следует заметить, что данное сочетание не работает после ввода каких-либо аргументов данной функции.

Сочетание клавиш Ctrl+Shift+A заполняет функцию фиктивными аргументами. Это может быть полезно, если вы еще не знаете, какими данными заполнить функцию. Формула будет возвращать ошибку и позже следует аргументы заменить. Например при вводе функции “ =СУММЕСЛИ ” зажать Ctrl+Shift+A , то получим вот такой результат: =СУММЕСЛИ(диапазон;критерий;диапазон_суммирования)

Ссылка на основную публикацию