Как сделать срзнач в excel

СРЗНАЧ (функция СРЗНАЧ)

В этой статье описаны синтаксис формулы и использование функции С AVERAGE в Microsoft Excel.

Описание

Возвращает среднее арифметическое аргументов. Например, если диапазон A1:A20 содержит числа, формула =СПБ(A1:A20) возвращает среднее из этих чисел.

Синтаксис

Аргументы функции СРЗНАЧ описаны ниже.

Число1 Обязательный аргумент. Первое число, ссылка на ячейку или диапазон, для которого требуется вычислить среднее значение.

Число2. Необязательный. Дополнительные числа, ссылки на ячейки или диапазоны, для которых нужно вычесть среднее значение, не более 255.

Замечания

Аргументы могут быть числами, именами или ссылками на диапазоны или ячейки, содержащие числа.

Логические значения и текстовые представления чисел, которые непосредственно введите в список аргументов, не учитываются.

Если аргумент является ссылкой на диапазон или ячейку, содержащую текст или логические значения, или ссылкой на пустую ячейку, то такие значения игнорируются; однако ячейки, которые содержат нулевые значения, учитываются.

Аргументы, являющиеся значениями ошибок или текстом, которые не могут быть преобразованы в числа, вызывают ошибки.

Если логические значения и текстовые представления чисел необходимо учитывать в расчетах, используйте функцию СРЗНАЧА.

Если требуется вычислить среднее значение только для тех значений, которые удовлетворяют определенным критериям, используйте функцию СРЗНАЧЕСЛИ или СРЗНАЧЕСЛИМН.

Примечание: Функция СРЗНАЧ вычисляет среднее значение, то есть центр набора чисел в статистическом распределении. Существует три наиболее распространенных способа определения среднего значения, описанных ниже.

Среднее значение — это среднее арифметическое, которое вычисляется путем сложения набора чисел с последующим делением полученной суммы на их количество. Например, средним значением для чисел 2, 3, 3, 5, 7 и 10 будет 5, которое является результатом деления их суммы, равной 30, на их количество, равное 6.

Медиана — это число, которое является серединой множества чисел, то есть половина чисел имеют значения большие, чем медиана, а половина чисел имеют значения меньшие, чем медиана. Например, медианой для чисел 2, 3, 3, 5, 7 и 10 будет 4.

Мода — это число, наиболее часто встречающееся в данном наборе чисел. Например, модой для чисел 2, 3, 3, 5, 7 и 10 будет 3.

При симметричном распределении множества чисел все три значения центральной тенденции будут совпадать. При ассиметричном распределении множества чисел они могут отличаться.

Совет: При вычислении средних значений ячеек следует учитывать различие между пустыми ячейками и ячейками, содержащими нулевые значения, особенно если в диалоговом окне Параметры Excel настольного приложения Excel снят флажок Показывать нули в ячейках, которые содержат нулевые значения. Если этот флажок установлен, пустые ячейки игнорируются, но нулевые значения учитываются.

Местонахождение флажка Показывать нули в ячейках, которые содержат нулевые значения

Откройте вкладку Файл , а затем нажмите кнопку Параметры и в категории Дополнительно найдите группу Показать параметры для следующего листа.

Пример

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Как посчитать среднее значение в Excel

В этой статье мы разберем как посчитать среднее значение в Excel с числами, текстом, пустыми ячейками, а также по заданным критериям.

  1. Как посчитать среднее значение чисел в Excel
  2. Синтаксис СРЗНАЧ
  3. Аргументы СРЗНАЧ
  4. Как найти среднее значение с учетом текста
  5. Как найти среднее арифметическое по условию

Как посчитать среднее значение чисел в Excel

Найти среднее арифметическое чисел в Excel можно с помощью функции СРЗНАЧ .

Синтаксис СРЗНАЧ

=СРЗНАЧ(число1;[число2];…) – русская версия

Аргументы СРЗНАЧ

  • число1 – первое число или диапазон чисел, для расчета среднего арифметического;
  • число2 (Опционально) – второе число или диапазон чисел для расчета среднего арифметического. Максимальное количество аргументов функции – 255.

Для расчета проделайте следующие шаги:

  • Выделите любую ячейку;
  • Напишите в ней формулу =СРЗНАЧ(
  • Выделите диапазон ячеек, для которого требуется сделать расчет;
  • Нажмите клавишу “Enter” на клавиатуре

Как посчитать среднее значение в Excel

Функция рассчитает среднее значение в указанном диапазоне среди тех ячеек, в которых есть числа.

Как найти среднее значение с учетом текста

Если в диапазоне данных есть текст, то рекомендую использовать функцию СРЗНАЧА . Она работает как функция СРЗНАЧ . Отличие в том, что она учитывает пустые ячейки, текст и значения ЛОЖЬ/ИСТИНА.

Если в диапазоне данных есть пустые строки или текст, то функция воспринимает их как “ноль”. Если среди данных есть логические выражения ЛОЖЬ или ИСТИНА, то ЛОЖЬ функция воспринимает как “ноль”, а ИСТИНА как “1”.

Как найти среднее арифметическое по условию

Для расчета среднего по условию или критерию используется функция СРЗНАЧЕСЛИ . Например, представим что у нас есть данные по продажам товаров:

Функция СРЗНАЧЕСЛИ в Excel

Наша задача вычислить среднее значение продаж ручек. Для этого проделаем следующие шаги:

  • В ячейке A13 напишем название товара “Ручки”;
  • В ячейке B13 введем формулу:

Диапазон ячеек “ А2:A10 ” указывает на список товаров, в котором мы будем искать слово “Ручки”. Аргумент A13 это ссылка на ячейку с текстом, который мы будем искать среди всего списка товаров. Диапазон ячеек “ B2:B10 ” это диапазон с данными продаж товаров, среди которых функция найдет “Ручки” и вычислит среднее значение.

Среднее значение в Excel по условию

Еще больше полезных приемов в работе со списками данных и функциями в Excel вы узнаете в практическом курсе “От новичка до мастера Excel“. Успей зарегистрироваться по ссылке!

Ссылка на основную публикацию