Как сделать кроссворд в excel инструкция

Делаем кроссворд в Excel

Составление кроссвордов в программе Microsoft Excel более желательно, нежели проделывание подобной процедуры в Word. Дело в том, что функционал Excel позволяет создать этот сканворд быстрее, плюс, имеется возможность создать проверку для кроссворда. В Word такой возможности.

Ранее мы уже разбирали, как создать кроссворд в MS Word. Рекомендуем ознакомиться с этой статьёй для лучшего понимания.

  1. Как создать кроссворд в Excel
  2. Этап 1: Создаём сканворд
  3. Этап 2: Проверка правильности

Как создать кроссворд в Excel

Для начала лучше обдумать структуру кроссворда заранее и начертить её где-нибудь на бумаге. Можно найти в сети уже готовый сканворд и скопировать его структуру. Когда всё будет готово переходите в интерфейс Excel.

Этап 1: Создаём сканворд

Задать саму структуру будущего кроссворда можно, если выполнить следующие действия:

  1. Запустите Excel. Как видите, ячейки здесь прямоугольные. Они не подходят для создания кроссворда, поэтому придётся поменять их форму. Выделите вся ячейки на листе, воспользовавшись сочетанием клавиш Ctrl+A.
  2. Нажмите правой кнопкой мыши по выделению. Из контекстного меню выберите вариант «Высота строки».

Откроется окошко с настройками высоты строки. Здесь задайте любое удобное вам значение, но не сильно большое. Например, мы установим высоту в 20 единиц. Жмите «Ок» для применения изменений.

  • Теперь кликните правой кнопкой мыши по названию любого столбца. Из контекстного меню выберите вариант «Ширина столбца».
  • Установите здесь значение 3 и нажмите «Ок».
  • Определитесь с размером кроссворда в вертикальном и горизонтальном положении. Сделайте выделение области в соответствии с тем, сколько клеток вы запланировали в сканворде.
  • Теперь в верхней строке, в блоке инструментов «Шрифт», кликните по кнопке «Граница». Из контекстного меню выберите «Все границы».
  • Границы, которые очерчивают сканворд успешно установлены. Теперь выделите те его части, которые не нужны в кроссворде, то есть куда ничего не будет вписываться. В блоке инструментов «Редактирование» нажмите на кнопку в виде ластика. Таким образом вы удалите выделение у тех участков, где оно не требуется.

  • Дополнительно можно выделить каким-нибудь акцентным цветом главную полосу кроссворда. Выделите эту полосу и измените у неё цвет с помощью инструмента заливки, что расположен в блоке «Шрифт».
  • Основная структура кроссворда готова, теперь осталось только пронумеровать строки и столбцы, а также прописать вопросы в отдельном блоке.

    1. Выделите ячейку около нужной строки/столбца. Поставьте в ней номер данной ячейки. Если цифра номера слишком большая, то вы можете уменьшить её, выбрав соответствующий размер в блоке инструментов «Шрифт». Также можно настроить выравнивание цифры в соответствующем блоке.
    2. Теперь нужно выделить область, в которую будут записаны вопросы. Её размер может быть произвольным, главное, чтобы все данные поместились в указанной области.
    3. В выделенной области нужно убрать разбиение на ячейки. Нажмите по ней правой кнопкой мыши и выберите из контекстного меню «Объединить ячейки».

  • Вставьте туда заранее подготовленный текст или пропишите вопросы вручную.
  • Этап 2: Проверка правильности

    Вы можете также сделать проверку кроссворда в Excel. Правда, она будет доступна только для тех пользователей, которые разгадывают его в электронном виде. Для печати функция проверки недоступна.

    Делается проверка готового кроссворда следующим образом:

    1. Создайте дополнительный лист для таблицы. Здесь запишите ответы в формате таблицы. Разделите её на столбцы:
      • «Ответы». Сюда вписываются сами ответы на вопросы;
      • «Введено». В этом столбце вписываются данные, которые пользователь ввёл;
      • «Совпадения». Здесь Excel будет сверять данные введённые пользователем с ответами;
      • Ещё внизу можно создать блок «Итого», где будет подсчитана сумма верных ответов.

    2. Переключитесь на первую ячейку столбца «Введено». Здесь нужно задать специальную функцию. Нажмите на кнопку в виде буквы «f» около строки ввода данных.
    3. Будет открыт мастер создания функций. В нём найдите функцию, которая называется «Сцепить». Выберите её и нажмите «Ок», чтобы она применилась.
    4. Откроется окошко задания аргументов для функции. Здесь нужно нажать на кнопку в виде таблички, что расположена около строки ввода аргумента.
    5. Переключитесь на первый лист и выберите все ячейки той строки, которая соответствуют нужному вопросу.
    6. Проделайте аналогичную операцию с другими ответами.
    7. Теперь переключитесь на первую ячейку совпадений. Сюда нужно задать функцию «Если». Она будет иметь следующий вид: «=ЕСЛИ(номер_ячейки_ответа=номер_ячейки_введено;1;0)». Вот так она выглядит у нас: «=ЕСЛИ(A4=B4;1;0)». То есть, если ответ пользователя совпадает с записанным в таблице ответом, то в «Совпадение» пишется один балл. В противном случае ставится 0.

    8. Переключитесь к строке «Итого». Здесь нужно прописать функцию «СУММ», чтобы суммировать полученные баллы. В скобках этой функции проставьте номера ячеек, которые требуется просуммировать.
    9. Осталось только вписать завершающую функцию на первом листе с кроссвордом, которая будет выдавать, правильно ли он решён или нет.

      1. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу. Именно от этого числа нужно будет составлять дальнейшую формулу.
      2. Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

      Теперь, если пользователь ответил на один или несколько вопросов неверно, то система предложит ему подумать ещё. В противном случае Excel оповестит человека о том, что он решил кроссворд правильно.

      Как сделать кроссворд в Excel с помощью стандартных функций

      Кроссворды любят разгадывать все. Это чрезвычайно полезная вещь, которая пригодится в разных сферах деятельности: для привлечения пользователей на ресурс, для проверки и закрепления знаний в ходе преподавания и др.

      Электронные таблицы Excel позволяют «автоматизировать» разгадывание кроссвордов: пользователю сразу видны результаты решения. Создадим их с помощью стандартных функций.

      Как сделать интерактивный кроссворд в Excel

      Стандартный лист Excel – это набор прямоугольных ячеек. Не совсем подходящих для рисования кроссвордов. Поэтому сначала их нужно сделать квадратными.

      Выделяем все ячейки – нажимаем Ctrl + А. Щелкаем в любом месте правой кнопкой мыши – выбираем «Высота строки». Устанавливаем значение 18.

      Ширину столбца поменяем другим способом: захватим мышкой правый край любой ячейки и подвинем его в левую сторону, установив значение 3.

      Одновременно изменяется ширина всех столбцов листа.

      Начинаем прорисовку сетки кроссворда. Выделяем необходимое количество ячеек. В группе «Шрифт» устанавливаем все границы.

      По такому же принципу рисуем весь кроссворд. Не забываем проставлять цифры – номера вопросов / ответов.

      Границы и вопросы.

      Оформляем вопросы кроссворда. Запишем их справа от сетки.

      Как сделать кроссворд в Excel с проверкой

      На новом листе создадим вспомогательную табличку с ответами:

      Ответы.

      В столбце «Введено» будут отображаться вводимые пользователем в кроссворд ответы. В столбце «?» — совпадения. В ячейке V8 – количество верных ответов.

      Теперь с помощью функции «СЦЕПИТЬ» склеим отдельные буквы, вводимые в кроссворд, в целые слова. Вводим формулы в ячейки столбца «Введено»:

      СЦЕПИТЬ.

      Пользователь может вводить как строчные, так и прописные буквы. В результате возникают проблемы. Чтобы этого избежать, используем функцию «СТРОЧН». Подставим ее во все ячейки перед функцией «СЦЕПИТЬ».

      Функция преобразует прописные буквы в строчные.

      Если пользователь вводит правильный ответ, в столбце V3:V7 появится цифра 1. В противном случае – 0. Сделаем это с помощью функции «ЕСЛИ».

      ЕСЛИ.

      Для подсчета количества правильных ответов – функция СУММ.

      СУММ.

      Количество всех правильных ответов – 5. Если в ячейке «Всего» появится цифра «5», это будет означать, что пользователь справился с решением кроссворда. На экране появляется запись «Молодец!» (например).

      Если в ячейке «Всего» находится другая цифра – «Еще подумай!».

      Реализуем задачу с помощью функции «ЕСЛИ»:

      Покажем еще пользователю, сколько ответов осталось отгадать. Всего вопросов – 5. Значит, формула будет следующая: =5-‘Лист1 (2)’!V8, где ‘Лист1 (2)’!V8 – число верных ответов из вспомогательной таблички.

      Для проверки работоспособности формул введем 1 правильный ответ в сетку кроссворда. Получаем следующий результат:

      Пример2.

      Спрячем от пользователя правильные ответы. Из сетки кроссворда на втором листе их удалим. Выделим строки вспомогательной таблицы. Перейдем на вкладку «Данные» — группа «Структура». Воспользуемся инструментом «Группировать».

      Группировать.

      В открывшемся окне поставим галочку напротив записи «Строки».

      В левом поле листа появятся значки структуры и символ минуса.

      Нажмем на значок «-». Данные вспомогательной таблицы станут невидимыми.

      Далее переходим на вкладку «Рецензирование». В группе «Изменения» находим кнопку «Защитить лист». В открывшемся окне назначаем пароль. Теперь раскрыть вспомогательную таблицу и посмотреть ответы у постороннего человека (кто не знает пароль) не получится.

      Если пользователь попытается открыть ответы, программа выдаст предупреждение о том, что: "Нельзя использовать данную команду на защищенном листе. ".

      Основная работа по созданию кроссворда закончена. Можно красиво оформить лист, добавить название, изменить цвет заливки сетки, сделать ярче границы ячеек и т.п.

      Ссылка на основную публикацию