Excel как посчитать количество символов в столбце
Перейти к содержимому

Excel как посчитать количество символов в столбце

Подсчет количества определенных символов в ячейке excel

Описание функции

Функция =СЧЁТСИМВЛ(ТЕКСТ, СИМВОЛ) имеет два обязательных аргумента:

  • ТЕКСТ — Строка, в которой необходимо посчитать количество символов.
  • ШАБЛОН — Символ, который необходимо посчитать.

Если вы забыли синтаксис данной функции, вы всегда сможете вызвать формулу из выпадающего списка функций в надстройке.

Теперь к практике. Далее привожу множество примеров использования данной функции.

Пример 1

Посчитать количество пробелов в тексте.

Пример 2

Посчитать количество заданных символов.

Пример 3

Посчитать количество символов не обращая внимание на регистр.

Пример 4

Посчитать количество слов в тексте.

Пример 5

Посчитать количество слов в тексте не обращая внимания на двойные пробелы.

Пример 6

Посчитать количество всех символов в строке за исключением пробелов.

Альтернатива данной функции

Excel позволяет пользователям достичь правильного решения разными путями. Данная формула не исключение. Заменить данную функцию можно с помощью двух других: ДЛСТР и ПОДСТАВИТЬ. Чтобы определить количество заданного символа сначала определите длину всего текста функцией ДЛСТР, а затем отнимите от этого значения длину этого же текста, только с предварительно удаленными символами (которые вы ищите): =ДЛСТР(B13)-ДЛСТР(ПОДСТАВИТЬ(B13;" ";"")). В файле для скачивания приведены конкретные примеры.

Подсчет символов в диапазоне в EXCEL

history 3 апреля 2013 г.
    Группы статей
  • Учет РЕгиСТра
  • Подсчет Символов, Букв в Текстовых Строках

Найдем количество вхождений определенного символа в диапазоне ячеек.

Определим, сколько букв Z содержится в диапазоне А7: A 11 .

Формула для подсчета (с учетом РЕгиСТра ), см. файл примера : =СУММПРОИЗВ(ДЛСТР(A7:A11)-ДЛСТР(ПОДСТАВИТЬ(A7:A11;B4;"")))

Формула для подсчета (без учета РЕгиСТра ): =СУММПРОИЗВ(ДЛСТР(A7:A11)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН(A7:A11);"z";"")))

Формула для одновременного подсчета символов Z и цифры 1 в диапазоне А7: A 11 (без учета РЕгиСТра ): =СУММПРОИЗВ(ДЛСТР(A7:A11)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН(A7:A11); <"z";"1">;"")))

Аналогичная формула =СУММПРОИЗВ(ДЛСТР( A7:A11 )-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН( A7:A11 ); <"1";"2">;""))) может подсчитать количество цифр (1 и 2) в диапазонах с числами.

Пусть в диапазоне А7: A 11 содержатся числа 1; 22; 123; 8; 5. Формула, приведенная выше, вернет 5, т.к. в диапазоне содержится две цифры 1 (в числах 1 и 123) и три цифры 2 (в числах 22 и 123).

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *