Как построить логическую таблицу в excel
Перейти к содержимому

Как построить логическую таблицу в excel

Использование MS Excel при изучении математической логики

В настоящее время применение информационных технологий становится неотъемлемой частью образовательного процесса. Компьютер наиболее полно удовлетворяет дидактическим требованиям и позволяет адаптировать процесс обучения к индивидуальным особенностям учащихся.

Компьютерные технологии активно внедряются в процесс обучения и диагностики, позволяют упростить процесс отработки навыков и умений и оценки знаний учащихся.

В данной работе рассматривается применение табличного процессора MS Excel при изучении основ логики.

Существует множество задач, в которых исходные и результатные данные должны быть представлены в табличной форме. Электронные таблицы представляют собой удобный инструмент для автоматизации таких вычислений. Решения многих вычислительных задач на ЭВМ, которые раньше можно было осуществить только путем программирования, стало возможно реализовать. Использование математических формул в электронных таблицах позволяет представить взаимосвязь между различными параметрами некоторой реальной системы. Основное свойство электронных таблиц – мгновенный пересчет формул при изменении значений входящих в них операндов. Благодаря этому свойству, таблица представляет собой удобный инструмент для организации численного эксперимента:

  • подбор параметров,
  • прогноз поведения моделируемой системы,
  • анализ зависимостей,
  • планирование.

В электронных таблицах предусмотрен также графический режим работы, который дает возможность графического представления (в виде графиков, диаграмм) числовой информации, содержащейся в таблице.

В процессе изучения алгебры логики учащиеся знакомятся с такими понятиями как: высказывание, таблицы истинности, логические функции и логические операции. Алгебра логики является разделом математической логики, в которой изучаются методы доказательства истинности (1) или ложности (0) сложных логических конструкций, составленных из простых высказываний, на основе истинности или ложности последних. Для закрепления полученных знаний возможно использование табличного процессора MS Excel и его функций.

Для реализации функций булевой алгебры используются логические функции: ЕСЛИ, И, ИЛИ, НЕ, ИСТИНА и ЛОЖЬ. При работе с функциями в MS Excel используется мастер функций (Вставка Функция…), в котором отображается имя функции, ее описание и аргументы.

Рисунок 1. Окно мастера функций

Первоначально следует создать таблицу основных логических операций:

Рисунок 2. Таблица истинности основных логических операций

При составлении таблицы истинности используются следующие формулы:

  1. Инверсия: =ЕСЛИ(A2=1;0;1);
  2. Дизъюнкция: =ЕСЛИ(ИЛИ(A2=1;B2=1);1;0);
  3. Конъюнкция: =ЕСЛИ(И(A2=1;B2=1);1;0);
  4. Импликация: =ЕСЛИ(И(A2=1;B2=0);0;1);
  5. Эквивалентность: =ЕСЛИ(A2=B2;1;0).

В последующей работе данная таблица может использоваться учащимися как основа для выполнения заданий лабораторной работы.

Учащимся может быть предложена следующая работа.

Задание: Построить таблицу истинности для формулы (A B C) A, используя MS Excel.

Алгоритм:

  1. Определить количество наборов входных переменных, по формуле: Q = 2 n , где n – количество переменных. Q = 2 3 = 8.
  2. Внести в таблицу все наборы входных переменных:

Рисунок 3. Исходные данные

  1. Определить количество логических операций и порядок их выполнения:
  • B
  • A B
  • A B C
  • (A B C) A
  1. Заполнить столбцы результатами выполнения логических операций в обозначенной последовательности.

Для этого в ячейку D2 ввести формулу: =ЕСЛИ(B2=1;0;1);

в E2: =ЕСЛИ(И(A2=1;D2=1);1;0);

в F2: =ЕСЛИ(И(E2=1;C2=0);0;1);

в G2: =ЕСЛИ(F2=A2;1;0).

Заполнение остальных строк произвести путем копирования введенной формулы.

Рисунок 4. Результат выполнения работы

Табличный процессор может быть использован для закрепления не только материала математической логики, но и для основ теории вероятностей и математической статистики.

Задачи для самостоятельного решения

Определить с помощью таблиц истинности равносильность формул.

Определить являются ли формулы тавтологиями.

Построить таблицу истинности в Excel: основные понятия и примеры

Алгебра высказываний – точная наука, не дающая компромиссов. Чтобы решить примеры с конъюнкцией, дизъюнкцией, импликацией и т. д., можно построить таблицу истинности в прикладной программе Excel. Она оснащена набором логических функций, позволяющих автоматизировать и облегчить процесс нахождения результата.

Математическая логика: основные понятия

Основателем формальной логики считают Аристотеля. В XVII в. Г. Лейбниц предложил вводить символы для определения высказываний. Д. Буль закрепил усвоенные знания и впервые обозначил предложения символами.

Схематически «ИСТИНА» замещается 1, а «ЛОЖЬ» – 0.

Под высказыванием понимают любое повествовательное предложение, дающее какую-либо информацию и способное принимать значение истинности или ложности. В алгебре логики отвлекаются от смысловой нагрузки предложений и рассматривают только логические значения.

Под отрицанием понимают новое выражение, принимающее значение истины в случае его ложности и наоборот.

Конъюнкцией двух переменных называют новое предложение, принимающее значение истинности в случае одновременного обозначения «1» и ложности в остальных ситуациях.

Под дизъюнкцией двух высказываний понимают новое выражение, принимающее значение «ЛОЖЬ» только при одновременном наличии «0» и «ИСТИНА» в остальных вариациях.

построить таблицу истинности

Импликацией двух переменных называют новое предложение, в котором:

  • если посылка истинна, а следствие ложно, то выражение равняется «0»;
  • высказывание равняется «1» в остальных случаях.

Под эквиваленцией двух переменных понимают новое высказывание, принимающее значение истинности только в случае одинаковости элементов. Иначе предложение равняется «0».

построить таблицу истинности

Логические значения выражений принято оформлять в табличном виде. Есть и другое название у такого рода информации. Говорят, для высказывания нужно построить таблицу истинности. В ней указываются первоначальные значения для всех переменных, а потом вычисляется результат всего выражения.

Алгоритм реализации вычислений в логических операциях

Чтобы построить таблицу истинности, необходимо знать, в каком порядке выполняются действия. В выражении, где несколько операндов, вычисление осуществляется в следующем порядке:

  • инверсия (отрицание);
  • конъюнкция (логическая функция в Excel «И»);
  • дизъюнкция (булев оператор в Excel «ИЛИ»);
  • импликация (следствие);
  • эквиваленция.

Существуют еще две операции, но для них приоритет не определен:

  • штрих Шеффера;
  • стрелка Пирса.

Алгоритм вычислений меняется, если выражение заключено в скобки.

Порядок построения табличной формы для логических операндов в Excel

Прежде чем находить значение выражения, нужно изучить понятие формулы алгебры логики. Определение гласит, что это сложное выражение, состоящее из простейших высказываний, соединенных между собой логическими операндами.

Пример 1. Построить таблицу истинности для конъюнкции, дизъюнкции и отрицания.

построить таблицу истинности

Пример 2. Дана формула алгебры логики. Построить таблицу истинности. Примеры в качестве образца даны ниже.

построить таблицу истинности примеры

Пример 3. Как построить таблицу истинности в Excel, если дана формула алгебры логики в словесном описании. Высказывание: «Если треугольник – равносторонний, то все его ребра равны или все его углы равны».

Для начала необходимо разобрать составное предложение на минимальные элементы:

  • Первая часть выражения: А = «треугольник равносторонний».
  • Вторая: В = «все стороны фигуры равны».
  • Третья: С = «все углы треугольника равны».

После этого составляется выражение и решается в программном пакете Excel.

как построить таблицу истинности в excel

При составлении таблиц истинности важно помнить о порядке выполнения операций.

Добавить комментарий

Ваш адрес email не будет опубликован.