Как удалить все после пробела в excel

Как удалить все после пробела в excel

можно, если бы Вы потрудились приложить файл — решение было бы уже сейчас

пока вот код функции

а по моему все ОЧЕНЬ просто
нам известно что 5 последних символов строки содержат значение от 1 до 10000

отрезаем 5 последних символов = ПРАВСИМВ(A1;5)
2 567
теперь ищем в составе этого значения пробел
=ПОИСК(" ";правсимв(A1;5))
получается 2

теперь отрезаем 5-x правых символов
=ПРАВСИМВ(A1;5-ПОИСК(" ";ПРАВСИМВ(A1;5)))
вот Вам 567

т.к. в алгоритме есть дыра на следующей строке "1 1 1"

ищем пробел в последних 3х символах
если он есть перерасчитываем формулу не для 5 символов а для 3х

=ЕСЛИ(
ЕОШИБКА(ПОИСК(" ";ПРАВСИМВ(A1;3))); ‘ ищем пробел в последних трех символах
ПРАВСИМВ(A1;5-ПОИСК(" ";ПРАВСИМВ(A1;5))); ‘ если его нет
ПРАВСИМВ(A1;3-ПОИСК(" ";ПРАВСИМВ(A1;3))) ‘ если он есть
)

=ЕСЛИ(ЕОШИБКА(ПОИСК(" ";ПРАВСИМВ(A1;3)));ПРАВСИМВ(A1;5-ПОИСК(" ";ПРАВСИМВ(A1;5)));ПРАВСИМВ(A1;3-ПОИСК(" ";ПРАВСИМВ(A1;3))))

=ЕСЛИ(ЕОШИБКА(ПОИСК(" ";ПРАВСИМВ(A1;3)));ПРАВСИМВ(A1;6-ПОИСК(" ";ПРАВСИМВ(A1;6)));ПРАВСИМВ(A1;3-ПОИСК(" ";ПРАВСИМВ(A1;3))))

Когда я писал про реализацию задачи с помощью формул, мне и представлялся примерно такой, последовательный перебор знаков в конце строки. С помощью Уокенбаха получается гораздо более элегантная формула для отсечения последнего слова:

=ЛЕВСИМВ(A1;НАЙТИ("*";ПОДСТАВИТЬ(A1;" ";"*";ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;" ";""))))-1)

=ЕСЛИ(ЕОШИБКА(ПОИСК(" ";ПРАВСИМВ(A1;3)));ПРАВСИМВ(A1;6-ПОИСК(" ";ПРАВСИМВ(A1;6)));ПРАВСИМВ(A1;3-ПОИСК(" ";ПРАВСИМВ(A1;3))))

Когда я писал про реализацию задачи с помощью формул, мне и представлялся примерно такой, последовательный перебор знаков в конце строки. С помощью Уокенбаха получается гораздо более элегантная формула для отсечения последнего слова:

=ЛЕВСИМВ(A1;НАЙТИ("*";ПОДСТАВИТЬ(A1;" ";"*";ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;" ";""))))-1)

Как удалить все после пробела в excel

в пору обьявлять конкурс на лучшее решение.
fijiisland, Вы, как автор вопроса можете назначить себя председателем жюри, обьявить размер призового фонда, выбрать и наградить победителя.

пользуясь случаем еще один вариант:
отмечаете колонку с данными, лента данные, кнопка "текст по столбцам", разделитель "запятая", кнопка "готово". готово!

fijiisland
Посмотреть профиль
Найти ещё сообщения от fijiisland
IgorGO, воспользовался вашим первым решением
DiemonStar
Посмотреть профиль
Найти ещё сообщения от DiemonStar

Выделить данные
Ctrl+H,
что — ,*
на что — ничего
"Заменить все"

Или запятую нужно оставить? А зачем?
Тогда на что — ,

Кто сможет помочь:
КАк в екселе удалить все символы после "/", то есть для примера:

то есть получается после повторения символа "/" в третий раз

Ссылка на основную публикацию