Как указать день недели в excel по дате

День недели в EXCEL

history 7 апреля 2013 г.
    Группы статей

  • Неделя, День недели
  • Пользовательский формат
  • Пользовательский Формат ДАТЫ и ВРЕМЕНИ

Определим день недели для заданной даты в ячейке. Существует несколько решений в зависимости от того результата, который мы хотим получить: номер дня недели (1 — Пн, 2- Вт, . ), текстовую форму (Понедельник, Вторник, . ) или просто можно изменить формат ячейки.

День недели можно быстро отобразить с помощью Пользовательского формата . Пользовательский формат можно ввести через диалоговое окно Формат ячеек , вкладка Число , ( все форматы ), нажав CTRL+1 . Для отображения вместо даты дня недели, на который она приходится, в поле Тип, предварительно все из него удалив, нужно ввести ДДД (краткий формат дня недели, например, Сб ) или ДДДД (будет отражено Суббота ).

Другим способом, определения дня недели является преобразование даты в текстовую форму с определенным форматом (см. файл примера ): =ТЕКСТ(01/01/10;"дддд")

Формула вернет текстовое значение " суббота ".

Для определения дня недели через числовую форму (понедельник=1; вторник=2, …) существует функция ДЕНЬНЕД() , английская версия WEEKDAY().

Если дата находится в ячейке А1 , то формула =ДЕНЬНЕД(A1;2) вернет день недели. Номер 1 соответствует понедельнику.

Для того, чтобы вывести день недели на английском языке используйте формулу = ТЕКСТ(A6;"[$-809]ДДД")

Другие статьи на эту тему можно найти в разделе Неделя, День недели .

Отображение дат как дней недели

Предположим, что вы хотите вывести в ячейке день недели, например "Понедельник", а не саму дату, такую как "3 октября 2005 г.". Это можно сделать несколькими способами.

Примечание: Снимок экрана в этой статье был сделан в Excel 2016. Если вы используете другую версию, у вас это может выглядеть немного по-другому, но если не указано иное, функциональность будет такой же.

Форматирование ячеек для отображения дня недели

Выделите ячейки, содержащие даты, которые вы хотите вывести в виде дней недели.

На вкладке Главная щелкните в поле со списком Числовом формате список Другие числовые форматы иперейдите на вкладку Число.

Список

В поле Числовые форматы выберите пункт (все форматы) и в поле Тип введите значение дддд, чтобы отображались полные названия дней недели ("понедельник", "вторник" и т. д.), либо ддд, чтобы отображались сокращенные названия ("Пн", "Вт", "Ср" и т. д.).

Преобразование дат в дни недели в текстовом формате

Для выполнения этой задачи используйте функцию ТЕКСТ.

Пример

Скопируйте следующие данные на пустой лист.

Ссылка на основную публикацию