Как создать количество ячеек в excel

REDMOND

Способы подсчета количества ячеек в диапазоне с данными

В Excel есть несколько функций, позволяющих подсчитать число пустых ячеек или ячеек с данными определенного типа в диапазоне.

Щелкните ячейку, в которой должен выводиться результат.

На вкладке Формулы щелкните Другие функции, наведите указатель мыши на пункт Статистические и выберите одну из следующих функции:

СЧЁТЗ: подсчитывает количество непустых ячеек.

СЧЁТ: подсчитывает количество ячеек, содержащих числа.

СЧИТАТЬПУСТОТЫ: подсчитывает количество пустых ячеек.

СЧЁТЕСЛИ: подсчитывает ячейки, отвечающие заданным условиям.

Совет: Чтобы ввести нескольких условий, используйте вместо этого функцию СЧЁТЕСЛИМН.

Выделите диапазон ячеек и нажмите клавишу RETURN.

Щелкните ячейку, в которой должен выводиться результат.

На вкладке Формулы щелкните Вставить, наведите указатель мыши на пункт Статистические и выберите одну из следующих функции:

СЧЁТЗ: подсчитывает количество непустых ячеек.

СЧЁТ: подсчитывает количество ячеек, содержащих числа.

СЧИТАТЬПУСТОТЫ: подсчитывает количество пустых ячеек.

СЧЁТЕСЛИ: подсчитывает ячейки, отвечающие заданным условиям.

Совет: Чтобы ввести нескольких условий, используйте вместо этого функцию СЧЁТЕСЛИМН.

Выделите диапазон ячеек и нажмите клавишу RETURN.

Как в Экселе посчитать количество ячеек

Посчитать количество ячеек в Эксель может потребоваться в различных случаях. В данной статье, мы и рассмотрим, как посчитать блоки с определенными значениями, пустые и если они попадают под заданные условия. Использовать для этого будем следующие функции: СЧЁТ, СЧЁТЕСЛИ, СЧЁТЕСЛИМН, СЧИТАТЬПУСТОТЫ.

Заполненных

Для начала, рассмотрим самый простой способ. Если Вам нужно посчитать количество заполненных блоков в Excel, выделите диапазон ячеек в документе – существуют различные способы, прочтите про них, перейдя по ссылке – и в «Строке состояния» обратите внимание на пункт «Количество» . Там будет написано количество непустых блоков: учитываются все с текстом и цифрами, а пустые – нет.

Если Вам нужно посчитать блоки в таблице, заполненные определенными значениями, и использовать это число в формулах для расчетов, то данный способ не подойдет, так как, данные в таблице могут периодически меняться. Поэтому перейдем к рассмотрению функций.

Где введены числа

Функция СЧЁТ – подсчитывает блоки, заполненные только числовыми значениями. Выделяем Н1 , ставим «=» , пишем функцию «СЧЁТ» . В качестве аргумента функции укажите нужный диапазон (F1:G10) . Если диапазонов несколько, разделите их «;» – (F1:G10;B3:C8) .

Всего заполнено 20 блоков. Тот, в котором записан текст, был не учтен, но посчитаны те, которые заполнены датой и временем.

REDMOND

С определенным текстом или значением

Функция СЧЁТЕСЛИ – позволяет рассчитать количество блоков, которые соответствуют заданному критерию. В качестве аргумента прописывается диапазон – В2:В13 , и через «;» указывается критерий – «>5» .

Например, есть таблица, в которой указано, сколько килограмм определенного товара было продано за день. Посчитаем, сколько товаров было продано весом больше 5 килограмм. Для этого нужно посчитать сколько блоков в столбце Вес, где значение больше пяти. Функция будет выглядеть следующим образом: =СЧЁТЕСЛИ(В2:В13;»>5″) . Она рассчитает количество блоков, содержимое в которых больше пяти.

Для того чтобы растянуть функцию на другие блоки, и скажем поменять условия, необходимо закрепить выбранный диапазон. Сделать Вы это сможете, используя абсолютные ссылки в Excel.

Функция также может рассчитать:

– количество ячеек с отрицательными значениями: =СЧЁТЕСЛИ(В2:В13;» ;
– количество блоков, содержимое в которых больше (меньше) чем в А10 (для примера): =СЧЁТЕСЛИ(В2:В13;»>»&A10) ;
– ячейки, значение в которых больше 0: =СЧЁТЕСЛИ(В2:В13;»>0″) ;
– непустые блоки из выделенного диапазона: =СЧЁТЕСЛИ(В2:В13;»<>») .

Применять функцию СЧЁТЕСЛИ можно и для расчета ячеек в Excel, содержащих текст. Например, рассчитаем, сколько в таблице фруктов. Выделим область и в качестве критерия укажем «фрукт». Будут посчитаны все блоки, с данным словом. Можно не писать текст, а просто выделить прямоугольник, который его содержит, например С2 .

Для формулы СЧЁТЕСЛИ регистр не имеет значения, будут подсчитаны ячейки содержащие текст «Фрукт» и «фрукт».

В качестве критерия также можно использовать специальные символы: «*» и «?» . Они применяются только к тексту.

Посчитаем сколько товаров начинается на букву А: «А*» . Если указать «абрикос*» , то учтутся все товары, которые начинаются с «абрикос»: абрикосовый сок, абрикосовое варенье, абрикосовый пирог.

Символом «?» можно заменить любую букву в слове. Написав в критерии «ф?укт» – учтутся слова фрукт, фуукт, фыукт.

Чтобы посчитать слова в ячейках, которые состоят из определенного количества букв, поставьте знаки вопросов подряд. Для подсчета товаров, в названии которых 5 букв, поставим в качестве критерия «. » .

Если в качестве критерия поставить звездочку, из выбранного диапазона будут посчитаны все блоки, содержащие текст.

С несколькими критериями

Функция СЧЁТЕСЛИМН используется в том случае, когда требуется указать несколько условий, максимальное их количество в Excel – 126. В качестве аргумента: задаем первый диапазон значений, и указываем условие, через «;» задаем второй диапазон, и пишем условие для него – =СЧЁТЕСЛИМН(B2:B13;»>5″;C2:C13;»фрукт») .

В первом диапазоне мы указали, чтобы вес был больше пяти килограмм, во втором выбрали, чтоб это были фрукты.

Пустых блоков

Функция СЧИТАТЬПУСТОТЫ рассчитает количество пустых ячеек в заданном диапазоне.

Посчитать в Экселе количество ячеек, которые содержат текст или числовые значения не так уж и сложно. Используйте для этого специальные функции, и задавайте условия. С их помощью можно посчитать как пустые блоки, так и те, где написаны определенные слова или буквы.

REDMOND

Ссылка на основную публикацию