Как работает функция еслиошибка в excel
Перейти к содержимому

Как работает функция еслиошибка в excel

Функция ЕСЛИОШИБКА

Функцию ЕСЛИЕROR можно использовать для ухимки и обработки ошибок в формуле. Если формула возвращает ошибку, она возвращает значение, определяемую формулой; в противном случае она возвращает результат формулы.

Синтаксис

Аргументы функции ЕСЛИОШИБКА описаны ниже.

значение Обязательный аргумент. Проверяемая ошибка аргумента.

value_if_error — обязательный аргумент. Значение, возвращаемая, если формула возвращает ошибку. Вычисляются следующие типы ошибок: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? или #NULL!.

Замечания

Если значение или value_if_error пустая ячейка, то она рассматривается как пустая строка ("").

Если значение является формулой массива, то она возвращает массив результатов для каждой ячейки диапазона, указанного в значении. См. второй пример ниже.

Примеры

Скопируйте данные из таблицы ниже и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — ВВОД.

=ЕСЛИОШИБКА(A2/B2;"Ошибка при вычислении")

Выполняет проверку на предмет ошибки в формуле в первом аргументе (деление 210 на 35), не обнаруживает ошибок и возвращает результат вычисления по формуле

=ЕСЛИОШИБКА(A3/B3;"Ошибка при вычислении")

Выполняет проверку на предмет ошибки в формуле в первом аргументе (деление 55 на 0), обнаруживает ошибку "деление на 0" и возвращает "значение_при_ошибке"

Ошибка при вычислении

=ЕСЛИОШИБКА(A4/B4;"Ошибка при вычислении")

Выполняет проверку на предмет ошибки в формуле в первом аргументе (деление "" на 23), не обнаруживает ошибок и возвращает результат вычисления по формуле.

Пример 2

Ошибка при вычислении

Выполняет проверку на предмет ошибки в формуле в первом аргументе в первом элементе массива (A2/B2 или деление 210 на 35), не обнаруживает ошибок и возвращает результат вычисления по формуле

Выполняет проверку на предмет ошибки в формуле в первом аргументе во втором элементе массива (A3/B3 или деление 55 на 0), обнаруживает ошибку "деление на 0" и возвращает "значение_при_ошибке"

Ошибка при вычислении

Выполняет проверку на предмет ошибки в формуле в первом аргументе в третьем элементе массива (A4/B4 или деление "" на 23), не обнаруживает ошибок и возвращает результат вычисления по формуле

Примечание. Если у вас есть текущая версия Microsoft 365,вы можете ввести формулу в левую верхнюю ячейку диапазона вывода, а затем нажмите ввод, чтобы подтвердить формулу как формулу динамического массива. В противном случае формулу необходимо ввести как формулу массива устаревшей формулы. Для этого сначала выберем диапазон вывода, введите формулу в левую верхнюю ячейку диапазона и нажмите CTRL+SHIFT+ВВОД, чтобы подтвердить ее. Excel автоматически вставляет фигурные скобки в начале и конце формулы. Дополнительные сведения о формулах массива см. в статье Использование формул массива: рекомендации и примеры.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Функция ЕСЛИОШИБКА() в EXCEL

history 11 апреля 2013 г.
    Группы статей
  • Поиск и исправление ошибок в формулах

Функция ЕСЛИОШИБКА() , английский вариант IFERROR(), п роверяет выражение на равенство значениям #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! Если проверяемое выражение или значение в ячейке содержит ошибку, то функция возвращает определенное для этого случая значение, в противном случае — результат вычисления выражения или содержимое ячейки.

Функция ЕСЛИОШИБКА() впервые появилась в EXCEL 2007.

Синтаксис функции

ЕСЛИОШИБКА ( значение ; значение_при_ошибке )

Значение — аргумент, проверяемый на возникновение ошибок.

Значение_при_ошибке — значение, возвращаемое при ошибке.

Для обработки ошибок #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! обычно используют формулу вида (см. файл примера ): =ЕСЛИОШИБКА(A2/B2;"Ошибка расчете")

Формула проверяет на предмет ошибки результат вычисления A2/B2.

Если результат вычисления не является ошибкой #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! , то формула возвращает результат вычисления A2/B2 , если обнаруживает, то возвращает строку Ошибка в расчете.

Функция ЕСЛИОШИБКА() vs ЕОШИБКА()

В отличие от функции ЕСЛИОШИБКА() функция ЕОШИБКА() не умеет самостоятельно обрабатывать ошибку — приходится задействовать функцию ЕСЛИ() : =ЕСЛИ(ЕОШИБКА(A2/B2);"Ошибка в расчетах";A2/B2)

Т.к. функция ЕСЛИОШИБКА() впервые появилась в EXCEL 2007, то в более ранних версиях придется использовать функцию ЕОШИБКА() .

Обратите внимание, что использована именно ЕОШИБКА() , а не ЕОШ() , т.к. для последней ошибка #Н/Д ошибкой не является (см. рисунок выше).

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *