Как сделать суммеслимн в excel

Функция СУММЕСЛИМН

Функция СУММЕСЛИМН — одна из математических и тригонометрических функций, которая суммирует все аргументы, удовлетворяющие нескольким условиям. Например, с помощью функции СУММЕСЛИМН можно найти число всех розничных продавцов, (1) проживающих в одном регионе, (2) чей доход превышает установленный уровень.

Это видео — часть учебного курса Усложненные функции ЕСЛИ.

Синтаксис

СУММЕСЛИМН(диапазон_суммирования; диапазон_условия1; условие1; [диапазон_условия2; условие2]; …)

=СУММЕСЛИМН(A2:A9; B2:B9; "=Я*"; C2:C9; "Артем")

=СУММЕСЛИМН(A2:A9; B2:B9; "<>Бананы"; C2:C9; "Артем")

Диапазон_суммирования (обязательный аргумент)

Диапазон ячеек для суммирования.

Диапазон_условия1 (обязательный аргумент)

Диапазон, в котором проверяется Условие1.

Диапазон_условия1 и Условие1 составляют пару, определяющую, к какому диапазону применяется определенное условие при поиске. Соответствующие значения найденных в этом диапазоне ячеек суммируются в пределах аргумента Диапазон_суммирования.

Условие1 (обязательный аргумент)

Условие, определяющее, какие ячейки суммируются в аргументе Диапазон_условия1. Например, условия могут вводится в следующем виде: 32, ">32", B4, "яблоки" или "32".

Диапазон_условия2, Условие2, … (необязательный аргумент)

Дополнительные диапазоны и условия для них. Можно ввести до 127 пар диапазонов и условий.

Примеры

Чтобы использовать эти примеры в Excel, выделите нужные данные в таблице, щелкните их правой кнопкой мыши и выберите команду Копировать. На новом листе щелкните правой кнопкой мыши ячейку A1 и в разделе Параметры вставки выберите команду Использовать форматы конечных ячеек.

=СУММЕСЛИМН(A2:A9; B2:B9; "=Я*"; C2:C9; "Артем")

Суммирует количество продуктов, названия которых начинаются с Я и которые были проданы продавцом Артем. Для поиска совпадающих названий продуктов в Criteria_range1 B2:B9 в группе Условия1 (=A*) используется поддиапный знак * и в Criteria_range2 C2:C9 — имя "Том". Затем функция суммирует соответствующие обоим условиям значения в диапазоне ячеек, заданном аргументом Диапазон_суммирования (A2:A9). Результат — 20.

=СУММЕСЛИМН(A2:A9; B2:B9; "<>Бананы"; C2:C9; "Артем")

Суммирует количество продуктов, которые не являются бананами и которые были проданы продавцом по имени Артем. Он исключает бананы, используя<>в критерии1, "<>Бананы"и ищет имя "Том" в Criteria_range2 C2:C9. Затем функция суммирует соответствующие обоим условиям значения в диапазоне ячеек, заданном аргументом Диапазон_суммирования (A2:A9). Результат — 30.

Распространенные неполадки

Вместо ожидаемого результата отображается 0 (нуль).

Если выполняется поиск текстовых значений, например имени человека, убедитесь в том, что значения аргументов Условие1, 2 заключены в кавычки.

Неверный результат возвращается в том случае, если диапазон ячеек, заданный аргументом Диапазон_суммирования, содержит значение ИСТИНА или ЛОЖЬ.

Значения ИСТИНА и ЛОЖЬ в диапазоне ячеек, заданных аргументом Диапазон_суммирования, оцениваются по-разному, что может приводить к непредвиденным результатам при их суммировании.

Ячейки в аргументе Диапазон_суммирования, которым присвоено значение ИСТИНА, оцениваются как 1. Ячейки, которым присвоено значение ЛОЖЬ, оцениваются как 0 (ноль).

Рекомендации

Использование подстановочных знаков

Подстановочные знаки, такие как вопросительный знак (?) или звездочка (*), в аргументах Условие1, 2 можно использовать для поиска сходных, но не совпадающих значений.

Вопросительный знак соответствует любому отдельно взятому символу. Звездочка — любой последовательности символов. Если требуется найти именно вопросительный знак или звездочку, следует ввести значок тильды (

) перед вопросительным знаком.

Например, формула =СУММЕСЛИМН(A2:A9; B2:B9; "=Я*"; C2:C9; "Арте?") будет суммировать все значения с именем, начинающимся на "Арте" и оканчивающимся любой буквой.

Различия между функциями СУММЕСЛИ и СУММЕСЛИМН

Порядок аргументов в функциях СУММЕСЛИ и СУММЕСЛИМН различается. Например, в функции СУММЕСЛИМН аргумент Диапазон_суммирования является первым, а в функции СУММЕСЛИ — третьим. Этот момент часто является источником проблем при использовании данных функций.

При копировании и изменении этих похожих формул нужно следить за правильным порядком аргументов.

Одинаковое количество строк и столбцов для аргументов, задающих диапазоны ячеек

Аргумент Диапазон_условия должен иметь то же количество строк и столбцов, что и аргумент Диапазон_суммирования.

У вас есть вопрос об определенной функции?

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

Функция СУММЕСЛИМН в Excel. Как использовать?

Функция СУММЕСЛИМН (SUMIFS) в Excel используется для суммирования значений по нескольким критериям. Если вы хотите суммировать значения по одному критерию, то лучше использовать функцию SUMIF (СУММЕСЛИ).

  1. Что возвращает функция
  2. Синтаксис
  3. Аргументы функции
  4. Дополнительная информация
  5. Примеры использования функции СУММЕСЛИМН в Excel

Что возвращает функция

Возвращает сумму чисел по нескольким критериям.

Синтаксис

=SUMIFS(sum_range, criteria_range1, criteria1, [criteria_range2, critertia2],…) – английская версия

=СУММЕСЛИМН(диапазон_суммирования; диапазон_условия1; условие1; [диапазон_условия2; условие2]; …) – русская версия

Аргументы функции

  • sum_range (диапазон_суммирования) – это диапазон данных, по которым будут вычисляться условия указанных вами критериев для суммирования данных;
  • criteria_range1 (диапазон_условия1), сriteria1 (условие1) – диапазон, в котором проверяется первое условие функции. Criteria_range1 (диапазон_условия1) и criteria1(условие1) составляют пару, определяющую, к какому диапазону применяется определенное условие при поиске. Соответствующие значения найденных в этом диапазоне ячеек суммируются в пределах аргумента sum_range (диапазон_суммирования).
  • [criteria_range2], criteria2([диапазон_условия2], условие 2) – (опционально) – второй диапазон критериев, по которым будут вычисляться данные;

Дополнительная информация

  • Суммирование значений в функции производится на основе нескольких критериев;
  • Пустые и текстовые ячейки игнорируются в аргументе sum_range (диапазон_суммирования);
  • Критерием могут служить числа, выражения, ссылка на ячейку, текст или формула;
  • Критерий, указанный в текстовом или логическом/математическом формате (=,+,-,/,*) должны быть указаны в двойных кавычках;
  • В качестве критерия могут использоваться подстановочные знаки (*);
  • Критерий не может быть больше чем 255 символов по длине;
  • Ячейки в аргументе sum_range (диапазон_суммирования) суммируются только при выполнении всех условий, заданных в формуле;
  • Если среди значений аргумента sum_range (диапазон_суммирования) указано логическое значение TRUE или FALSE, то они подразумевают значения “1” и “0” соответственно;
  • Диапазон аргументов sum_range (диапазон_суммирования) и всех критериев должны совпадать.

Примеры использования функции СУММЕСЛИМН в Excel

Функция SUMIFS (СУММЕСЛИМН) в Excel

Еще больше полезных приемов в работе со списками данных и функциями в Excel вы узнаете в практическом курсе “От новичка до мастера Excel“. Успей зарегистрироваться по ссылке!

Ссылка на основную публикацию