Как убрать нули в ячейках excel
Перейти к содержимому

Как убрать нули в ячейках excel

Как избавиться от начальных и конечных нулей в Excel

Соавтор(ы): Nicole Levine, MFA. Николь Левин — автор и редактор, пишущий о технологиях для wikiHow. Имеет более 20 лет опыта в написании технической документации и руководстве командами технической поддержки в крупных компаниях, занимающихся веб-хостингом и разработкой программного обеспечения. Получила магистерскую степень по писательскому мастерству в Портлендском государственном университете и преподает композицию, литературное творчество и создание фэнзинов в различных учебных заведениях.

Скрытие значений в EXCEL равных 0

history 25 апреля 2013 г.
    Группы статей
  • Значение Пустой текст ("")
  • Пользовательский формат
  • Условное форматирование
  • Условное Форматирование Числовых значений
  • Пользовательский Формат Числовых значений

Иногда требуется скрыть значения равные 0. Сделаем это несколькими способами.

Скрыть значения равные 0 во всех ячейках на листе можно через Параметры MS EXCEL (далее нажмите Дополнительно/ Раздел Показать параметры для следующего листа/ , затем снять галочку Показывать нули в ячейках, которые содержат нулевые значения ).

Скрыть значения равные 0 в отдельных ячейках можно используя пользовательский формат, Условное форматирование или значение Пустой текст ("") .

Пользовательский формат

Пользовательский формат вводим через диалоговое окно Формат ячеек .

  • для вызова окна Формат ячеек нажмите CTRL+1 ;
  • выберите (все форматы).
  • в поле Тип введите формат # ##0,00;-# ##0,00;

Применение вышеуказанного формата не влияет на вычисления. В Строке формул , по-прежнему, будет отображаться 0, хотя в ячейке ничего не будет отображаться.

Условное форматирование

Используя Условное форматирование , также можно добиться практически такого же результата.

  • выделите интересующий диапазон;
  • в меню выберите Главная/ Стили/ Условное форматирование/ Правила выделения ячеек/ Равно );
  • в левом поле введите 0;
  • в правом поле выберите пользовательский формат (белый цвет шрифта);

Теперь нулевые значения отображаются белым шрифтом и не видны на стандартном белом фоне.

Если фон поменять, то нули станут снова видны, в отличие от варианта с пользовательским форматом, который не зависит от фона ячейки. Даже если просто выделить диапазон, то нулевые ячейки будут слегка видны.

Значение Пустой текст ("")

Замечательным свойством значения Пустой текст является, то что оно не отображается в ячейке (например, введите формулу ="" ). Записав, например, в ячейке B1 формулу =ЕСЛИ(A1;A1;"") получим пустую ячейку В1 в случае, если в А1 находится значение =0. Столбец А можно скрыть.

Добавить комментарий

Ваш адрес email не будет опубликован.