Как создать список дел в excel

Создаем список дел в MS Excel

Сегодня мы научимся создавать в MS Excel “чеклист” или, если по-русски, список дел. Список дел в Excel – с этим вы наверняка уже сталкивались в попытках организовать работу. Обычно люди выделяют цветом сделанные/несделанные дела, “зачеркивают” пункты списка… но все это слишком долго, да и просто неудобно.

Гораздо проще все это можно реализовать с помощью “галочек” – установки и снятия т.н. “флажков”. Ну, а чтобы все не было так просто, мы сделаем наш список дел более функциональным: снабдим внутренним счетчиком и счетчиком выполнения задач.

Расставляем флажки в MS Excel

Сначала создадим простейшую таблицу со списком дел. Затем перейдем на вкладку “Разработчик” и в группе “Элементы управления” активируем инструмент “Вставка” и выберем пункт “Флажок”. Как только флажок окажется помещенным на листе, сотрите ненужную подпись и поставьте его в выбранную ячейку.

Использование

Использование “флажков” в Excel

Теперь протяните ячейку с флажком за уголок до конца “списка дел”, и такие же “флажки” появятся во всех остальных ячейках столбца. Итак шаблончик будущего списка дел готов – можно даже щелкать по флажкам уже сейчас, расставляя галочки… только вот удовольствия и пользы от этого никакого, верно? Давайте её добавим!

Протягиваем ячейку MS Excel, чтобы заполнить все другие ячейки столбца тем же содержимым

Протягиваем ячейку MS Excel, чтобы заполнить все другие ячейки столбца тем же содержимым

Заготовка списка дел в MS Excel

Заготовка списка дел в MS Excel

Список дел с зависимостями в MS Excel

Щелкаем правой кнопкой мыши по первому элементу-флажку, и выбираем самый нижний пункт из выпадающего меню: “Формат объекта”.

Список дел с в экселе

Формат ячеек в MS Excel

В появившемся окне “Форматирование объекта” щелкните в поле “Связь с ячейкой”, а затем, щелкните на соседнюю ячейку справа от текущей. Тот же фокус нужно проделать для всех остальных флажков, создав пары с соседней ячейкой.

Создаем связь с ячейкой в MS Excel

Создаем связь с ячейкой в MS Excel

Обратите внимание: если поставить галочку на одном из флажков, в “связанной” ячейке появится надпись: “истина” если “галочка” установлена или “ложь”, если снята. Пока запомним это просто как интересный факт, и двинемся дальше.

связанные ячейки таблицы эксель

Теперь активация флажков-галочек меняет состояние в связанных с ними ячейках таблицы

Функция СЧЕТЕСЛИ

Ну а теперь немого функций и математики. В “список дел” я добавляю ещё 2 строки: число задач вообще, и число задач, которые уже выполнены. Обе строи заполняются данными автоматически, а помогает им в этом встроенная Excel-функция СЧЕТЕСЛИ. Работает она просто:

=СЧЁТЕСЛИ( диапазон_ячеек ; критерий_работы )

Как посчитать все выполненные задачи? Задать в качестве критерия работы функции положение “ИСТИНА” в третьей колонке (как вы помните, положение зависит от того – стоит галочка или нет).

А как посчитать все задачи (и выполненные и невыполненные) сразу? Сначала посчитать по отдельности количество значений “ЛОЖЬ” и “ИСТИНА”, а затем сложить результат.

Считаем задачи в нашем excel-списке дел

Считаем задачи в нашем excel-списке дел

В общем и целом, наш список дел или список задач на день построенный в MS Excel, уже готов. Нужно только немного украсить его и сделать более опрятным.

Итоговый список задач в MS Excel

Первым делом скройте столбец “С” (истина/ложь), чтобы он не загромождал вид таблицы. А во вторых, давайте добавим “общий критерий эффективности”, то есть ещё одно поле – “можно ли переходить к следующему плану?”. Ёжику понятно, что переходить к следующему плану можно только после того, как выполнены все задания нынешнего. Или, перефразируя с языка логики на язык математики: когда пункты “всего задач” и “задач выполнено” нашего списка, равны друг другу!

Воспользуемся простой функцией условием =ЕСЛИ() и зададим исходные данные:

=ЕСЛИ(B8=B7 ; “Да” ; “НЕТ”)

Расшифровывается это просто: если значения равны, то вывести в ячейке слово “ДА”, если не равны, “НЕТ”. А результат будет выглядеть как у меня на примере ниже.

Готовый список задач сделанный в MS Excel.

Готовый список задач сделанный в MS Excel. Почти полностью автоматический и от того ещё более интересный 🙂

Обратите внимание только на одну деталь – зеленый цвет ячейки и белый цвет текста в ней. Эти элементы также не мои художества, а результат работы MS Excel, а вернее, принципов условного форматирования, о чем мы говорили с вами в одном из прошлых уроков.

Компьютер плюс

Список ExcelСоздание списков инструментами Excel дает возможность не только сделать этот процесс максимально быстрым, но и унифицировать написание тех или иных слов и терминов. Последнее непосредственно касается создания так называемых выпадающих списков.

Списки для сортировки и заполнения

Списки для сортировки и заполнения, это те списки, элементы которых располагаются в строгой последовательности, кроме того, они циклически повторяются. Примерами таких списков являются дни недели, месяца года и т.п.

Приложение Excel позволяет не вписывать в ячейки каждый раз следующий день недели. Достаточно один раз вписать в ячейку, например, понедельник и выполнить автоматическое заполнение данными последующих строк или столбцов при помощи мыши. Для этого цепляем мышью уголок ячейки и протягиваем его куда нам нужно.

дни недели

Изменять параметры такого списка можно в меню списки, которое открывается в основных параметрах Excel. Находим кнопку «Изменить списки» и нажимаем ее. В появившемся окне видны имеющиеся списки, также можно задавать новые. Для этого в окне «Элементы списка» нужно последовательно указать его части и «добавить» в списки. Также можно импортировать списки прямо с листа Excel, предварительно выделив необходимый диапазон.

Редактирование списка

Создание выпадающих списков

Выпадающие списки дают возможность не только вставлять в ячейку только заранее определенные значения, но и не дают возможности допустить ошибки при написании элементов этого списка. Чтобы в выпадающем окошке появлялся список нужно его предварительно создать. Это можно сделать как на открытом, так и на другом листе книги Excel.

Создание выпадающего списка с источником на этом же листе

Чтобы пользоваться выпадающим списком нужно сначала этот список создать. Создаем список на этом же (открытом) листе и проверяем правильность написания его составляющих. Затем выделяем ячейку или несколько ячеек, куда будем вставлять эти данные, открываем окошко «Проверка вводимых значений», которое открывается по прохождении следующего пути: данные/работа с данными/проверка данных.

создание выпадающего списка

В этом окне выбираем тип данных – список, в строке источник указываем диапазон ранее созданного списка-источника. Можно ввести этот диапазон с клавиатуры, но легче это сделать, просто выделив его мышью. После нажатия кнопки ОК увидим, возле нашей ячейки показывается стрелочка, при нажатии на которую выпадает наш перечень.

Создание выпадающего списка с источником на другом листе

Использование списка-источника, расположенного на том же активном листе, не совсем удобно, поскольку можно «нечаянно» изменить его содержимое. Поэтому предпочтительнее этот список «спрятать» на другом листе, а доступ к нему заблокировать.

В этом случае, описанным выше способом не обойтись, так как при открытом окне «Проверки…» мы не сможем попасть на другой лист, чтобы выделить или определить диапазон ячеек исходного списка. В этом случае пользуются назначением имени первоначальному списку.

Выполняем это так: создаем список данных на одном листе, затем выделяем его и присваиваем ему имя, кликаем последовательно вкладка формулы/присвоить имя (в разделе определенные имена), в открывшемся окне задаем имя списка. Если, предварительно мы не выделили список, то задаем диапазон его ячеек.

присвоение списку имени

Переходим к выпадающему перечню на другом листе. Выделяем ячейки рабочего поля редактор, в которые будем вставлять элементы списка, открываем окно проверки… . В типе данных указываем список, в источнике ставим знак равенства и имя требуемого списка.

источник по имени

Как скрыть лист с источником списка

Лист с источниками выпадающих списков желательно открывать как можно реже, дабы случайно не внести в него ненужные изменения. Для этого лист можно защитить паролем и скрыть его отображение. Для того, чтобы спрятать лист нужно кликнуть по его ярлычку правой клавишей мыши и в открывшемся перечне команд нажать скрыть.

скрыть лист

Таким образом Excel представляет большие возможности по созданию списков, даже по сравнению с текстовым процессором Word Office.

6 мыслей о “Создание списка в Excel”

Константин :

Excel использую часто, но с выпадающими списками пока не приходилось работать – в основном сводные таблицы с многоэтажными формулами, значения которых подтягиваются из разных листов и книг. Эта программа требует внимательного изучения, тогда в ней множество возможностей открывается, это удобный инструмент для работы с данными.

Александра Куриен :

Я с Excel работаю не часто, хотя понимаю, сколько возможностей дает эта программа.
Обязательно познакомлюсь с функцией “списки” поближе.
Тем более, что в последнее время начала использовать списки абсолютно везде: начиная от похода в магазин до глобальных планов на годы вперед.

admin :

На самом деле и я пользуюсь редко этой программой, только когда нужны большие таблицы и расчеты по ним. Ежедневно же общаюсь с документами Word.

Василий (iklife.ru) :

Отлично все написано. Было бы интересно я думаю проводить аналогии с Гугл таблицами работает все также как в windows , или есть отличия. Спасибо.

admin :

Да, надо посмотреть. Спасибо за совет!

Елена :

Отличная статья, помогла разобраться с созданием выпадающего списка, спасибо!

Ссылка на основную публикацию