Как сравнить текстовые значения в excel

Как в офисе.

excel-2013-12-535x535

Когда вы используете табличный процессор Excel (от Microsoft Office), кроме задач по сравнению числовых значений, часто необходимо бывает сравнить текстовые (или «строковые») данные в ячейках таблицы. Сделать это можно так: в Excel есть встроенныефункции сравнения, и если результат операции необходимо получить в виде цифрового или же логического значения нужно воспользоваться этим сравнением. Так же можно использовать и опции условного форматирования, это делается в том случае, когда результатом должно стать визуальное выделение всех совпадающих (или же несовпадающих) ячеек данной таблицы.

Воспользуемся встроенной функцией для сравнения ячеек СЧЁТЕСЛИ, когда нужно сравнить текстовые показатели в ячейках колонки таблицы непосредственно с образцом текста и потом пересчитать все возможные совпадающие значения. Начинаем с заполнения конкретной колонки текстовыми значениями, потом делаем это в другой колонке и щелкаем ячейку, где вы хотите увидеть результат вашего подсчета, и там вводим соответствующую формулу. К примеру, если проверяемые показатели находятся в колонке типа «A», а результат нужно поместить в 1-ю ячейку колонки типа «C», то всё ее содержимое должно выглядеть так: =СЧЁТЕСЛИ($A:$A;"Виноград")."Виноград" здесь, это строковое значение, непосредственно с которым и сравниваются показатели всех ячеек данной колонки «A». Можно так же не указывать это в формуле, но поместить в свободную отдельную ячейку (в «B1», например) и вставить в формулу нужную ссылку: =СЧЁТЕСЛИ($A:$A;B1).

Дальше мы будем использовать опции условного форматирования, особенно, если нужно визуально выделить в конкретной таблице результаты сравнения строковых переменных. Так, если необходимо выделить в данной колонке ячейки «A», текст совпадающий с образцом находящимся в ячейке «B1», старайтесь начинать с выделения данной колонки, а для этогощелкните по её заголовку. Потом щелкните по кнопке «Условное форматирование», находящееся в группе команд типа «Стили», закладке «Главная» в программе Excel. Переходим в раздел под названием «Правила выделения ячеек» с выбором строки «Равно». Там указываем ячейку-образец (щелкаем по клетке «B1») и выбираем в выпадающем списке вариант для оформления совпадающих строк. Нажимаем кнопку «OK».

Тут нужно использовать комбинацию встроенных функций типа «ЕСЛИ» и «СЦЕПИТЬ» ипри необходимости сравниватьс данным образцом не одну, а несколько текстовых ячеек. Функция «СЦЕПИТЬ» будет соединять указанные ей значения непосредственно в одну строковую переменную. К примеру, команда типа «СЦЕПИТЬ» (шаг «A1» или «B1») в строке из ячейки типа «A1» добавит нужный текст " и «, ну а после него он поместит строку из другой ячейки, а именно из „ B1“. Сделанную таким способом строку можно затем сравнивать с образцом при помощи функции „ЕСЛИ“. Если сравнивать необходимо не одну строку, то удобнее дать имя (своё собственно) ячейке-образцу. Что бы это сделать щелкните ее, а потом влево от строки формулы вместо обозначения ячейки („C1“ например) наберите новое ее имя („образец“, к примеру). Затем нужно кликнуть ту ячейку, в которой и должен быть результат вашего сравнения, и вводим формулу такого типа:

ЕСЛИ(СЦЕПИТЬ(A1;» и ";B1)=образец;1;0)

Тут, единица -значение, которое станет содержать ячейка с формулой, когда сравнение даст вам положительный результат, а цифра ноль — то же самое, но для отрицательного результата. Размножать эту формулу ко всем строкам таблицы, которые необходимо сравнить с данным образцом очень легко — наведите курсор к правому нижнему углу ячейки и, в тот момент, когдакурсор изменится (он станет черным крестиком), нужно нажать на левую кнопку мышки и растянуть эту ячейку далеко вниз до последней из сравниваемых строк.

Как в Excel сравнить данные

Как в Excel сравнить данные

  • Как в Excel сравнить данные
  • Как выбрать максимальное значение из таблицы
  • Как удалить повторяющиеся значения в экселе
  • Табличный редактор Microsoft Office Excel 2007 или 2010.
  • Как в Excel найти совпадения
  • Как в Excel отсортировать данные
  • Как сравнить файлы
  • Что такое функция СРЗНАЧ в Excel и для чего она нужнаЧто такое функция СРЗНАЧ в Excel и для чего она нужна
  • Как увеличить аргументы функции "если" в ExcelКак увеличить аргументы функции
  • Как вычислять формулы в ExcelКак вычислять формулы в Excel
  • Как делать сравнительный анализКак делать сравнительный анализ
  • Как посчитать динамикуКак посчитать динамику
  • Как построить линейный графикКак построить линейный график
  • Как в Excel сделать формулуКак в Excel сделать формулу
  • Как в Excel сделать условиеКак в Excel сделать условие
  • Как записать данные в Excel из vbaКак записать данные в Excel из vba
  • Как в Excel составить таблицуКак в Excel составить таблицу
  • Как в Excel данные нескольких листов перенести в одинКак в Excel данные нескольких листов перенести в один
  • Как в Excel посчитать матрицуКак в Excel посчитать матрицу
  • Как в экселе объединить ячейкиКак в экселе объединить ячейки
  • Как в Excel найти текстКак в Excel найти текст
  • Как в excel построить зависимостьКак в excel построить зависимость
  • Как рассчитать удельный вес в процентахКак рассчитать удельный вес в процентах
  • Как посчитать в экселе с процентамиКак посчитать в экселе с процентами
  • Как отсортировать таблицуКак отсортировать таблицу
  • Как отсортировать массив по возрастаниюКак отсортировать массив по возрастанию
  • Как сделать выпадающий список в экселеКак сделать выпадающий список в экселе
  • Как в Excel вычитатьКак в Excel вычитать
  • Как в excel умножить столбцыКак в excel умножить столбцы
Ссылка на основную публикацию