Как суммировать по критерию в excel

Корпорация "Центр"

Функция СУММЕСЛИ() — Сложение с одним критерием в EXCEL (Часть1.ЧИСЛОвой критерий)

history 2 апреля 2013 г.
    Группы статей

  • Сумма

Для суммирования значений, удовлетворяющих заданному критерию (условию), используется функция СУММЕСЛИ() , английская версия SUMIF().

Синтаксис функции

СУММЕСЛИ ( Диапазон ; Условие ; [Диапазон_суммирования])

Диапазон — диапазон ячеек, в котором ищутся значения соответствующие аргументу Условие . Диапазон может содержать числа, даты, текстовые значения или ссылки на другие ячейки. В случае, если другой аргумент — Диапазон_суммирования — опущен, то аргумент Диапазон также является диапазоном, по которому производится суммирование значений удовлетворяющих аргументу Условие (в этом случае Диапазон должен содержать числа).

Условие — критерий в форме числа, выражения или текста, определяющий, какие ячейки должны суммироваться. Например, аргумент Условие может быть выражен как 32, "яблоки" или ">32".

Диапазон_суммирования — диапазон ячеек содержащий числа, которые будут просуммированы, в случае если соответствующие им ячейки, указанные в аргументе Диапазон соответствуют аргументу Условие . Диапазон_суммирования — необязательный аргумент. Если он опущен, то суммирование будет производиться по диапазону ячеек, указанному в аргументе Диапазон .

Примеры

Рассмотрим случай, когда аргумент Диапазон_суммирования опущен. В этом случае суммирование будет производиться по диапазону ячеек, указанному в первом аргументе Диапазон (т.е. он должен содержать числа). В нем же будет производиться поиск значений соответствующих аргументу Условие , которые затем и будут просуммированы. Пусть это будет диапазон B5:B15 , см. Файл примера .

  • найти сумму всех чисел больше или равных 10. Ответ: 175. Формула: =СУММЕСЛИ(B5:B15;">=10")
  • найти сумму всех чисел меньше или равных 10. Ответ: 42. Формула: =СУММЕСЛИ(B5:B15;"
  • найти сумму всех положительных чисел в диапазоне. Формула: =СУММЕСЛИ(B5:B15;">0") . Альтернативный вариант с использованием функции СУММПРОИЗВ() выглядит так : =СУММПРОИЗВ((B5:B15)*(B5:B15>0))

Форма задания условия (критерия) достаточно гибка. Например, в формуле =СУММЕСЛИ(B5:B15;D7&D8) критерий D7&D8 : в D7 содержится текстовое значение =СУММЕСЛИ(B5:B15;" =СУММЕСЛИ(B5:B15;" или =СУММЕСЛИ(B5:B15;" или =СУММЕСЛИ(B5:B15; D7 &56) .

В статье СУММЕСЛИ — Сложение по условию (один Текстовый критерий) рассмотрен более общий случай, когда критерий применяется к соседнему диапазону, содержащему текстовые значения, а суммирование производится только соответствующих ячеек из числового диапазона.

Функция СУММЕСЛИ

Функция СУММЕСЛИ используется, если необходимо просуммировать значения диапазон, соответствующие указанному критерию. Предположим, например, что в столбце с числами необходимо просуммировать только значения, превышающие 5. Для этого можно использовать следующую формулу: =СУММЕСЛИ(B2:B25;"> 5")

Корпорация "Центр"

Это видео — часть учебного курса Сложение чисел в Excel.

При необходимости условия можно применить к одному диапазону, а просуммировать соответствующие значения из другого диапазона. Например, формула =СУММЕСЛИ(B2:B5; "Иван"; C2:C5) суммирует только те значения из диапазона C2:C5, для которых соответствующие значения из диапазона B2:B5 равны "Иван".

Если необходимо выполнить суммирование ячеек в соответствии с несколькими условиями, используйте функцию СУММЕСЛИМН.

Важно: Функция СУММЕФ возвращает неправильные результаты, если она используется для поиска строк длиннее 255 символов или строки #VALUE!.

Синтаксис

СУММЕСЛИ(диапазон; условие; [диапазон_суммирования])

Аргументы функции СУММЕСЛИ описаны ниже.

Диапазон — обязательный аргумент. Диапазон ячеек, оцениваемых на соответствие условиям. Ячейки в каждом диапазоне должны содержать числа, имена, массивы или ссылки на числа. Пустые и текстовые значения игнорируются. Выбранный диапазон может содержать даты в стандартном формате Excel (см. примеры ниже).

Условие .Обязательный аргумент. Условие в форме числа, выражения, ссылки на ячейку, текста или функции, определяющее, какие ячейки необходимо суммировать. Можно использовать поддиавные знаки: вопросии (?), которые соответствуют любому отдельному символу, звездочка (*) — любой последовательности символов. Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак "тильда" (

Например, критерий может быть выражен как 32, ">32", B5, "3?", "яблок*", "*

Важно: Все текстовые условия и условия с логическими и математическими знаками необходимо заключать в двойные кавычки ( "). Если условием является число, использовать кавычки не требуется.

Диапазон_суммирования .Необязательный аргумент. Ячейки, значения из которых суммируются, если они отличаются от ячеек, указанных в качестве диапазона. Если аргумент диапазон_суммирования опущен, Excel суммирует ячейки, указанные в аргументе диапазон (те же ячейки, к которым применяется условие).

Sum_range должны быть того же размера и формы, что идиапазон. В этом случае производительность может пострадать, и формула суммирует диапазон ячеек, который начинается с первой ячейки в sum_range, но имеет те же измерения, что и диапазон. Например:

Корпорация "Центр"

Ссылка на основную публикацию