Как суммировать ячейки в excel с текстом

Как в excel сложить текстовые ячейки

Объединение текста и чисел

​Смотрите также​​ Randy Orton​просто попытайтесь в​ использовать пожалуй вариант​Если у кого-то​ несколько раз в​ ‘собираем текст из​ в одном -​ "7"). При его​ — текст из​ + муж =​ значения с одним​ грамматические ошибки. Для​ эффективно объединять диапазоны.​ текст и больше​ косой черты (\)​ образом. Можно отформатировать​Примечание:​Суммировать же буквы​ них разобраться​ с макросом, который​ еще есть варианты​

​ одной ячейке.​ ячеек Next rCell​ кнопка​ использовании необходимо помнить,​ всех ячеек всех​ любовь!»​ условием. Например, когда​ нас важно, чтобы​TEXTJOIN​ не функция числа​ в начале.​ ячейки, содержащие 15,​Мы стараемся как​ нельзя. Буквы можно​

Используйте числовой формат для отображения текста до или после числа в ячейке

​Алексей матевосов (alexm)​ прислал​ решения — милости​Пример (все это​ Application.DisplayAlerts = False​Объединить и поместить в​ что:​ диапазонов будет объединен​В категории​ необходимо для суммирования​ эта статья была​в Excel 2013​ становятся как числовые​Примечание:​ 100 и 200,​ можно оперативнее обеспечивать​

​ СЦЕПИТЬ. Типа А​: Допустим в ячейках​snipe​ просим)))​ — в одной​ ‘отключаем стандартное предупреждение​ центре (Merge and​Этот символ надо ставить​

​Текстовые​ определенного продукта total​

​ вам полезна. Просим​​ и более ранние​​ значения. Это означает,​​изменение встроенного формата​​ чтобы они отображались​

​ вас актуальными справочными​​ и В сидели​​ столбца с А1​​.​​snipe​ ячейке, в А2):​ о потере текста​ Center)​

​ в каждой точке​​Для массового объединения также​​есть функция​ sales.​ вас уделить пару​ версии не поддерживается.​

​ что больше не​ не приводит к​ на листе как​ материалами на вашем​ на трубе.​ по А10 числа,​Благодарю!​: Public Function iSumma(Текст​
​154 р. -​​ .Merge Across:=False ‘объединяем​в Excel объединять-то​ соединения, т.е. на​

​ удобно использовать новую​

​СЦЕПИТЬ (CONCATENATE)​

​При необходимости суммирование значений​

​ секунд и сообщить,​

​Примеры различных на рисунке​

​ может выполнять любые​ удалению формат.​ 15 # продукт,​ языке. Эта страница​В ячейке А1​ текст и пустые​Svsh2015​ As String) As​

​ булочки; 550 р.​ ячейки Application.DisplayAlerts =​

​ всех "стыках" текстовых​ функцию​, которая соединяет содержимое​ с помощью нескольких​ помогла ли она​

​ ниже.​ математических операций на​Для отображения​

​ переведена автоматически, поэтому​ буква А, в​ ячейки.​: Floyd73,добрый день,вариант функции​ Double Dim a()​ — мясо; 120​ True .Item(1).Value =​ вот с текстом​ строк также, как​ОБЪЕДИНИТЬ (TEXTJOIN)​ нескольких ячеек (до​

Объединение текста и чисел из разных ячеек в одной ячейке с помощью формулы

​ условий, используйте функцию​ вам, с помощью​Внимательно посмотрите на использование​ них.​Используйте код​ 200 # продукта.​ ее текст может​ ячейке В1 буква​Формула суммирования =СУММ​ uuu в A1​

​ As String a()​ р. — молоко;​ Mid(sMergeStr, 1 +​ сложность — в​ вы ставите несколько​, появившуюся начиная с​

​ 255) в одно​​ СУММЕСЛИМН . Например​

​ кнопок внизу страницы.​ функции​Для объединения чисел с​​Принцип действия​​Использование пользовательского числового формата​​ содержать неточности и​​ В​ (A1:A10)​​Function uuu(t$) Dim​​ = Split(Текст, ";")​ 65 р. -​ Len(sDELIM)) ‘добавляем к​​ живых остается только​​ плюсов при сложении​​ Excel 2016. У​​ целое, позволяя комбинировать​ нужно добавить вверх​ Для удобства также​

​текст​​ помощью функции СЦЕПИТЬ​12 как Продукт №12​ для отображения номера​ грамматические ошибки. Для​Формулы​Формула пропускает пустые​ i% With CreateObject("VBScript.RegExp"):​ For i =​ яблоки.​ объед.ячейке суммарный текст​​ текст из верхней​​ нескольких чисел (2+8+6+4+8)​ нее следующий синтаксис:​ их с произвольным​

Примеры

​ total sales определенного​ приводим ссылку на​

​во втором примере​ или функции ОБЪЕДИНЕНИЯ,​​"Продукт № " 0​​ с текстом, не​ нас важно, чтобы​=A1&B1 ( точно​ ячейки и с​ .Pattern = "\d+":​ 0 To UBound(a())​​Далее, из ячейки​​ End With End​ левой ячейки.​Если нужно приклеить произвольный​=ОБЪЕДИНИТЬ(Разделитель; Пропускать_ли_пустые_ячейки; Диапазон1; Диапазон2​ текстом. Например, вот​ продукта в рамках​ оригинал (на английском​ на рисунке. При​ текст и TEXTJOIN​Текст, заключенный в кавычки​ изменяя порядок сортировки​ эта статья была​​ как в считалке)​​ текстом. Суммирует только​

Примеры объединения текста и чисел

См. также

​ с такими данными​

Способы добавления значений на листе

​Чтобы объединение ячеек происходило​​ текст (даже если​ . )​ так:​ определенной области продаж.​ языке) .​ присоединении к числа​ и амперсанд (&)​ (включая пробел) отображается​ число. Таким образом​ вам полезна. Просим​=СЦЕПИТЬ (A1;B1)​ числовые значения.​ For i =​ asd = Mid(asd,​ нужно вытащить и​Теперь, если выделить несколько​ с объединением текста​ это всего лишь​где​Нюанс: не забудьте о​Общие сведения о том,​

​Один быстрый и простой​ в строку текста​ оператор.​ в ячейке перед​ изменение способа отображения​ вас уделить пару​Randy orton​Kleom​​ 0 To .Execute(t).Count​​ 1, InStr(1, asd,​​ сложить все числа,​​ ячеек и запустить​​ (как в таблицах​​ точка или пробел,​Разделитель​ пробелах между словами​ как сложение и​ для добавления значений​ с помощью оператор​Примечания:​ числом. В этом​

Используйте мастер автосуммирования для автоматического создания формулы СУММ. Выделите диапазон сверху/снизу или справа/слева от суммируемого диапазона, затем на ленте откройте вкладку ​ номера без изменения​

​ секунд и сообщить,​: Вот: =СЧЁТЗ (A1:A3)​: что значит буквенное?​ — 1 uuu​ " ") -​ в ячейке, например,​ этот макрос с​

Добавление на основе условий

​ Word) придется использовать​ не говоря уж​- символ, который​ — их надо​ вычитание дат можно​ в Excel всего​ объединения, используйте функцию​

​ ​ коде "0" обозначает​ значения.​ помогла ли она​ В скобках диапазон​ если числа написаны​ = uuu +​ 1) iSumma =​

Сложение или вычитание дат

​ А1.​ помощью сочетания клавиш​ макрос. Для этого​ о целом слове),​ будет вставлен между​ прописывать как отдельные​ найти Добавление и​ воспользоваться функцией Автосумма.​текст​

Сложение и вычитание значений времени

​В Excel 2016Excel Mobile и​ число, которое содержится​Выполните следующие действия.​ вам, с помощью​ укажи.​ словами, то придется​ .Execute(t)(i) Next End​ iSumma + CDbl(asd)​Т.е. в А1​

3 способа склеить текст из нескольких ячеек

​ Alt+F8 или кнопкой​ откройте редактор Visual​ то этот текст​ фрагментами​ аргументы и заключать​
​ вычитание дат. Более​ Выделите пустую ячейку​, чтобы управлять​ Excel Online с​
​ в ячейке (например,​Выделите ячейки, формат которых​ кнопок внизу страницы.​
​Pulse​ сначала их вручную​ With End Function​

Способ 1. Функции СЦЕПИТЬ, СЦЕП и ОБЪЕДИНИТЬ

​ Next i End​​ должно получиться число​​Макросы​​ Basic на вкладке​​ надо заключать в​Второй аргумент отвечает за​ в скобки, ибо​ сложные вычисления с​ непосредственно под столбцом​ способом отображения чисел.​ помощью функции​

Склейка текста функцией СЦЕПИТЬ

​ 12).​ требуется изменить.​ Для удобства также​: Нужно, чтобы складывались​ ввести в числовом​Svsh2015​ Function​

​ 889.​на вкладке Разработчик​Разработчик -​ кавычки. В предыдущем​ то, нужно ли​ текст.​ датами, читайте в​ данных. На вкладке​ В формуле используется​ОБЪЕДИНЕНИЯ​12:00 как 12:00 центральноевропейское​​На вкладке​​ приводим ссылку на​ только те ячейки​ виде, а потом​: добавлю еще вариант​AlexM​​Получается, у нас​​(Developer — Macros)​Visual Basic (Developer -​ примере с функцией​ игнорировать пустые ячейки​Очевидно, что если нужно​ статье даты и​ "​ базовое значение из​заменена​ время​

Склейка функцией СЦЕП

​Главная​ оригинал (на английском​ в которых содержится​​ складывать, иначе никак. ​​ функции,в файл примере​: Можно массивной формулой​ ячейка А1 -​

​, то Excel объединит​ Visual Basic)​

​ СЦЕПИТЬ о кавычках​

  • ​ (ИСТИНА или ЛОЖЬ)​​ собрать много фрагментов,​ операций со временем.​формулы​
  • ​ ячейки, на который​функции СЦЕПИТЬ​ч:мм "центральноевропейское время"​в группе​
  • ​ языке) .​​ числа. Т.е если​Demetry​ uuu (и есть​

​ Код =СУММ(—ЕСЛИ(ПРАВБ(ПСТР(A1;СТРОКА($1:$99);6);2)="р.";ПСТР(A1;СТРОКА($1:$99);3)))​

Склейка текста функцией ОБЪЕДИНИТЬ

Способ 2. Символ для склеивания текста (&)

​ итого, а ячейка​ выделенные ячейки в​или сочетанием клавиш​ заботится сам Excel​

​Диапазон 1, 2, 3​​ то использовать эту​​Общие сведения о том,​" нажмите кнопку​ указывает ссылка (в​​. Несмотря на​​Текущее время показано в​​число​​Предположим, что нужно создать​ в ячейке текст,​​: =СЧЁТЕСЛИ (A1:A100;"*н*")​​ uuu1)​Floyd73​ А2 — детализация.​ одну, слив туда​ Alt+F11, вставим в​

  • ​ — в этом​. — диапазоны​ функцию уже не​ как сложение и​Автосумма​ данном примере.4) —​ то, что функция​ формате даты/времени ч:мм​
  • ​щелкните стрелку.​ предложение грамматически правильные​ нужно, чтобы она​Считает в диапазоне​Function uuu#(t$) Dim​: Спасибо за столь​При небольшом гуглении​ же и текст​ нашу книгу новый​ же случае их​ ячеек, содержимое которых​ очень удобно, т.к.​ вычитание значений времени​>​ не форматированное значение,​

​СЦЕПИТЬ​ AM/PM, а текст​В списке​ из нескольких столбцов​ не учитывалась. Справку​

Сцепка текста амперсандом

​ от А1 до​ i%, s# With​ разнообразные варианты решений!​ варианта решения не​​ через пробелы.​​ программный модуль (меню​ надо ставить вручную.​ хотим склеить​

Склейка ФИО

Способ 3. Макрос для объединения ячеек без потери текста.

​ придется прописывать ссылки​ отображается Добавление и​Сумма​ отображаемое в ячейке​по-прежнему доступен для​ "московское время" отображается​категории​ данных для подготовки​​ смотрел, даже пример​ А100 количество ячеек,​ CreateObject("VBScript.RegExp"): .Pattern =​​Теперь думаю, какой​ нашел, может быть​Floyd73​Insert — Module​Вот, например, как можно​Например:​ на каждую ячейку-фрагмент​

​ вычитание значений времени.​. Excel автоматически будут​ (40%). Чтобы восстановить​ обеспечения обратной совместимости,​ после времени.​выберите категорию, например​ массовой рассылки. Или,​​ есть, но почему​ ​ в тексте которых​ "\d+": .Global =​​ из них удобнее​ неправильно формулирую запрос,​: День добрый!​) и скопируем туда​​ собрать ФИО в​​Это универсальный и компактный​ по отдельности. Поэтому,​ Другие вычисления времени,​

​ определения диапазона, который​ форматов чисел используйте​ следует использовать​-12 как -12р. дефицит​настраиваемые​ возможно, вам нужно​ то он у​ есть буква "н".​ True For i​ будет использовать)))​ конечно. ​Имеется небольшая задачка,​ текст такого простого​ одну ячейку из​ способ сцепки, работающий​ начиная с 2016​ можно просмотреть даты​ необходимо суммировать. (Автосумма​ функцию​ОБЪЕДИНЕНИЯ​ и 12 как​и нажмите кнопку встроенный​ форматирование чисел с​ меня не работает.​Алексей матевосов (alexm)​ = 0 To​Казанский​Подозреваю, что можно​

​ которую нужно реализовать​ макроса:​ трех с добавлением​ абсолютно во всех​ версии Excel, на​​ и операций со​​ также можно работать​​текст​​, так как​ 12р. избыток​ формат, который похож​ текстом, не затрагивая​_Boroda_​

Вытащить из ячейки числа и сложить их

​: После двух часового​​ .Execute(t).Count — 1​
​:​ сделать скриптом, но​ в экселе.​
​Sub MergeToOneCell() Const​ пробелов:​
​ версиях Excel.​ замену функции​ временем.​
​ по горизонтали при​.​функции СЦЕПИТЬ​0.00р. "избыток";-0.00р. "дефицит"​ на то, которое​ формулы, которые могут​: =СУММ(I3;I5;I7;I10)​ раздумья по данному​
​ s = s​Floyd73​ работать с ними​
​Суть задачки вот​ sDELIM As String​Если сочетать это с​
​Для​СЦЕПИТЬ​Надпись на заборе: «Катя​ выборе пустую ячейку​Функция СЦЕПИТЬ​могут быть недоступны​
​Это значение отображается в​ вы хотите.​ использовать эти числа.​Итог 43​ вопросу появилась желание​ + CDbl(.Execute(t)(i)) Next​
​, до кучи Function​ не умею =(​ в чем.​
​ = " "​ функцией извлечения из​суммирования​пришла ее более​
​ + Миша +​ справа от ячейки,​СЦЕП​ в будущих версиях​ формате "Денежный". Кроме​
​В поле​ В Excel существует​Справка вражеская. Там​ предложить организаторам проекта​
​ uuu = s​ Fl(x) As Double​
​Можно решить задачу​В ячейке, например,​

​ ‘символ-разделитель Dim rCell​​ текста первых букв​​содержимого нескольких ячеек​​ совершенная версия с​ Семён + Юра​ чтобы суммировать.)​

​Функция ТЕКСТ​​ Excel.​
​ того, если в​Тип​ несколько способов для​ разделитель — запятая.​

​ "Вопросы и ответы"​​ End With End​ Dim y For​ обычными формулами?​ А2, записываются данные,​ As Range Dim​ -​ используют знак плюс​ похожим названием и​ + Дмитрий Васильевич​"Сумма"." />​Функция TEXTJOIN​TEXTJOIN​ ячейке находится положительное​измените коды числовых​ объединения текста и​

​ А у нас​​ усовершенствовать систему начисления​ Function​

​ Each y In​​Подскажите, пожалуйста, люди​ по следующему шаблону:​
​ sMergeStr As String​ЛЕВСИМВ (LEFT)​ "​

​ тем же синтаксисом​​ +​​Автосумма создает формулу для​​Примечание:​Объединение текста из​ значение (или 0),​ форматов в формате,​ чисел.​ — точка с​ баллов.​snipe​

​ Split(Replace(x, ",", "."),​​ добрые!​число, пробел, текст,​

​ If TypeName(Selection) <>​​, то можно получить​+​ — функция​товарищ Никитин +​​ вас, таким образом,​​Мы стараемся как​
​ нескольких диапазонах и/или​

​ после него будет​​ который вы хотите​Если столбец, который вы​
​ запятой.​Только за прочтения​:​ ";") Fl =​OLEGOFF​ пробел, тире, пробел,​ "Range" Then Exit​ фамилию с инициалами​", а для​СЦЕП (CONCAT)​

​ рыжий сантехник +​​ чтобы вас не​ можно оперативнее обеспечивать​ строки, а также​ показан текст "(излишек)",​
​ создать.​ хотите отсортировать содержит​Pulse​ таких вопросов начислять​Floyd73​ Fl + Val(y)​:​ текст, точка с​ Sub ‘если выделены​ одной формулой:​склеивания​. Ее принципиальное отличие​

​ Витенька + телемастер​​ требуется вводить текст.​​ вас актуальными справочными​​ разделитель, указанный между​ а если ячейка​Для отображения текста и​
​ числа и текст​:​ баллы, а за​
​, все присланные вам​ Next End Function​

Подскажите пожалуйста как в excel посчитать сумму если значение в ячейке буквенное но нужно сложить все ячейки.

​Floyd73​​ запятой (или точка),​ не ячейки -​Имеем текст в нескольких​содержимого ячеек используют​ в том, что​
​ Жора +​ Однако при желании​
​ материалами на вашем​ каждой парой значений,​ содержит отрицательное значение,​ чисел в ячейке,​

​ — 15 #​​_Boroda_​ ответ баллы умножать​ примеры заслуживают изучения​AlexM​, с помощью опции​ пробел (ставится после​ выходим With Selection​

​ ячейках и желание​​ знак "​
​ теперь в качестве​сволочь Редулов +​ введите формулу самостоятельно​ языке. Эта страница​ который будет добавляться​

Excel. Как сложить ячейки в excel , если в ячейках забита буква а не цифра ?

​ после него будет​​ заключите текст в​ продукта, продукт #100​, Спасибо! Выходит в​ на коэффициент.​ с целью понимания​: Вариант с макросом​ " Текст по​
​ точки с запятой,​ For Each rCell​ — объединить эти​&​ аргументов можно задавать​
​ не вспомнить имени,​ просматривать функцию сумм.​ переведена автоматически, поэтому​ текст. Если разделитель​
​ показан текст "(недостаток)".​ двойные кавычки (»​ и 200 #​ справке ошибка?!​И так. Ячейки,​
​помимо моей функции​ универсальный​ столбцам" можно так​ после точки не​
​ In .Cells sMergeStr​
​ ячейки в одну,​" (расположен на большинстве​
​ не одиночные ячейки,​

​ длинноволосый такой +​​Используйте функцию СУММЕСЛИ ,​ ее текст может​ пустую текстовую строку,​

Сложение ячеек содержащих текст (Сложение ячеек содержащих текст)

​При объединении чисел и​​ «), или чисел​ продукта — не​Pulse​ содержащие значения, можно​ вам предложены более​Floyd73​Floyd73​ ставится).​ = sMergeStr &​ слив туда же​ клавиатур на цифре​

​ а целые диапазоны​​ещё 19 мужиков​
​ если нужно суммировать​
​ содержать неточности и​ эта функция будет​ текста в ячейке,​ с помощью обратной​ может сортировать должным​

​: Капец!​​ считать, как показал​​ красивые решения​​: Всем спасибо, буду​: Спасибо за решение.​

Excel сумма если текст содержит

Функция СУММЕСЛИ используется, если необходимо просуммировать значения диапазон, соответствующие указанному критерию. Предположим, например, что в столбце с числами необходимо просуммировать только значения, превышающие 5. Для этого можно использовать следующую формулу: =СУММЕСЛИ(B2:B25;"> 5")

Это видео — часть учебного курса Сложение чисел в Excel.

При необходимости условия можно применить к одному диапазону, а просуммировать соответствующие значения из другого диапазона. Например, формула =СУММЕСЛИ(B2:B5; "Иван"; C2:C5) суммирует только те значения из диапазона C2:C5, для которых соответствующие значения из диапазона B2:B5 равны "Иван".

Если необходимо выполнить суммирование ячеек в соответствии с несколькими условиями, используйте функцию СУММЕСЛИМН.

Синтаксис

СУММЕСЛИ(диапазон; условие; [диапазон_суммирования])

Аргументы функции СУММЕСЛИ описаны ниже.

Диапазон — обязательный аргумент. Диапазон ячеек, оцениваемых на соответствие условиям. Ячейки в каждом диапазоне должны содержать числа, имена, массивы или ссылки на числа. Пустые и текстовые значения игнорируются. Выбранный диапазон может содержать даты в стандартном формате Excel (см. примеры ниже).

Условие .Обязательный аргумент. Условие в форме числа, выражения, ссылки на ячейку, текста или функции, определяющее, какие ячейки необходимо суммировать. Например, условие может быть представлено в таком виде: 32, ">32", B5, "32", "яблоки" или СЕГОДНЯ().

Важно: Все текстовые условия и условия с логическими и математическими знаками необходимо заключать в двойные кавычки ( "). Если условием является число, использовать кавычки не требуется.

Диапазон_суммирования .Необязательный аргумент. Ячейки, значения из которых суммируются, если они отличаются от ячеек, указанных в качестве диапазона. Если аргумент диапазон_суммирования опущен, Excel суммирует ячейки, указанные в аргументе диапазон (те же ячейки, к которым применяется условие).

В аргументе условие можно использовать подстановочные знаки: вопросительный знак ( ?) и звездочку ( *). Вопросительный знак соответствует одному любому символу, а звездочка — любой последовательности символов. Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак "тильда" (

Примечания

Функция СУММЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов или применяется к строке #ЗНАЧ!.

Аргумент диапазон_суммирования может не совпадать по размерам с аргументом диапазон. При определении фактических ячеек, подлежащих суммированию, в качестве начальной используется верхняя левая ячейка аргумента диапазон_суммирования, а затем суммируются ячейки части диапазона, соответствующей по размерам аргументу диапазон. Пример:

Для суммирования значений по одному диапазону на основе данных другого диапазона используется функция СУММЕСЛИ() . Рассмотрим случай, когда критерий применяется к диапазону содержащему текстовые значения.

Пусть дана таблица с перечнем наименований фруктов и их количеством (см. файл примера ).

Если в качестве диапазона, к которому применяется критерий, выступает диапазон с текстовыми значениями, то можно рассмотреть несколько типов задач суммирования:

  • суммирование значений, если соответствующие им ячейки в диапазоне поиска соответствуют критерию (простейший случай);
  • в критерии применяются подстановочные знаки (*, ?);
  • критерий сравнивается со значениями в диапазоне поиска с учетом РЕгиСтРА.

Рассмотрим эти задачи подробнее.

Значение соответствует критерию

Найдем количество всех значений "Яблоки", т.е. просуммируем значения из столбца Количество, для которых соответствующее значение из столбца Фрукты в точности равно "Яблоки" (без учета РЕГИСТРА).

Для подсчета используем формулу
=СУММЕСЛИ(A3:A13;"яблоки";B3:B13)

Критерий яблоки можно поместить в ячейку D5, тогда формулу можно переписать следующим образом:
=СУММЕСЛИ(A3:A13;D5;B3 :B13 )

В качестве диапазона суммирования можно указать лишь первую ячейку диапазона — функция СУММЕСЛИ() просуммирует все правильно:
=СУММЕСЛИ(A3:A13; D5 ;B3)

В критерии применяются подстановочные знаки (*, ?)

Просуммируем значения из столбца Количество, для которых соответствующее значение из столбца Фрукты содержит слово Яблоки (без учета РЕгиСТРА).

Для решения этой задачи используем подстановочные знаки (*, ?). Подход заключается в том, что для отбора текстовых значений в качестве критерия задается лишь часть текстовой строки. Например, для отбора всех ячеек, содержащих слова яблоки (свежие яблоки, яблоки местные и пр.) можно использовать критерии с подстановочным знаком * (звездочка). Для этого нужно использовать конструкцию *яблоки*.

Решение задачи выглядит следующим образом (учитываются значения содержащие слово яблоки в любом месте в диапазоне поиска):
=СУММЕСЛИ($A$3:$A$13;"*яблоки*";B3)

Альтернативный вариант без использования подстановочных знаков выглядит более сложно:
=СУММПРОИЗВ(B3:B13*НЕ(ЕОШ(ПОИСК("яблоки";A3:A13))))

Примеры, приведенные ниже, иллюстрируют другие применения подстановочных знаков.

Задача. Просуммировать значения, если соответствующие ячейки:

Задача

Критерий

Формула

Результат

Примечание

заканчиваются на слово яблоки, например, Свежие яблоки

11

Использован подстановочный знак * (перед значением)

начинаются на слово яблоки, например, яблоки местные

20

Использован подстановочный знак * (после значения)

начинаются с гру и содержат ровно 6 букв

= СУММЕСЛИ($A$3:$A$13; "гру. ";B3)

56

Использован подстановочный знак ?

Критерий сравнивается со значениями в диапазоне поиска с учетом РЕгиСТРА

Учет РЕгиСТра приводит к необходимости создания более сложных формул. Чаще всего используются формулы на основе функций НАЙТИ() и СОВПАД() учитывающих регистр.

Ниже приведены формулы для суммирования чисел, если соответствующие значения совпадают с критерием с учетом регистра.

Просуммировать значения, если соответствующие ячейки:

Критерий

Формула

Результат

Примечание

в точности равны Яблоки с учетом регистра

содержат значение Яблоки в любом месте текстовой строки с учетом регистра

= СУММ(ЕСЛИ( СОВПАД("Яблоки";A3:A13);1;0) *B3:B13)

В предыдущей статье мы рассмотрели синтаксис функции СУММЕСЛИ в Excel, теперь давайте закрепим знания на практике при помощи ряда примеров формулы СУММЕСЛИ:

СУММЕСЛИ в Excel примеры с логическими операторами (больше, меньше или равно)

Давайте рассмотрим несколько примеров формул СУММЕСЛИ, которые вы можете использовать для суммирования значений для условий больше чем, меньше чем или равно заданному значению.

Примечание . Обратите внимание, что в формулах Excel СУММЕСЛИ оператор сравнения, за которым следует число или текст, всегда должен быть заключен в двойные кавычки ("").

Пример формулы СУММЕСЛИ

Сумма, если больше

Суммирует значения больше 5 в ячейках A2:A10.

Сумма, если меньше

Суммирует значения в ячейках B2:B10, если соответствующая ячейка в столбце A не равна значению в ячейке D1.

Сумма если больше или равно

Суммирует значения, которые больше или равны 5 в диапазоне A2:A10.

Сумма если меньше или равно

Обратите внимание , что вам понадобятся разные формулы СУММЕСЛИ для точного и частичного совпадения, как показано в таблице ниже.

Пример формулы СУММЕСЛИ

Сумма, если равно

=СУММЕСЛИ(A2:A8; "бананы"; C2:C8)

Суммирует значения в ячейках C2:C8, если соответствующая ячейка в столбце A содержит точное слово «бананы» и никакие другие слова или символы. Ячейки, содержащие «зеленые бананы», «бананы зеленые» или «бананы!» не будут считаться.

=СУММЕСЛИ(A2:A8; "*бананы*"; C2:C8)

Суммирует значения в ячейках C2:C8, если соответствующая ячейка в столбце A содержит слово «бананы», отдельно или в сочетании с любыми другими словами. Ячейки, содержащие «зеленые бананы» или «бананы зеленые», будут учитываться для суммирования.

Сумма, если не равно

=СУММЕСЛИ(A2:A8; "<>бананы"; C2:C8)

Суммирует значения в ячейках C2:C8, если соответствующая ячейка в столбце A содержит любое значение, отличное от слова «бананы». Если ячейка содержит «бананы» вместе с некоторыми другими словами или символами, такими как «желтые бананы» или «бананы желтые», такие ячейки будут учитываться для суммирования.

=СУММЕСЛИ(A2:A8; "<>*бананы*"; C2:C8)

Суммирует значения в ячейках C2:C8, если соответствующая ячейка в столбце A не содержит слова «бананы», отдельно или в сочетании с любыми другими словами. Ячейки, содержащие «желтые бананы» или «бананы желтые», не суммируются.

Для получения дополнительной информации о частичном совпадении см. пункт СУММЕСЛИ примеры формул с подстановочными знаками.

А теперь, давайте посмотрим пример формулы «Сумма, если не равно» в действии. Как показано на изображении ниже, формула суммирует количество всех продуктов, кроме «Банана Дамский пальчик»:

=СУММЕСЛИ(A2:A8; "<>Банан Дамский пальчик"; C2:C8)

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с проверкой на неравенство

Примечание . Как и большинство других функций Excel, СУММЕСЛИ нечувствительна к регистру, что означает, что «<> бананы», «<> Бананы» и «<> БАНАНЫ» будут давать точно такой же результат.

СУММЕСЛИ в Excel примеры операторов сравнения со ссылками на ячейки

Если вы хотите получить более универсальную формулу Excel СУММЕСЛИ, вы можете заменить числовое или текстовое значение в критериях ссылкой на ячейку, например:

В этом случае вам не придется менять формулу СУММЕСЛИ, основанную на другом критерии – вы просто вводите новое значение в ссылочной ячейке.

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ, суммирование исключая значение в ячейке F1

Примечание. Когда вы используете логическое выражение с ссылкой на ячейку, вы должны использовать двойные кавычки (""), чтобы начать текстовую строку и амперсанд (&), чтобы объединить и завершить строку, например «<>» и F1.

Оператор «равенства» (=) можно не использовать до ссылки на ячейку, поэтому обе приведенные ниже формулы эквивалентны и правильны:

Формула 1: =СУММЕСЛИ(A2:A8; "=" & F1; C2:C8)

Формула 2: =СУММЕСЛИ(A2:A8; F1; C2:C8)

СУММЕСЛИ примеры формул с подстановочными знаками

Если вы намерены условно суммировать ячейки на основе «текстовых» критериев и хотите суммировать путем частичного совпадения, вам нужно использовать подстановочные знаки в формуле СУММЕСЛИ.

Доступны следующие подстановочные знаки:

Звездочка (*) — представляет любое количество символов

Знак вопроса (?) — представляет один символ в определенном месте

Пример 1. Суммирование значений, основанные на частичном совпадении

Предположим, вы хотите суммировать количество, относящиеся ко всем видам бананов. Следующие формулы СУММЕСЛИ будут очень эффективны в таких случаях:

=СУММЕСЛИ(A2:A8; "*бананы*";C2:C8) — критерий включает текст, заключенный в звездочки (*).

=СУММЕСЛИ(A2:A8; "*"&F1&"*"; C2:C8) — критерий включает ссылку на ячейку, заключенную в звездочки, обратите внимание на использование амперсанда (&) до и после ссылки на ячейку для конкатенации строки.

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с подстановочными знаками для суммирования по частичному совпадению

Если вы хотите считать только те ячейки, которые начинаются или заканчиваются определенным текстом, добавьте только один * до или после текста:

=СУММЕСЛИ(A2:A8; "бананы*"; C2:C8) — значения суммы в C2:C8, если соответствующая ячейка в столбце A начинается со слова «бананы».

=СУММЕСЛИ(A2:A8; "*бананы"; C2:C8) — значения суммы в C2:C8, если соответствующая ячейка в столбце A заканчивается словом «бананы».

Функция СУММЕСЛИ в Excel с примерами – Пример использования функции СУММЕСЛИ с текстовым условием

Пример 2. Суммирование по заданному количеству символов

Если вы хотите суммировать некоторые значения длиной в шесть букв, вы должны использовать следующую формулу:

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с условием суммирования, если длина текстовой строки в шесть букв

Пример 3. Сумма ячеек, соответствующих текстовым значениям

Если ваш рабочий лист содержит разные типы данных, и вы хотите только суммировать ячейки, соответствующие текстовым значениям, пригодится следующая формула СУММЕСЛИ:

=СУММЕСЛИ(A2:A8; "?*"; C2:C8) – суммирует значения из ячеек C2:C8, если соответствующая ячейка в столбце A содержит не менее 1 символа.

=СУММЕСЛИ(A2:A8; "*"; C2:C8) – учитывает пустые ячейки, содержащие строки нулевой длины, возвращаемые некоторыми другими формулами, например ="".

Обе приведенные выше формулы игнорируют нетекстовые значения, такие как ошибки, логические значения, числа и даты.

Пример 4. Использование * или ? как обычные символы

Если вы хотите использовать либо *, либо ? для обработки в функции СУММЕСЛИ как литерала, а не подстановочного знака, то используйте перед этим знаком тильду (

). Например, следующая формула СУММЕСЛИ просуммирует значения в ячейках C2:C8, если ячейка в столбце A в той же строке содержит знак вопроса:

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с суммированием значений, соответствующие знаку вопроса в другом столбце

СУММЕСЛИ в Excel примеры с датами

Как правило, функцию СУММЕСЛИ используют для условного суммирования значений на основе дат так же, как и с текстовыми и числовыми критериями.

Если вы хотите суммировать значения, соответствующие датам, которые больше или меньше указанной вами даты, используйте операторы сравнения, которые мы рассматривали выше. Ниже приведены примеры формул Excel СУММЕСЛИ с датами:

Пример формулы СУММЕСЛИ

Сумма по определенной дате

Суммирует значения в ячейках C2:C9, если соответствующая дата в столбце B равна 29.10.2017.

Сумма, если дата больше либо равна заданной в формуле дате

Суммирует значения в ячейках C2:C9, если соответствующая дата в столбце B больше или равна 29.10.2017.

Сумма, если дата больше даты, указанной в ячейке

Суммирует значения в ячейках C2:C9, если соответствующая дата в столбце B больше даты, указанной в ячейке F1.

Если вы хотите суммировать значения на основе текущей даты, вам необходимо использовать СУММЕСЛИ в сочетании с функцией СЕГОДНЯ(), как показано ниже:

Пример формулы СУММЕСЛИ

Суммирование значений, за текущую дату

=СУММЕСЛИ(B2:B9; СЕГОДНЯ (); C2:C9)

Суммирование значений, меньше текущей даты, то есть до сегодняшнего дня.

Суммирование значений за неделю от текущей даты. (т.е. сегодня + 7 дней).

Изображение ниже показывает, как вы можете использовать последнюю формулу, чтобы найти общее количество всех продуктов, которые будут отправлены через неделю:

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ с суммированием количества продуктов, которые будут отправлены через неделю

СУММЕСЛИ в заданном диапазоне дат

Если вам необходимо суммировать значения между двумя датами, то необходимо использовать комбинацию, а точнее разницу двух функций СУММЕСЛИ. В версиях старше Excel 2007 вы можете использовать функцию СУММЕСЛИМН, которая позволяет использовать несколько условий. Эту функцию мы рассмотрим в следующей статье. А так как данная статья посвящена функции СУММЕСЛИ, то приведем пример использования СУММЕСЛИ в диапазоне дат:

=СУММЕСЛИ(B2:B9; ">=01.11.2017"; C2:C9) — СУММЕСЛИ(B2:B9; ">=01.12.2017"; C2:C9)

Эта формула суммирует значения в ячейках C2:C9, если дата в столбце B находится между 1 ноября 2017 года и 30 ноября 2017, включительно.

Функция СУММЕСЛИ в Excel с примерами – Пример функции СУММЕСЛИ дата в диапазоне

Эта формула может показаться немного сложной с первого взгляда, но при более близком рассмотрении это выглядит довольно просто. Первая функция СУММЕСЛИ объединяет все ячейки в C2:C9, где соответствующая ячейка в столбце B больше или равна дате начала (в данном примере 1 ноября). Затем вам просто нужно вычесть значения, которые попадают после даты окончания (30 ноября), с помощью второй функции СУММЕСЛИ.

В данной статье мы разобрали множество примеров функции СУММЕСЛИ с разными условиями, такими как числовые, текстовые, даты и другие. В следующей статье мы рассмотрим функцию СУММЕСЛИМН, которая является аналогом функции СУММЕСЛИ с несколькими условиями.

Ссылка на основную публикацию