Функция если в excel как задать условие что ячейка не пустая

Использование функции ЕСЛИ для проверки ячейки на наличие символов

Иногда требуется проверить, пуста ли ячейка. Обычно это делается, чтобы формула не выводила результат при отсутствии входного значения.

Ячейка E2 содержит формулу =ЕСЛИ(D2=1;

В данном случае мы используем ЕСЛИ вместе с функцией ЕПУСТО:

Эта формула означает: ЕСЛИ(ячейка D2 пуста, вернуть текст "Пустая", в противном случае вернуть текст "Не пустая"). Вы также можете легко использовать собственную формулу для состояния "Не пустая". В следующем примере вместо функции ЕПУСТО используются знаки "". "" — фактически означает "ничего".

Проверка пустоты ячейки — ячейка E2 содержит формулу =ЕСЛИ(ЕПУСТО(D2);

Эта формула означает: ЕСЛИ(в ячейке D3 ничего нет, вернуть текст "Пустая", в противном случае вернуть текст "Не пустая"). Вот пример распространенного способа использования знаков "", при котором формула не вычисляется, если зависимая ячейка пуста:

ЕСЛИ(в ячейке D3 ничего нет, не возвращать ничего, в противном случае вычислить формулу).

Функция ЕПУСТО() в EXCEL

history 16 декабря 2013 г.
    Группы статей

  • стандартные функции

Задача функции ЕПУСТО() , английский вариант ISBLANK(), — проверять есть ли в ячейке число, текстовое значение, формула или нет. Если в ячейке А1 имеется значение 555, то формула = ЕПУСТО(А1) вернет ЛОЖЬ, а если ячейка А1 пуста, то ИСТИНА.

Синтаксис функции ЕПУСТО()

ЕПУСТО ( значение )

Значение — значением может быть все что угодно: текст, число, ссылка, имя , пустая ячейка , значение ошибки, логическое выражение.

Использование функции

В файле примера приведены несколько вариантов проверок:

1. Если в проверяемой ячейке содержится число, текстовое значение, формула, то функция вернет логическое значение ИСТИНА.

2. Если проверяемая ячейка пуста, то функция также вернет логическое значение ЛОЖЬ.

Проверка диапазона ячеек

Функция ЕПУСТО() проверяет содержимое только одной ячейки. Чтобы подсчитать количество пустых ячеек в диапазоне, то используйте функцию СЧИТАТЬПУСТОТЫ() , но если ячейки содержат значение Пустой текст (""), то функция СЧИТАТЬПУСТОТЫ() будет подсчитывать также и эти ячейки наряду с действительно пустыми. Об этом читайте в статье Подсчет пустых ячеек .

Чтобы ответить на вопрос "Есть ли хотя бы 1 пустая ячейка в B6:B11?" используйте формулу массива

Чтобы ответить на вопрос "Есть ли хотя бы 1 заполненная ячейка в B6:B11?" используйте формулу массива

Ссылка на основную публикацию