Срзнач в excel как

Корпорация "Центр"

СРЗНАЧ (функция СРЗНАЧ)

В этой статье описаны синтаксис формулы и использование функции С AVERAGE в Microsoft Excel.

Описание

Возвращает среднее арифметическое аргументов. Например, если диапазон A1:A20 содержит числа, формула =СПБ(A1:A20) возвращает среднее из этих чисел.

Синтаксис

Аргументы функции СРЗНАЧ описаны ниже.

Число1 Обязательный аргумент. Первое число, ссылка на ячейку или диапазон, для которого требуется вычислить среднее значение.

Число2. Необязательный. Дополнительные числа, ссылки на ячейки или диапазоны, для которых нужно вычесть среднее значение, не более 255.

Замечания

Аргументы могут быть числами, именами или ссылками на диапазоны или ячейки, содержащие числа.

Логические значения и текстовые представления чисел, которые непосредственно введите в список аргументов, не учитываются.

Если аргумент является ссылкой на диапазон или ячейку, содержащую текст или логические значения, или ссылкой на пустую ячейку, то такие значения игнорируются; однако ячейки, которые содержат нулевые значения, учитываются.

Аргументы, являющиеся значениями ошибок или текстом, которые не могут быть преобразованы в числа, вызывают ошибки.

Если логические значения и текстовые представления чисел необходимо учитывать в расчетах, используйте функцию СРЗНАЧА.

Если требуется вычислить среднее значение только для тех значений, которые удовлетворяют определенным критериям, используйте функцию СРЗНАЧЕСЛИ или СРЗНАЧЕСЛИМН.

Примечание: Функция СРЗНАЧ вычисляет среднее значение, то есть центр набора чисел в статистическом распределении. Существует три наиболее распространенных способа определения среднего значения, описанных ниже.

Среднее значение — это среднее арифметическое, которое вычисляется путем сложения набора чисел с последующим делением полученной суммы на их количество. Например, средним значением для чисел 2, 3, 3, 5, 7 и 10 будет 5, которое является результатом деления их суммы, равной 30, на их количество, равное 6.

Медиана — это число, которое является серединой множества чисел, то есть половина чисел имеют значения большие, чем медиана, а половина чисел имеют значения меньшие, чем медиана. Например, медианой для чисел 2, 3, 3, 5, 7 и 10 будет 4.

Мода — это число, наиболее часто встречающееся в данном наборе чисел. Например, модой для чисел 2, 3, 3, 5, 7 и 10 будет 3.

Корпорация "Центр"

При симметричном распределении множества чисел все три значения центральной тенденции будут совпадать. При ассиметричном распределении множества чисел они могут отличаться.

Совет: При вычислении средних значений ячеек следует учитывать различие между пустыми ячейками и ячейками, содержащими нулевые значения, особенно если в диалоговом окне Параметры Excel настольного приложения Excel снят флажок Показывать нули в ячейках, которые содержат нулевые значения. Если этот флажок установлен, пустые ячейки игнорируются, но нулевые значения учитываются.

Местонахождение флажка Показывать нули в ячейках, которые содержат нулевые значения

Откройте вкладку Файл , а затем нажмите кнопку Параметры и в категории Дополнительно найдите группу Показать параметры для следующего листа.

Пример

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Функция СРЗНАЧ() — Среднее арифметическое в EXCEL

history 5 января 2013 г.
    Группы статей

  • Вычисление Среднего

Пусть дана таблица значений (см. файл примера ). Найдем среднее арифметическое значений ячеек таблицы.

Для решения этой задачи в EXCEL существует стандартная функция СРЗНАЧ() . Вычисления выполняются в соответствии с хорошо известной всем формулой:

где n — общее количество значений х.

Если значения расположены в диапазоне A 5: A 15 , то формула для вычисления среднего (среднего арифметического) будет выглядеть так:

Функция СРЗНАЧ() может в качестве аргумента воспринимать несколько ссылок на различные диапазоны: формула =СРЗНАЧ(A5:A11;A12:A15) вернет тот же результат, что и предыдущая формула.

Если в массиве есть числа в текстовом формате

В случае, если число введено в ячейку с текстовым форматом (см. ячейку А6 ), то это значение воспринимается функцией СРЗНАЧ() как текст и игнорируется. Поэтому, не смотря на то, что в диапазоне A 5: A 15 11 значений, для функции СРЗНАЧ() их всего 10, т.е. n в этом случае =10. Среднее будет равно 20,4 (см. файл примера ).

Функция СРЗНАЧA() ведет себя по другому: числа в текстовом формате интерпретируются ею как 0, впрочем, как и все остальные текстовые значения, включая значение Пустой текст "" . Поэтому, для функции СРЗНАЧА() n =11, а среднее будет равно 18,545454.

Чтобы числа в текстовом формате также учитывались при вычислении среднего, то нужно записать формулу массива =СРЗНАЧ(A5:A15+0) . В этом случае среднее будет равно 18,818181, т.к. n=11, а число в текстовом формате будет интерпретировано как 3.

Примечание : о вычислении средневзвешенного значения см. статью Средневзвешенная цена в MS EXCEL

Корпорация "Центр"

Ссылка на основную публикацию